Layout switching overlaps all other hotkeys

Forum rules
Before you post please read how to get help
Post Reply
Piterpog
Level 1
Level 1
Posts: 2
Joined: Sun Jul 15, 2018 5:04 am

Layout switching overlaps all other hotkeys

Post by Piterpog » Sat Jul 21, 2018 7:09 am

Hello, everyone.
Please help me to resolve an annoying problem. I got Linux Mint 19 Tara xfce, without compiz. My keyboard is set to switch language using the left ctrl + shift. Besides any other commands don't work using that keys.
For example, the function of pasting to terminal doesn't work using ctrl +shift +v.
When I press ctrl +shift, the changing of language occurs, and after I press the key V the letter V is typed in the language switched.
Please help me to fix the issue. Don't suggest to change hot keys of switching lang or to change all hot keys in operation system.
This is my layout settings:
http://i.imgur.com/ogAq9oU.png

User avatar
mint4all
Level 2
Level 2
Posts: 86
Joined: Tue Feb 13, 2018 1:16 pm

Re: Layout switching overlaps all other hotkeys

Post by mint4all » Sun Jul 22, 2018 2:15 pm

Greetings, and welcome to Linux Mint :)

After some searching i found that the xfce4-terminal doesn't appear to have an option to circumvent linux' ctrl-shift-v shortcut. Of course, that shortcut could be changed to something else, but that would affect your entire system ... So, unfortunately for you, the keyboard-layout switch-shortcut you have chosen (ctrl-shift) is being preempted by the system; i assume that it has a higher interrupt priority than the terminal's paste command. I am curious, though: xfce offers you 35 alternative shortcuts to switch your keyboard layout (including some that are key-press toggles). Isn't there another one you might/could chose?

In any event, you do have Linux' middle-click (3rd mouse button, or scroll wheel nowadays) paste option that works just dandy in terminal and across all Linux apps i've used over time. Perhaps someone else might give you a useful tip ...

Cheers, m4a

Post Reply

Return to “Xfce”