How to disable panel popups?

Forum rules
Before you post please read how to get help
Post Reply
johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

How to disable panel popups?

Post by johnywhy » Sun Jul 29, 2018 2:37 pm

Mint 19 xfce

How to disable panel popups, on mouse hover?
Screenshot_2018-07-29_11-35-01.png
Screenshot_2018-07-29_11-35-01.png (8.04 KiB) Viewed 229 times
Mint 19 xfce. Semi-noob

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: How to disable panel popups?

Post by mint4all » Sun Jul 29, 2018 3:40 pm

Greetings! The easy fix is to adjust the "Properties" of the panel's app-launch buttons. As you can see from the attached snapshot, simply check the "Disable tooltips" option (a button's "Advanced" properties).
LauncherAdvanced.png
LauncherAdvanced.png (32.06 KiB) Viewed 219 times
Cheers, m4a

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: How to disable panel popups?

Post by johnywhy » Sun Jul 29, 2018 3:46 pm

thx, that works!
but that's just for one launcher.
How to set globally, or at least for a whole panel?
Last edited by johnywhy on Sun Jul 29, 2018 3:53 pm, edited 1 time in total.
Mint 19 xfce. Semi-noob

User avatar
richyrich
Level 18
Level 18
Posts: 8970
Joined: Mon May 04, 2009 8:31 pm

Re: How to disable panel popups?

Post by richyrich » Sun Jul 29, 2018 3:49 pm

Try this one . . right-click somewhere in the open desktop > choose "Desktop Settings" from the context menu. Go to the Icons tab, and un-check the "Show Icon Tooltips" checkbox.

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: How to disable panel popups?

Post by johnywhy » Sun Jul 29, 2018 3:54 pm

richyrich wrote:
Sun Jul 29, 2018 3:49 pm
Try this one . . right-click somewhere in the open desktop > choose "Desktop Settings" from the context menu. Go to the Icons tab, and un-check the "Show Icon Tooltips" checkbox.
Have you tried that yourself?
doesn't work for me-- seems to be for desktop icons, not panel launchers.
thx tho!
Mint 19 xfce. Semi-noob

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: How to disable panel popups?

Post by mint4all » Sun Jul 29, 2018 6:56 pm

The "generic" solution is being discussed @ https://forum.xfce.org/viewtopic.php?id=7714 ... Fwiw, it might just do the trick, or might not -- so just be cautious as it might adversely affect some apps (like chromium). For that reason, imho i prefer the single-button option. Also noted should be the fact that this is a fix for widgets that were designed for gtk2-based styles/themes; therefore, migrating to gtk3 (now or later, ie via xfce 4.14 if and when it becomes available) may turn out to be problematic ... who knows :?

Cheers, m4a

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: How to disable panel popups?

Post by johnywhy » Sun Jul 29, 2018 7:14 pm

mint4all wrote:
Sun Jul 29, 2018 6:56 pm
migrating to gtk3 (now or later, ie via xfce 4.14 if and when it becomes available) may turn out to be problematic
you mean wrt the "generic" solution being discussed @ https://forum.xfce.org/viewtopic.php?id=7714 ?

thx`
Mint 19 xfce. Semi-noob

Post Reply

Return to “Xfce”