Xcfe open File Manager & Minimize Desktop shortcuts - [ closed in Frustration, nothing works right ]

Forum rules
Before you post please read how to get help
Post Reply
User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Xcfe open File Manager & Minimize Desktop shortcuts - [ closed in Frustration, nothing works right ]

Post by AZgl1500 » Mon Jul 30, 2018 12:21 pm

on nearly all of the OSs that i use, the "Windows Key" plus E will start up the File Manager

and the "Windows Key" plus D will minimize the entire Desktop.

that is not working in Xcfe, why not?

I am aware that I can use AutoKey to make it work, but why should I have to?
Last edited by AZgl1500 on Wed Aug 01, 2018 8:36 pm, edited 1 time in total.

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by mint4all » Mon Jul 30, 2018 3:34 pm

Greetings!

Question: have you explored the "keyboard shortcuts" that XFCE comes with (by default, i assume)? For example: the existing "ctrl-alt-d" shortcut does exactly with your "windows-d" shortcut does, namely to minimize all apps running on the desktop (or, conversely, restore them to their prior state). You could easily remap this to the "windows-d" shortcut; likewise, setting up a new "windows-e" shortcut to launch the file manager (Thunar) is not complicated at all. I'd be glad to walk you through this if you like ...

Cheers, m4a

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Mon Jul 30, 2018 3:52 pm

mint4all wrote:
Mon Jul 30, 2018 3:34 pm
Greetings!

Question: have you explored the "keyboard shortcuts" that XFCE comes with (by default, i assume)? For example: the existing "ctrl-alt-d" shortcut does exactly with your "windows-d" shortcut does, namely to minimize all apps running on the desktop (or, conversely, restore them to their prior state). You could easily remap this to the "windows-d" shortcut; likewise, setting up a new "windows-e" shortcut to launch the file manager (Thunar) is not complicated at all. I'd be glad to walk you through this if you like ...

Cheers, m4a
No, have not read anything on xcfe as of yet, just installed it as a 2nd OS on this dual boot laptop.

right now, all I really want is to get those two functions "to normal" ala the way I have always used them :D

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Mon Jul 30, 2018 4:02 pm

I looked at this and it doesn't seem what I want.

viewtopic.php?t=108803

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Mon Jul 30, 2018 4:10 pm

I found this, and I can't change the entry


Image

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by mint4all » Mon Jul 30, 2018 8:28 pm

First, let's "remap" the XFCE-shortcut for showing the desktop (aka "minimize all apps"), ctrl-alt-d, to what you want, the "windows-d" shortcut. Note: in linux parlance, the "Windows"-key is often referred to as the "Super"-key. I just tested the following steps:

Whisker-Menu > All Settings > Windows Manager > Keyboard {tab} > Scroll to & click on the "Show desktop" shortcut > Click Edit button > Press the desired key sequence (such as Super-d) > Click Save button. Done. Now your XFCE-default shortcut has changed from ctrl-alt-d to the familiar windows shortcut, super-d.

Setting up a NEW shortcut to bring up XFCE's file manager will take a little more work. I'm testing those steps now ...

Cheers, m4a

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Mon Jul 30, 2018 8:56 pm

My Windows Manager does not have a SAVE button, it has a Close button.

I did a reboot and it shows Super-D is the command, but it is not working.

Ctl-Alt-D is still doing that job. :(

Image

Thank you for your time on this.
John

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by mint4all » Tue Jul 31, 2018 3:21 pm

AZgl1500 wrote:
Mon Jul 30, 2018 8:56 pm
My Windows Manager does not have a SAVE button, it has a Close button.

I did a reboot and it shows Super-D is the command, but it is not working.

Ctl-Alt-D is still doing that job. :(

Thank you for your time on this.
John
You are welcome! I was able to duplicate your problem (Super-D shortcut not working as intended) on my every-day LM18.3-XFCE workhorse. Afaict, the cause is an old gotcha: this distro ships with the "Super_L" shortcut being mapped to pop up XFCE's whisker-menu. As long as that mapping is in place, the system appears to throw away (ignore) any 2nd or 3rd keypress while the Super_L key remains pressed -- something i completely forgot about, and apologize for not mentioning, until now ...

Deja-vu: I found this very "feature" quite annoying when i switched to XFCE a long time ago, ~ 3-4 years or such. Back then i figured a way around this problem by assigning my keyboards' unused "Menu" key to popping up the whisker-menu, a tweak i've since been putting on all my XFCE-systems. Ime, the following will take care of it: (1) with thunar, navigate to the /.config/xfce4/xfconf/xfce-perchannel-xml/ folder, (2) edit the xfce4-keyboard-shortcuts.xml file, (3) locate the following line (#42 on my system)
<property name="Super_L" type="string" value="xfce4-popup-whiskermenu"/>
, (4) change it to
<property name="Menu" type="string" value="xfce4-popup-whiskermenu"/>
, then (5) save your edit, close all open apps, logout, and login again.

Now your "menu" key shold pop up the whisket-menu, and your Super-D shortcut should do its job. Let me know how it goes ..

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Tue Jul 31, 2018 3:58 pm

Okay,
did all that,
Super does not bring up the Main Menu,
and Super+D does not show the Desktop

Super+L now does nothing as I would expect.

here is the change, it was line 38 for me


Image


FWIW, my Xcfe ISO is a very recent download, and checksum matched.

and all updates have been applied.

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by mint4all » Wed Aug 01, 2018 4:43 pm

My LM18.3-XFCE system is working ok with the {new} keyboard shortcuts you had suggested: "super+d" to show the desktop (actually a minimize-all / restore-all apps), and "super-e" to open xfce's {explorer-type} file manager, thunar. To get the shortcut to thunar to work, i added the following line to the ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file:
AddThunarToShortcuts.png
(see last/bottom line).

For some strange reasons, neither shortcut would work for me until i repeated my fix for the "windows+d" (aka "super+d) shortcut @ viewtopic.php?f=57&t=274567#p1504620 using xfce's settings manager. Somehow, there must be an undocumented shortcut dependency (a quirk?) with xfce's original/default "Super_L" shortcut (the keyboards left-side "windows" key) that seems to require this extra step.

Cheers, m4a

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Wed Aug 01, 2018 5:50 pm

This is getting to be so frustrating.

Once I select Window Manager and clear the Super-L or Super-D after I modified it,
that is the last time that Window Manager will come up.

it is no longer accessible.

I re-edited the keyboard file and repasted the fixed for Super-D and saved it back.

nothing.

Ctl-Alt-L does not work, Super-D does not work, Super-L does not work also.

never got far enough to try and make Super-E bring up Thunar....

so, I just formatted that partition and started all over.
and reinstalled Xcfe and it is exactly like it was, same exact issues.

I have to believe this is because I have Xcfe and Cinnamon sharing the same /home partition.
No matter what is on the desktop when I close one or the other OS, that exact app(s) come up on screen when I start the other OS... at first I thought that was super neat, is was useful until now.


this is making me begin to hate the idea of sharing /home as it is screwing up the other OS that is also sharing it.

User avatar
mint4all
Level 2
Level 2
Posts: 74
Joined: Tue Feb 13, 2018 1:16 pm

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by mint4all » Wed Aug 01, 2018 6:24 pm

Agreed -- this *IS* very frustrating, but an old issue afaik (see discussion @ viewtopic.php?t=102475 ) ... Thus far i didn't realize that your 2 desktops (cinnamon & xfce) in fact share (and co-update) your /home partition. As you may have noticed, this forum is rife with topics discussing quirks between different DEs using the same /home partition.

What gets even more difficult to trouble shoot is when one installs multiple DEs atop the same core system (trust me i've tried and failed multiple times at that -- notwithstanding Ubuntu's claims to the contrary). I wished it were much simpler, but some of the DEs (like cinnamon) mess with the underlying core OS which rarely can be undone.

With utmost respect for your choices, i'd put my bet on a fresh & pure LM18.3-xfce install (until LM19.1 comes out i'd wait because LM19.0 still has lots of problems as can be gleaned from ubuntu's 18.04.1 release notes re. xubuntu-issues).

Cheers, m4a

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Wed Aug 01, 2018 8:29 pm

Okay,
3rd install of Xcfe, this time set it to erase /dev/sda6 and only use the existing /swap partition.
going to forgo having it use the Cinnamon /home dedication partition on /dev/sda5

so far, so good, I think..... just now got Firefox setup to sync with my bookmarks so I could get back to here.

just set Super-D to "showdesktop" and did the Whiskermenu change.
going to log out, and back in and return to this thread.

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts

Post by AZgl1500 » Wed Aug 01, 2018 8:36 pm

Well,

I think I will abandon Xcfe, it just is not worth the effort.

nothing I do will change the way it works.

Super-D plainly shows up in Window Manager menu, but has no effect on how it works, other than, it deleted the default action that Ctl-Alt-L used to do....

so, I am closing this thread, and deleting Xcfe from the laptop.

User avatar
AZgl1500
Level 8
Level 8
Posts: 2283
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Xcfe open File Manager & Minimize Desktop shortcuts - [ closed in Frustration, nothing works right ]

Post by AZgl1500 » Thu Aug 02, 2018 12:21 am

I replaced Xcfe with LMDE3-Cindy

thread closed.

Post Reply

Return to “Xfce”