Can't Build xfce4-generic-slider

Forum rules
Before you post please read how to get help
Post Reply
johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Can't Build xfce4-generic-slider

Post by johnywhy » Fri Aug 10, 2018 3:05 pm

http://goodies.xfce.org/projects/panel- ... ric-slider

doc says:
it doesn't use Autoconf yet, you'll probably want to edit the Makefile. Right now it assumes plugins go in /usr/lib/xfce4/xfce4/panel-plugins and desktop files go in /usr/share/xfce4/panel-plugins. Changing that shouldn't be too hard. Then it is a simple:
make && sudo make install.
i get:

Code: Select all

$ make && sudo make install
make: *** No targets specified and no makefile found.  Stop.
got info here:
https://forum.xfce.org/viewtopic.php?pid=49251#p49251

I installed:

xfce4-dev-tools
glib2-devel

then i got:

Code: Select all

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /usr/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/
This post says i can ignore that:
https://askubuntu.com/a/58435

also getting:

Code: Select all

X Window system libraries and header files are required
did:

Code: Select all

apt-fast install xorg-dev
got:

Code: Select all

checking for libxfce4ui-1 >= 4.12.0... not found
*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.12.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
i can see in Synaptic that libxfce4ui-1 is installed.

i installed xfce4-panel-dev

did:

Code: Select all

export PKG_CONFIG_PATH="/usr/lib/pkgconfig:$PKG_CONFIG_PATH"
viewtopic.php?f=57&t=198801

got same libxfce4ui-1 error.

did:

Code: Select all

apt-fast install libgtk2.0-dev
got same libxfce4ui-1 error.

i did:

Code: Select all

locate pkg-config
/etc/dpkg/dpkg.cfg.d/pkg-config-hook-config
/usr/bin/i686-linux-gnu-pkg-config
/usr/bin/pkg-config
/usr/bin/x86_64-linux-gnu-pkg-config
/usr/bin/x86_64-pc-linux-gnu-pkg-config
/usr/lib/pkg-config.multiarch
/usr/share/pkg-config-crosswrapper
/usr/share/pkg-config-dpkghook
/usr/share/bash-completion/completions/pkg-config
/usr/share/doc/pkg-config
/usr/share/doc/pkg-config/AUTHORS
/usr/share/doc/pkg-config/NEWS.gz
/usr/share/doc/pkg-config/README
/usr/share/doc/pkg-config/changelog.Debian.gz
/usr/share/doc/pkg-config/copyright
/usr/share/doc/pkg-config/pkg-config-guide.html
/usr/share/lintian/data/files/pkg-config-bad-regex
/usr/share/man/man1/pkg-config.1.gz
/var/lib/dpkg/info/pkg-config.conffiles
/var/lib/dpkg/info/pkg-config.list
/var/lib/dpkg/info/pkg-config.md5sums
/var/lib/dpkg/info/pkg-config.postinst
/var/lib/dpkg/info/pkg-config.prerm


root@minty-boost:/mnt/D81CF64D1CF62662/Downloads/Linux/xfce4-generic-slider/xfce4-generic-slider-master# locate pkgconfig
/mnt/D81CF64D1CF62662/Documents/Old Desktop/Compilers/http%3a%2f%2fwww.goh4.com%2fcygwin%2f/release/pkgconfig
/usr/lib/pkgconfig
/usr/lib/pkgconfig/gnome-system-tools.pc
/usr/lib/pkgconfig/libgdiplus.pc
/usr/lib/pkgconfig/pm-utils.pc
/usr/lib/rpm/pkgconfigdeps.sh
/usr/lib/rpm/fileattrs/pkgconfig.attr
/usr/lib/x86_64-linux-gnu/pkgconfig
/usr/lib/x86_64-linux-gnu/pkgconfig/geoclue-2.0.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/gtk-engines-2.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/reiserfscore.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/xfce4-session-2.0.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/xorg-wacom.pc
/usr/share/pkgconfig
/usr/share/gtksourceview-3.0/language-specs/pkgconfig.lang
/usr/share/pkgconfig/adwaita-icon-theme.pc
/usr/share/pkgconfig/bash-completion.pc
/usr/share/pkgconfig/fontutil.pc
/usr/share/pkgconfig/gnome-icon-theme-symbolic.pc
/usr/share/pkgconfig/gnome-icon-theme.pc
/usr/share/pkgconfig/iso-codes.pc
/usr/share/pkgconfig/mobile-broadband-provider-info.pc
/usr/share/pkgconfig/poppler-data.pc
/usr/share/pkgconfig/shared-mime-info.pc
/usr/share/pkgconfig/systemd.pc
/usr/share/pkgconfig/udev.pc
/usr/share/pkgconfig/usbutils.pc
/usr/share/pkgconfig/xbitmaps.pc
/usr/share/pkgconfig/xkbcomp.pc
/usr/share/pkgconfig/xkeyboard-config.pc
/usr/share/pkgconfig/yelp-xsl.pc
/usr/src/libdvd-pkg/build/debian/libdvdcss-dev/usr/lib/x86_64-linux-gnu/pkgconfig
/usr/src/libdvd-pkg/build/debian/libdvdcss-dev/usr/lib/x86_64-linux-gnu/pkgconfig/libdvdcss.pc
/usr/src/libdvd-pkg/build/debian/tmp/usr/lib/x86_64-linux-gnu/pkgconfig
/usr/src/libdvd-pkg/build/debian/tmp/usr/lib/x86_64-linux-gnu/pkgconfig/libdvdcss.pc
Mint 19 xfce. Semi-noob

User avatar
MrEen
Level 7
Level 7
Posts: 1706
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't Build xfce4-generic-slider

Post by MrEen » Fri Aug 10, 2018 3:43 pm

I don't build from source, but you're using old instructions. Try here.

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: Can't Build xfce4-generic-slider

Post by johnywhy » Fri Aug 10, 2018 4:10 pm

thx

i get

Code: Select all

$ diff --git a/Makefile b/Makefile
diff: unrecognized option '--git'
then tried:

Code: Select all

xfce4-generic-slider-master$ git diff --no-index a b
error: Could not access 'a'
https://unix.stackexchange.com/a/216667

any ideas?
Mint 19 xfce. Semi-noob

Post Reply

Return to “Xfce”