SOLVED - Laptop - Mint 19 XFCE - Energy / Display issues !!!

Forum rules
Before you post please read how to get help
Post Reply
User avatar
LinWinux
Level 4
Level 4
Posts: 262
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

SOLVED - Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by LinWinux » Mon Oct 08, 2018 12:40 pm

Hi everyone. We've been using Mint with the XFCE desktop on all of our computers for years, also on our "travel machine" which of course happens to be a laptop. Last week I went ahead and installed Mint 19 XFCE on that laptop. One thing that we really like to do when we're on the road, is to open up a music archive of ours with custom song selections, which we then run for hours on end. For this we've always been using either VLC or MoviePlayer, both of which permit the opening of archives in order to listen to everything within that archive.
Well, here's the problem that we're running into with the laptop ...

Songs begin to play, but then after 15 or 20 minutes (haven't actually timed it) the music suddenly stops because the desktop enters the login screen / mode (presumably because there's been no activity on the screen).

Screensavers are not installed by default with Mint 19 XFCE, so there's no display setting in the screensaver mode that could be disabled. However, in the Energy saving configuration of Mint 19 XFCE, everything has been disabled there, to prevent the screen from going into some kind of weird unwanted sleep mode. Still, the display ends up with the login screen after awhile. Okay, so I checked the user session, and sure enough there was a screensaver time-out enabled in the system-startup items ... even though there aren't any screensavers installed. HUH ??? No problem, unchecked that.
Still, the friggen login screen came back again, un-believable .... :shock: :evil:
Okay, let's check the task manager, to see if a running process is the culprit?
Except for lightdm which I'm not familiar with, there was nothing display related there.

This is driving me nuts. We have Mint 19 XFCE installed on our desktops without ever experiencing the issue with the login screen. The only difference between the laptop and our desktops, is that I can power-off the display completely when we're playing music from an archive, and the music will just keep on playing. Anyone else experience something similar with their laptop? Thanks, and sorry for the long explanation ... :wink:

.
Last edited by LinWinux on Thu Oct 11, 2018 11:25 am, edited 1 time in total.
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

Hoser Rob
Level 12
Level 12
Posts: 4325
Joined: Sat Dec 15, 2012 8:57 am

Re: Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by Hoser Rob » Tue Oct 09, 2018 8:44 am

"Travel" laptops are often older and Mint 19 has some issues with older hardware. This isn't a Mint issue, it's happening at the kernel dev level and affects all newer distro releases.

In any case you've not included any useful system info, please paste the text output of

Code: Select all

inxi -Fxz
here.

User avatar
LinWinux
Level 4
Level 4
Posts: 262
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by LinWinux » Tue Oct 09, 2018 11:37 am

Thanks for the info. I can't provide the output because the laptop is in use in our barn right now. It doesn't have email either since we use it strictly for media purposes and a little browsing. The laptop is indeed old, an older Asus G2S Gaming Laptop. It has Nvidea graphics, but I'm using the default driver that Mint19 XFCE provides. Screen is 17 inch. Anyway. here are the complete specs, perhaps that'll help?
https://www.cnet.com/products/asus-g2s/specs/

.
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

User avatar
mint4all
Level 2
Level 2
Posts: 86
Joined: Tue Feb 13, 2018 1:16 pm

Re: Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by mint4all » Tue Oct 09, 2018 6:40 pm

LinWinux wrote:
Tue Oct 09, 2018 11:37 am
Thanks for the info. I can't provide the output because the laptop is in use in our barn right now. It doesn't have email either since we use it strictly for media purposes and a little browsing. The laptop is indeed old, an older Asus G2S Gaming Laptop. It has Nvidea graphics, but I'm using the default driver that Mint19 XFCE provides. Screen is 17 inch. Anyway. here are the complete specs, perhaps that'll help? https://www.cnet.com/products/asus-g2s/specs/
Greetings!

Just to let you know, the above-mention "inxi" command explores your system's configuration AS-IS and AS-CONFIGURED, and not just its OEM-specs. It is generally very helpful in troubleshooting problems like your's. And the command's output gets posted in this forum thread (see the "code" tags) and doesn't need emailing ...

Anyhow, now to my question: have you had a chance to revisit the power-manager settings? LM19 (based on Ubuntu 18.04) comes with quite a view updates under the hood, ime. One quick look worth taking: Menu > Settings > Power Manager > System {tab} > Security {checkbox to lock the screen} s/b unchecked; otherwise, the system will lock up when going to sleep /suspend/ hibernate. Note: I have a 2006-vintage Toshiba laptop that runs LM19-Xfce 32bit just fine, and i had to disable THAT very option after installing LM19 ..

Cheers, m4a

User avatar
LinWinux
Level 4
Level 4
Posts: 262
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by LinWinux » Wed Oct 10, 2018 2:25 am

Thanks for that last response. Will check it our later today and report back. What I meant about that email remark ... Since that laptop is in another location and without email, I didn't feel like going through the hassle of bringing a usb stick over there, just for the sake of using a one-time command, copying it into a text file, saving it onto the stick, bringing it over here, retrieving the saved text, in order to enter it here in the forum. If nothing else works, I may do that, but it's definitely not my first option.

Granted, I can log into the mint forum with the other laptop, only problem with that is that we use dedicated vpn services on our machines here at the house. Logging out of one site here and then onto a site with another machine, generally causes password/confirmation issues later. Nothing that can't be corrected within a couple of minutes, but again, more hassle than need be right now.

When I wrote the post, I was hoping that it was something quick & simple that others had encountered, thereby providing a simple fix from their own experience, like you just did. We just happen to be extremely privacy oriented. We don't sync any of our phones/computers/web accounts on purpose, and we stay away from social media. My wife and I have been Online professionally since 1991, but we don't need any of that privacy invasive garbage. Anyway, I'll be back ... :wink:

.
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

User avatar
LinWinux
Level 4
Level 4
Posts: 262
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

SOLVED - Re: Laptop - Mint 19 XFCE - Energy / Display issues !!!

Post by LinWinux » Thu Oct 11, 2018 11:24 am

mint4all wrote:
Tue Oct 09, 2018 6:40 pm
One quick look worth taking: Menu > Settings > Power Manager > System {tab} > Security {checkbox to lock the screen} s/b unchecked; otherwise, the system will lock up when going to sleep /suspend/ hibernate. Note: I have a 2006-vintage Toshiba laptop that runs LM19-Xfce 32bit just fine, and i had to disable THAT very option after installing LM19 ..

Cheers, m4a
Got it figured out, thanks. My power manager on Mint19 XFCE 64bit is a little different though. For me it was the DISPLAY setting that had to be changed ... which I actually had already changed. I took it for granted that as before, when you check the box to disable the power manager display settings, that all power manager display settings would then be disabled ... as opposed to just some of them. So I was totally surprised today when I checked those settings again, just to find that even though the display settings were disabled, the slider bar for locking the screen ... pretty much what you had mentioned ... was still set to 25 minutes. It was the only function that was still enabled even though the display settings had the button which showed disabled.
Ah well, always something else that requires a minute of extra attention here and there. :?

Personally, I think it's a dumb change, sorry for being blunt about that. I think it should be exactly the other way around. When a person checks DISABLED for the display power, sleep, lock, whatever settings ... everything display related should indeed be disabled. Then, if someone decides that one or two of those settings might be more useful enabled, go ahead and let them decide that ... then. Ah well. :roll:
Anyway, will be marked as solved. Good day to everyone. :D

.
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

Post Reply

Return to “Xfce”