install xscreensaver in 19 tara conflict with power managaer [SOLVED]

Forum rules
Before you post please read how to get help
Post Reply
tomfun
Level 1
Level 1
Posts: 1
Joined: Tue Nov 28, 2017 6:57 am

install xscreensaver in 19 tara conflict with power managaer [SOLVED]

Post by tomfun » Mon Oct 08, 2018 2:41 pm

I used to use xscreensaver for 2 reasons that important to me:
- it locks the session
- has blank blak screen that after some time (few seconds) switch my display to power save mode - I see fully turned off / black display (but it is not, if I tocuh mouse it rapidly show the picture = power saving mode)

In new (19) linux xscreensaver was removed. Ok. But new power management has a little different actions. It really turns off display then my display show bright picture about "check cable". Also, my sound switched to another devices (display + hdmi = sound output device) which give additional problems (long story).

So the expectation - after N minutes I want to see black screen so that I see no bright image. It is the only what I want.

I've tried to install xscreensaver which I have started to love after new linux. So it is just my attempt to solve the original problem.
So if you know how to fix the original problem without installing xscreensaver it will be very helpful for me.

The problem with xscreensaver.
I've installed it. It works. I tried to completely disable xfce power manager, and stop its daemon.
I have VLC, when I watch video it executes some command to prevent screensaver every M minutes (I thought so, but it is not the correct command; anyway it describe the problem), like that:

Code: Select all

xdg-screensaver reset
And it has worked for internal screensaver (display turn off'er). But after installing new screensaver xdg-screensaver is not work,
it wrongly detects screensaver, because of this bash line:

Code: Select all

dbus-send --print-reply --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.GetNameOwner string:org.gnome.ScreenSaver > /dev/null 2>&1 && DE="gnome_screensaver"
And after N minutes xscreensaver shows blank screen. While I watch video. It is the problem what I try to solve.

So simple test to check if all are well:

Code: Select all

sleep 1 && xdg-screensaver activate && sleep 5 && bash -x /usr/bin/xdg-screensaver reset
In my case it thinks that there is gnome screensaver (which I have not), and it don't communicate with xscreensaver, but it is telling to the internal power manager something to not turn off my display.

How to teach xfce to talk with xscreensaver and proxy "deactivate" command to it? How to resolve this conflict?

------------------

Just looked what is listening dbus, it was light-locker, after removing it from startup (via "Session and Startup"), problem almost (sometimes, screen is still turns off, I didn't check it yet, it is rarely happen) solved.

screen: http://imgur.com/ECdwDQDl.png

Post Reply

Return to “Xfce”