[SOLVED] Power manager / screen lock problems on LM 19 XFCE

Forum rules
Before you post please read how to get help
Post Reply
flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

[SOLVED] Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Fri Nov 02, 2018 6:06 pm

Sorry for yet another post about screenlock on LM19 XFCE, but reading the previous discussions on the subject doesn't help.

Goal - screen locks with password after 3 minutes of inactivity. Blank screen preferred.

Real simple request, right?
Well not in LM19. The screensaver program has been removed since LM18, and basic functionality moved to power manager.
But it doesn't work!

I even tried installing xscreensaver per advice in one of the posts on the subject. No luck.
Another post recommended disabling power manager because it conflicts with xscreensaver, so I did that too. No luck.

I also tried doing:
chown -R MYNAME:MYNAME ~/.dbus
Followed by reboot.
Because I saw it was originally owned as root.
That didn't help.

I also see these messages in syslog:
Nov 3 17:30:50 asus303 dbus-daemon[733]: dbus[733]: Unknown username "whoopsie" in message bus configuration file
Nov 3 17:30:50 asus303 dbus-daemon[733]: dbus[733]: Unknown group "power" in message bus configuration file
The 'whoopsie message appears unrelated, but does the 'power' message mean anything?

Finally - I did a tail -f on auth and syslog files, but I see no log lines at the time the screensaver should kick in.

I appreciate all advice.
Thanks.
Last edited by flyingrhino on Sat Nov 03, 2018 4:47 pm, edited 6 times in total.

flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

Re: Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Fri Nov 02, 2018 6:16 pm

.
Last edited by flyingrhino on Sat Nov 03, 2018 4:53 pm, edited 3 times in total.

flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

Re: [SOLVED] Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Sat Nov 03, 2018 1:11 am

For final troubleshooting I verified that running:
light-locker-command --lock
does indeed lock the screen, as does CTRL-ALT-L.

I then went back to the power manager -> Display tab, and disabled/enabled the power management switch. I also moved the slider to 1 minute.
Screensaver started working !

Not sure why this voodoo fixed it, but it did.
If someone knows why then you're welcome to post an explanation :)

flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

Re: [SOLVED] Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Sat Nov 03, 2018 4:55 pm

Here are screenshots of the working solution:
2018-11-04_001.png
2018-11-04_002.png
2018-11-04_003.png
I installed the xscreensaver package from software manager. Then verified that the packages run at startup.

flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

Re: [SOLVED] Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Sat Nov 03, 2018 4:56 pm

And the power manager screenshots:

1 of 2 (due to 3 file upload limit).
2018-11-04_004.png
2018-11-04_005.png
2018-11-04_006.png

flyingrhino
Level 3
Level 3
Posts: 145
Joined: Sat Apr 04, 2015 8:55 pm

Re: [SOLVED] Power manager / screen lock problems on LM 19 XFCE

Post by flyingrhino » Sat Nov 03, 2018 4:56 pm

2 of 2.
2018-11-04_007.png
2018-11-04_008.png

Post Reply

Return to “Xfce”