LM19.1 Xfce: Losing desktop settings at remote desktop

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 25
Joined: Fri Oct 26, 2018 4:32 pm

LM19.1 Xfce: Losing desktop settings at remote desktop

Post by NeroR » Sun Jan 27, 2019 5:09 pm

When I run a remote desktop session (RDP, with Xrdp) on my Linux Mint 19.1 Xfce all desktop settings (Mint -theme, colors, panel, font size, dpi, etc.) get lost.
At connect/login I get a dialog box, if I'd like to use an empty panel or the default panel. With "default" I get the defaults of Xfce, not the Mint-Xfce-defaults.
The lost desktops settings (Xfce-defaults) are permanent, i.e. they are also active on local logins.

First I have this problem I've deleted the configuration (~/.config/xfce4) and so I got the Linux-Mint-Xfce-defaults back.
Since I use it on my HTPC I have to change several things (DPI, font size, etc.) to fit my needs. This is just painful.

I had this problem now twice, at all my RDP-logins since I've updated to LM19.1.
With LM19 I didn't had this problem.

Does anybody else have this problem?
What can I do to fix this problem?

Level 1
Level 1
Posts: 2
Joined: Sun Mar 03, 2019 2:22 pm

Re: LM19.1 Xfce: Losing desktop settings at remote desktop

Post by GrahamLMC » Mon Jul 29, 2019 2:20 pm

Yes, I had the same problem trying to setup a headless server with LM 19.2 XFCE.

I've tried numerous things and I was able to change some of settings back to Mint but not get it all setup right. I think the Mint XFCE setup needs copying over the default XFCE somwhere but I couldn't get it right, and I just wanted to get the PC going.

I've since gone with LM 19.2 Mate which works fine and keeps the Mint desktop setup when run headless.

Post Reply

Return to “Xfce”