Sticky windows shadows with xfwm4+compositing

Forum rules
Before you post please read how to get help
Post Reply
Girafenaine
Level 2
Level 2
Posts: 69
Joined: Thu Aug 13, 2015 10:37 am

Sticky windows shadows with xfwm4+compositing

Post by Girafenaine » Sat Mar 16, 2019 10:54 am

Hello LM community,

I use a (very good) LM19 install on my macbook 5.1.

I have xfwm4+compositing enabled as desktop parameters. I want to use transparency (for windows decorations, and dock, and unactive windows), but no shadows.

I saw that even with unticked "normal window shadows" box, there are shadows around my windows. The others boxes do make their planned effects (transparency works, docks shadows can be enabled or unabled, etc.), but this one does not.

Does anyone encounter the same issue ? Is there a bug or something to do to unabled these shadows ?

Girafenaine
MacBook 5.1 (Dual core Intel Core2)
Dual boot MacOS 10.6.8 (36 Go HFSplus partition) / Linux Mint 19 xfce 64bits (39 Go ext4 partition) / shared partition for documents (400 Go HFSplus partition)

User avatar
fblais
Level 1
Level 1
Posts: 27
Joined: Mon Aug 27, 2012 8:03 am
Location: Québec, Canada

Re: Sticky windows shadows with xfwm4+compositing

Post by fblais » Thu Mar 21, 2019 10:11 am

Maybe you could use Compton for compositing instead of xfwm's own.
Be sure to install compton-conf as well to be able to fine-tune it as needed.

User avatar
secureIT
Level 3
Level 3
Posts: 164
Joined: Wed Dec 05, 2018 1:26 pm

Re: Sticky windows shadows with xfwm4+compositing

Post by secureIT » Sun Mar 24, 2019 1:42 pm

Had this issue with sticky shadow around cairo-dock.

With the settings below they are gone :

Untick both : "Show shadows under normal windows" and "Show shadows under bars" .
In der Ruhe liegt die Kraft ! .......... The strenght is to be found in serenity !

Girafenaine
Level 2
Level 2
Posts: 69
Joined: Thu Aug 13, 2015 10:37 am

Re: Sticky windows shadows with xfwm4+compositing

Post by Girafenaine » Wed Apr 03, 2019 5:18 pm

Hello,

Thanks for your help and sorry for being late.

All the "shadows" boxes are unticked in my parameters setting page, and "compositer" let shadows haunt each of my windows

I have tried with compton instead of compositor (xfwm4+compton as desktop setting). Thanks to fblais and after installing "compton.conf" from the synaptic package manager, I could make these shadows disappear : thanks ! However, it seems the display is slower, more sluggish that with "xfwm4+compositer". I will try for a few days and have a look at compton ressources usage.

Girafenaine
MacBook 5.1 (Dual core Intel Core2)
Dual boot MacOS 10.6.8 (36 Go HFSplus partition) / Linux Mint 19 xfce 64bits (39 Go ext4 partition) / shared partition for documents (400 Go HFSplus partition)

Post Reply

Return to “Xfce”