How to rid lag on Chromium with compositor enabled?

Forum rules
Before you post please read how to get help
Post Reply
User avatar
deanr72
Level 3
Level 3
Posts: 159
Joined: Sat Mar 24, 2018 2:00 pm
Location: Poland

How to rid lag on Chromium with compositor enabled?

Post by deanr72 » Sun May 12, 2019 7:57 am

I like to have transparent windows when I drag boxes around the screen (purely cosmetic, so not a deal breaker - but then it does prevent screen tearing too) but with this feature enabled I get definite lag on Chromium. As I need to type a lot for work this becomes a bigger issue as the letters appear slower than when I type which leads to me making lots of typing errors. Is there any way to prevent this?

Here's some basic info:

XFCE latest version
Lenovo H50-55, AMD A8
16GB Ram

I can provide more info from the terminal if you can tell me what to enter :)

Thanks

User avatar
deanr72
Level 3
Level 3
Posts: 159
Joined: Sat Mar 24, 2018 2:00 pm
Location: Poland

Re: [SOLVED] How to rid lag on Chromium with compositor enabled?

Post by deanr72 » Tue May 21, 2019 10:36 am

Some tinkering and more research seems to have solved this problem should anyone else encounter the same thing. I don't which of the following is responsible, or whether it's a combination of factors, but it solves the lag problem and, indeed, removed all screen tearing I was experiencing (a nice bonus) this is what I did:

Desktop settings > select Xwfm4 + Compton
Window Manager Tweaks > Compositor > Synchronise drawing to the vertical blank (tick this)
Chromium > Settings > Advanced > Use hardware acceleration when available (Turn this on)

Other than the obvious technique of dragging windows and scrolling up and down web pages I used the following to confirm screen tearing has been eliminated:

https://www.youtube.com/watch?v=0RvIbVmCOxg

Robbins21
Level 1
Level 1
Posts: 4
Joined: Thu May 23, 2019 10:29 am

Re: How to rid lag on Chromium with compositor enabled?

Post by Robbins21 » Mon May 27, 2019 8:51 am

I tried to switch to Compton before, and I was under the impression that
"Window Manager Tweaks > Compositing activated"
means that you are using default compositing (NOT compton). So if you go --

Step 1: Desktop settings > select Xwfm4+Compton
Step 2: Window Manager Tweaks > activate Compositing
Reboot

-- then Step 2 basically has taken back Step 1; Xwfm4+Compositing will be used. Under "Desktop settings" it still may say "Xwfm4+Compton". But Taskmanager will show that no compton is running.

(I find it confusing, that "compositing" could mean A. "a task in general", but it could also mean B. "a certain way to handle this general task" (default compositing). As far as I understand, dealing with settings, you're better off understanding "compositing/compositor" more specific, as "default compositing".) -- Should anyone know better, please explain.

User avatar
deanr72
Level 3
Level 3
Posts: 159
Joined: Sat Mar 24, 2018 2:00 pm
Location: Poland

Re: How to rid lag on Chromium with compositor enabled?

Post by deanr72 » Tue Jun 11, 2019 4:43 am

Yes, it is confusing. I presumed you need to turn compositing off in Window Manager Tweaks and then choose whichever compositor you want via Desktop settings. But I've got no idea, tbh.

As far as I see it, any OS should just be set up (if possible) simply to eliminate screen tearing - this is probably the most notable negative aspect of bad compositing (if I can say that) and one that your average user is likely to a) notice and b) have problems with. If more advanced users need to tweak the compositor then they're the ones that should need to go into the setting and play around with things :)

Mint, btw, does seem to do a good job with this.

Post Reply

Return to “Xfce”