Page 1 of 1

(Solved) Xorg Problems

Posted: Wed May 29, 2019 11:44 pm
by Shadow in Fire
I've been having issues with Xorg randomly bloating up and slowing down in terms of performance, likely triggered by a service. I'm using GNU/Linux Mint 18.3 (same as Ubuntu 16.04) and my WM is Xfwm4 (with Compton).

I'm tired of having to restart Xorg every other minute. I'm not sure what's going on, but whenever I refresh my desktop and notice the text of the icons have a shade glitch display, I know something happened. I've tried switching my WM to Compiz, but no dice. Any help?

I suspect one of these might be the culprit:

Code: Select all

redacted

Re: Xorg Problems

Posted: Sat Jun 01, 2019 6:49 am
by cottfcfan
Might be an obvious thing, but have you made sure that the compositor in Window Manager Tweaks is turned off, before you change your window manager, otherwise you will have 2 compositors enabled and conflicting.

Re: Xorg Problems

Posted: Sat Jun 01, 2019 8:11 am
by Hoser Rob
I wouldn't assume it's a wm or compositor issue but there's no useful info there. Copy/paste this to the terminal and copy/paste the text output here (no screenshots plz):

Code: Select all

inxi -Fxz

Re: Xorg Problems

Posted: Sun Jun 02, 2019 1:24 am
by Shadow in Fire
Here it is:

Code: Select all

redacted

Re: Xorg Problems

Posted: Sun Jun 02, 2019 10:04 am
by Hoser Rob
I said to post the whole output not just the gpu related stuff.

Re: Xorg Problems

Posted: Mon Jun 03, 2019 4:11 am
by Shadow in Fire
Sorry. Here's the output:

Code: Select all

redacted

Re: Xorg Problems

Posted: Mon Jun 03, 2019 7:35 am
by MrEen
I'd assume this isn't related to your issue, but this looks weird ID-1: / size: 109.91 GiB used: 90.51 GiB (82.4%) fs: ext4 dev: /dev/sdc1

90GiB used for / when you have a separate /home partition? Might that be because of RAID mode? Or Timeshift?

Re: Xorg Problems

Posted: Mon Jun 03, 2019 9:05 am
by Hoser Rob
That's a rather old gpu, you're using the right driver. Try disabling the eye candy/compositing. The simplest way to do that in Xfce is to go to settings > desktop settings > wiindows. Then left click the popup menu and select 'Xfwm4'.

Re: Xorg Problems

Posted: Mon Jun 03, 2019 12:56 pm
by Shadow in Fire
MrEen wrote:
Mon Jun 03, 2019 7:35 am
I'd assume this isn't related to your issue, but this looks weird ID-1: / size: 109.91 GiB used: 90.51 GiB (82.4%) fs: ext4 dev: /dev/sdc1

90GiB used for / when you have a separate /home partition? Might that be because of RAID mode? Or Timeshift?
I keep Timeshift data in that partition.
Hoser Rob wrote:
Mon Jun 03, 2019 9:05 am
That's a rather old gpu, you're using the right driver. Try disabling the eye candy/compositing. The simplest way to do that in Xfce is to go to settings > desktop settings > wiindows. Then left click the popup menu and select 'Xfwm4'.
I do have a Radeon that works with the machine, but there's not enough room inside the casing for it to "breathe" properly. In other words, it heats up rather frequently, even on idle (because of the included fan).

Re: Xorg Problems

Posted: Sat Jun 29, 2019 3:12 am
by Shadow in Fire
After nearly a month of no replies since my last one, I can safely confirm this issue has been solved. It's correct that a simple fix would be upgrading my GPU, as I was using a much older one. Not experiencing that issue anymore, although I will look more into the possibilities of Xorg memory leaks.

Thanks.