Windows open up on the secondary monitor.

Forum rules
Before you post please read how to get help
Post Reply
scowal
Level 1
Level 1
Posts: 1
Joined: Sat Jun 01, 2019 9:50 pm

Windows open up on the secondary monitor.

Post by scowal » Sat Jun 01, 2019 10:51 pm

My windows in XFCE keeps opening on the wrong monitor. First let me start by saying what i have done. I have set my my main monitor to primary. It is a HDMI monitor. and for some reason, every linux distribution i have tried seems to choose My smaller DVI monitor as being the main monitor. After i have changed and verified that my main monitor was set to primary, I begin to look for a way to set the Identity of the monitors to what they should be. This has failed and i have scoured the internet from site to site and forum to forum looking for an answer. Just about all the places that have posted help for this, seem to come to the conclusion that linux or maybe xranr does not like the orientation of my monitor. My primary monitor(HDMI) is on the right side. My secondary(DVI) is on the left. There seems to be no solution because many come the the solution that they need to swap the settings and make the monitor be on the right even though it is not. If you have an idea that can help me i would be truly appreciative. I am sure that Linuxmint XFCE is not the problem. Because every distro i have tried has the same effect. I am at my wits end. Please help.One Last thing, If you happen to know how i can set the location the window opens on the monitor. Its a real pain that it always opens at top left corner of monitor.
Screenshot_2019-06-01_21-20-10.jpg
Screenshot_2019-06-01_21-22-04.png
Screenshot_2019-06-01_21-22-54.png

User avatar
secureIT
Level 3
Level 3
Posts: 109
Joined: Wed Dec 05, 2018 1:26 pm

Re: Windows open up on the secondary monitor.

Post by secureIT » Sat Jun 08, 2019 12:42 pm

Hi scowal,

I am using LM 19.1 with Notebook-Screen left and bigger Monitor right, but never had this issue.
What is your Version ?
Did you try to open an application-window from the notebook screen (libre office e.g.) ..... and then drag it to the second monitor.

After closing, the last position of the window should be remembered and then, if you start the application again the window will usually open on its last postion. (second Monitor)
But let us see the terminal-output of:

Code: Select all

xrandr
Last question of your post :
If you happen to know how i can set the location the window opens on the monitor. Its a real pain that it always opens at top left corner of monitor.
you can adjust it in : Graphical settings management > Fine settings of the window management > By default, place the windows as follows > in the middle of the screen
In der Ruhe liegt die Kraft ! .......... The strenght is to be found in serenity !

ugly
Level 4
Level 4
Posts: 217
Joined: Thu Nov 24, 2016 9:17 pm

Re: Windows open up on the secondary monitor.

Post by ugly » Sat Jun 08, 2019 2:50 pm

I have a similar set up and I've run into the same problem. Some programs don't seem to respect the primary monitor setting on the right side and a secondary on the left. It seems to happen most often when it's a sub-window of a program (like a setting window that you open from within a program). A lot of games seem to open on the left monitor too.

I could be totally wrong on this, but I believe that even though the right monitor is primary, the bottom left corner of the monitor on the left side is still considered position 0,0 and then the bottom left corner of the right monitor would be 1921,0 (assuming it the left monitor is 1920x1080). And that messes up the default position where some windows open.

Fortunately, most programs do open on the primary monitor. But for the ones that don't, I've never found a solution.

As secureIT said, sometimes moving the window to the right monitor and closing it helps the next time the program opens. But, in my experience, some programs just will not open on the right primary monitor.

User avatar
secureIT
Level 3
Level 3
Posts: 109
Joined: Wed Dec 05, 2018 1:26 pm

Re: Windows open up on the secondary monitor.

Post by secureIT » Sun Jun 09, 2019 3:56 pm

Hi, scowal and ugly

Please define, which apps do not remind its last position.

It is well known, that some qt-apps do not remember its position, but that can be solved with the help of another app.

To narrow down whether there is an error in Xfce or at xrandr, or if it is just the qt-programmed application, it would be important to know which application you are using, when its window open up without remembering the last position..............
In der Ruhe liegt die Kraft ! .......... The strenght is to be found in serenity !

ugly
Level 4
Level 4
Posts: 217
Joined: Thu Nov 24, 2016 9:17 pm

Re: Windows open up on the secondary monitor.

Post by ugly » Mon Jun 10, 2019 1:07 am

I'm actually on Cinnamon.

One program which always opens on my left monitor is the System Monitor.

User avatar
secureIT
Level 3
Level 3
Posts: 109
Joined: Wed Dec 05, 2018 1:26 pm

Re: Windows open up on the secondary monitor.

Post by secureIT » Tue Jun 11, 2019 11:43 am

Hi ugly,

This is the board for Xfce.
In Xfce the system-monitor opens up on the first monitor, if started from this.
For opening the system-montior on second monitor, we have to create a launcher on the desktop or in a panel of the second monitor, and start it from this. The command will be :

Code: Select all

xfce4-taskmanager
For cinnamon try the command :

Code: Select all

gnome-system-monitor
By the way : for questions about cinnamon open a new thread in the cinnamon board.
In der Ruhe liegt die Kraft ! .......... The strenght is to be found in serenity !

ugly
Level 4
Level 4
Posts: 217
Joined: Thu Nov 24, 2016 9:17 pm

Re: Windows open up on the secondary monitor.

Post by ugly » Tue Jun 11, 2019 6:14 pm

secureIT wrote:
Tue Jun 11, 2019 11:43 am
Hi ugly,

This is the board for Xfce.

By the way : for questions about cinnamon open a new thread in the cinnamon board.
Oh sorry, I wasn't paying attention. The 'Desktop & Window Managers' board lists all topics together.

Post Reply

Return to “Xfce”