VNC xstartup - startxfce4 uses wrong theme

Forum rules
Before you post please read how to get help
Post Reply
Xzander
Level 1
Level 1
Posts: 4
Joined: Tue Aug 21, 2018 9:30 pm

VNC xstartup - startxfce4 uses wrong theme

Post by Xzander » Mon Jul 15, 2019 12:08 pm

Hi!

I am trying to setup a VNC server on a (mostly) headless Linux Mint 19.1 Xfce x64 computer. I modified the xstartup file to contain these commands:

Code: Select all

xrdb $HOME/.Xresources
startxfce4 &
When I start the VNC server through SSH and connect to it, there is a popup that says "Welcome to the first start of the panel". I can select "Use default config" and "One empty panel". No matter which one I choose, the theme is screwed: wrong icons, start menu is at the top and such. The damage is permanent for the user, even when logging in locally, unless I restore .config/xfce to its previous state.

Here's the VNC log:

Code: Select all

15/07/19 11:52:24 Xvnc version TightVNC-1.3.10
15/07/19 11:52:24 Copyright (C) 2000-2009 TightVNC Group
15/07/19 11:52:24 Copyright (C) 1999 AT&T Laboratories Cambridge
15/07/19 11:52:24 All Rights Reserved.
15/07/19 11:52:24 See http://www.tightvnc.com/ for information on TightVNC
15/07/19 11:52:24 Desktop name 'X' (MyComputer:1)
15/07/19 11:52:24 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
15/07/19 11:52:24 Listening for VNC connections on TCP port 5901
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
xrdb: No such file or directory
xrdb: can't open file '/home/temp/.Xresources'
/usr/bin/startxfce4: X server already running on display :1
Xlib:  extension "RANDR" missing on display ":1".
gpg-agent[1324]: WARNING: "--write-env-file" is an obsolete option - it has no effect
gpg-agent: a gpg-agent is already running - not starting a new one

(xfce4-session:1304): xfce4-session-WARNING **: 11:52:25.597: gpg-agent returned no PID in the variables
(xfce4-session:1304): xfce4-session-WARNING **: 11:52:25.618: xfsm_manager_load_session: Something wrong with /home/temp/.cache/sessions/xfce4-session-MyComputer:1, Does it exist? Permissions issue?
Xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".
XKB extension not present on :1.0
Xlib:  extension "RANDR" missing on display ":1.0".

** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding 'XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Ctrl>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Alt>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Shift>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Ctrl><Shift>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Ctrl><Alt>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.920: Binding '<Alt><Shift>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Ctrl><Shift><Alt>XF86AudioRaiseVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding 'XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Ctrl>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Alt>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Shift>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Ctrl><Shift>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Ctrl><Alt>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Binding '<Alt><Shift>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.921: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Binding '<Ctrl><Shift><Alt>XF86AudioLowerVolume' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Binding '<Ctrl>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Binding '<Alt>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.922: Binding '<Shift>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Binding '<Ctrl><Shift>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Binding '<Ctrl><Alt>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Binding '<Alt><Shift>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Binding '<Ctrl><Shift><Alt>XF86AudioMute' failed!
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
** (xfce4-volumed:1355): WARNING **: 11:52:25.923: Failed to map virtual modifiers
xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".

(xfsettingsd:1339): xfsettingsd-CRITICAL **: 11:52:26.101: No RANDR extension found in display :1.0. Display settings won't be applied.
Xlib:  extension "XInputExtension" missing on display ":1.0".

(xfsettingsd:1339): xfsettingsd-CRITICAL **: 11:52:26.102: XI is not present.
(xfsettingsd:1339): xfsettingsd-CRITICAL **: 11:52:26.102: Failed to initialize the Xkb extension.
(xfsettingsd:1339): xfsettingsd-CRITICAL **: 11:52:26.103: Failed to initialize the Accessibility extension.
(xfsettingsd:1339): GLib-CRITICAL **: 11:52:26.119: g_str_has_prefix: assertion 'prefix != NULL' failed

** (light-locker:1338): ERROR **: 11:52:26.476: Environment variable XDG_SESSION_PATH not set. Is LightDM running?
Xlib:  extension "RANDR" missing on display ":1.0".

(xfwm4:1328): xfwm4-WARNING **: 11:52:26.662: The display does not support the XRender extension.
(xfwm4:1328): xfwm4-WARNING **: 11:52:26.663: The display does not support the XRandr extension.
(xfwm4:1328): xfwm4-WARNING **: 11:52:26.663: The display does not support the XComposite extension.
(xfwm4:1328): xfwm4-WARNING **: 11:52:26.663: The display does not support the XDamage extension.
(xfwm4:1328): xfwm4-WARNING **: 11:52:26.663: The display does not support the XFixes extension.
(xfwm4:1328): xfwm4-WARNING **: 11:52:26.663: Compositing manager disabled.
Xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".

(polkit-gnome-authentication-agent-1:1343): GLib-CRITICAL **: 11:52:26.924: g_variant_new_string: assertion 'string != NULL' failed

(xfsettingsd:1339): xfsettingsd-WARNING **: 11:52:26.935: Failed to get the _NET_NUMBER_OF_DESKTOPS property.

(polkit-gnome-authentication-agent-1:1343): polkit-gnome-1-WARNING **: 11:52:26.936: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(xfwm4:1328): GLib-CRITICAL **: 11:52:27.002: g_str_has_prefix: assertion 'prefix != NULL' failed
(xfwm4:1328): xfwm4-WARNING **: 11:52:27.257: The property '/general/double_click_distance' of type int is not supported

15/07/19 11:52:28 Got connection from client 127.0.0.1
15/07/19 11:52:28 Using protocol version 3.8
15/07/19 11:52:28 Enabling TightVNC protocol extensions
xfwm4-Message: 11:52:29.328: Unsupported keyboard modifier '<Super>Tab'

(blueberry-tray.py:1420): Gtk-WARNING **: 11:52:29.371: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method "RegisterClient" with signature "ss" on interface "org.xfce.Session.Manager" doesn't exist

(nm-applet:1346): Gtk-WARNING **: 11:52:29.474: Can't set a parent on widget which has a parent
xfwm4-Message: 11:52:29.835: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.066: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.202: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.396: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.611: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.707: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.812: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:30.905: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:31.070: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:31.167: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:31.274: Unsupported keyboard modifier '<Super>Tab'
15/07/19 11:52:31 Full-control authentication passed by 127.0.0.1
15/07/19 11:52:31 Using tight encoding for client 127.0.0.1
15/07/19 11:52:31 rfbProcessClientNormalMessage: ignoring unknown encoding 16
15/07/19 11:52:31 Using image quality level 6 for client 127.0.0.1
15/07/19 11:52:31 rfbProcessClientNormalMessage: ignoring unknown encoding -223
15/07/19 11:52:31 Enabling LastRect protocol extension for client 127.0.0.1
15/07/19 11:52:31 Enabling cursor position updates for client 127.0.0.1
15/07/19 11:52:31 Enabling full-color cursor updates for client 127.0.0.1
xfwm4-Message: 11:52:31.427: Unsupported keyboard modifier '<Super>Tab'
xfwm4-Message: 11:52:31.529: Unsupported keyboard modifier '<Super>Tab'

(xfwm4:1328): xfwm4-WARNING **: 11:52:31.541: Cannot find visual format on screen 0
(xfwm4:1328): Gdk-WARNING **: 11:52:31.588: /build/gtk+2.0-AoeliP/gtk+2.0-2.24.32/gdk/x11/gdkproperty-x11.c:325 invalid X atom: 184
(xfce4-volumed:1355): libnotify-WARNING **: 11:52:51.792: Failed to connect to proxy
I read this other 2017 thread regarding a similar issue with Serena but the suggested fix didn't work (looks like ck-launch-session isn't found):
viewtopic.php?t=246759

Also, if it may help, here's the command I use to launch the VNC server:

Code: Select all

vncserver -geometry 1920x1080 -httpport 5901 -localhost
Except for adding tightvnc, this install is mostly fresh. Any help would be much appreciated. Thanks!

Post Reply

Return to “Xfce”