How to remove MIME type associations?

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Livy
Level 1
Level 1
Posts: 2
Joined: Fri May 03, 2019 3:09 am

How to remove MIME type associations?

Post by Livy » Fri Aug 09, 2019 5:13 am

After installing Wine, it automatically sets Wine Windows Program Loader as the default application for MIME application/x-ms-dos-executable. I would like to have that removed, which effectively forces running .exe files through command line.
Image I am using 19.2 Xfce. It only allows me to change the default application, not remove. Can someone guide me how to do this? I am not really a fan of graphical application and also want to do it in low level way if possible (editing some configuration files, use command line... etc).

cipricus
Level 1
Level 1
Posts: 13
Joined: Fri Feb 08, 2013 8:23 am

Re: How to remove MIME type associations?

Post by cipricus » Mon Sep 02, 2019 4:02 pm

Why do you think they will be run in terminal, and what do you mean by that? In my case, if Wine is NOT installed the default selection for exe is Mono Runtime. I see that in MIME Type Editor there is also the option "Mono Runtime (terminal)". Is that what you are looking for? What can that do? Or maybe you are looking for a way to run exe in wine but run wine in terminal?

gm10
Level 18
Level 18
Posts: 8725
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to remove MIME type associations?

Post by gm10 » Mon Sep 02, 2019 5:05 pm

So Cinnamon's MIME Type Editor doesn't actually let you edit? Interesting. ;)

I'm not familiar with the app but since it says user-set, I suppose check in ~/.local/share/applications/ for the wine*.desktop file responsible for this. Otherwise check in /usr/share/applications for system-wide installed associations.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

User avatar
Flemur
Level 17
Level 17
Posts: 7073
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How to remove MIME type associations?

Post by Flemur » Mon Sep 02, 2019 8:08 pm

Check for 1 or 2 lines conainting 'wine' in

Code: Select all

~/.config/mimeapps.list
and delete the refs to wine (check the synctax), and delete the *wine*.desktop files from

Code: Select all

~/.local/share/applications/
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

Post Reply

Return to “Xfce”