[SOLVED] "Black Hole" Area On Desktop Eats Icons

Forum rules
Before you post please read how to get help
Post Reply
zilcro
Level 2
Level 2
Posts: 61
Joined: Tue Mar 21, 2017 5:37 pm

[SOLVED] "Black Hole" Area On Desktop Eats Icons

Post by zilcro » Mon Sep 30, 2019 4:10 pm

OK, this is a weird one...

I saved a link from Chrome to my desktop some time ago. Recently I decided to delete it. This left an empty spot, so I moved one of my other icons - a text file - to the same spot and *poof* - it disappeared! If I move another icon to that spot, it too will disappear :shock: .

If I create a NEW text file and place it's icon in that spot, it doesn't disappear, but the minute I remove that new text file and move one of my existing icons over to the same spot, it will be gone in an instant. This only seems to happen in the one spot. None of the missing icons show up in the desktop folder, even after a reboot.

I have never seen this before. I'm running LM19.1 XFCE. Any ideas?
Last edited by zilcro on Wed Oct 09, 2019 11:37 am, edited 1 time in total.

User avatar
blueocean
Level 5
Level 5
Posts: 765
Joined: Sun Jul 08, 2018 11:50 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by blueocean » Wed Oct 02, 2019 8:38 pm

Try this:
Menu>type nemo>desktop>from upper bar select>view>ck mark in hidden. Is there a hidden folder showing? would have a . in front. like this .My-Stuff. If so delete it after looking for your lost links.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
MrEen
Level 15
Level 15
Posts: 5529
Joined: Mon Jun 12, 2017 8:39 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by MrEen » Wed Oct 02, 2019 8:48 pm

blueocean wrote:
Wed Oct 02, 2019 8:38 pm
Try this:
Menu>type nemo>desktop>from upper bar select>view>ck mark in hidden. Is there a hidden folder showing? would have a . in front. like this .My-Stuff. If so delete it after looking for your lost links.
Translating for Xfce. Open Thunar (File Manager) and navigate to the Desktop directory. Press Ctrl+H (or View > Show hidden files) and see if there's a hidden file there. No idea myself if that'll help, but Xfce doesn't come with Nemo, so just wanted the give your instruction the tweak that would be necessary.

User avatar
blueocean
Level 5
Level 5
Posts: 765
Joined: Sun Jul 08, 2018 11:50 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by blueocean » Wed Oct 02, 2019 8:54 pm

MrEen wrote:
Wed Oct 02, 2019 8:48 pm
blueocean wrote:
Wed Oct 02, 2019 8:38 pm
Try this:
Menu>type nemo>desktop>from upper bar select>view>ck mark in hidden. Is there a hidden folder showing? would have a . in front. like this .My-Stuff. If so delete it after looking for your lost links.
Translating for Xfce. Open Thunar (File Manager) and navigate to the Desktop directory. Press Ctrl+H (or View > Show hidden files) and see if there's a hidden file there. No idea myself if that'll help, but Xfce doesn't come with Nemo, so just wanted the give your instruction the tweak that would be necessary.
Thanks, I guess I should have a copy of Xfce.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
MrEen
Level 15
Level 15
Posts: 5529
Joined: Mon Jun 12, 2017 8:39 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by MrEen » Wed Oct 02, 2019 8:58 pm

blueocean wrote:
Wed Oct 02, 2019 8:54 pm
Thanks, I guess I should have a copy of Xfce.
Yes, everyone should! :wink:

User avatar
blueocean
Level 5
Level 5
Posts: 765
Joined: Sun Jul 08, 2018 11:50 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by blueocean » Wed Oct 02, 2019 9:23 pm

I have trouble keeping all the settings stuff in my brain case with to many OS. Used to use Mate, but 3 years ago went to Cinnamon.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4307
Joined: Sun Mar 27, 2016 6:58 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by rene » Wed Oct 02, 2019 9:58 pm

And check the "Rubbish Bin" in Nemo to see if your icons ended up there. This not happening with a newly created icon does not match it, but I otherwise could sort of imagine the "Rubbish Bin" in that spot but somehow with a corrupted/undisplayable icon.

User avatar
murray
Level 4
Level 4
Posts: 418
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: "Black Hole" Area On Desktop Eats Icons

Post by murray » Wed Oct 02, 2019 10:37 pm

blueocean wrote:
Wed Oct 02, 2019 8:38 pm
Try this:
Menu>type nemo>desktop>from upper bar select>view>ck mark in hidden. Is there a hidden folder showing? would have a . in front. like this .My-Stuff. If so delete it after looking for your lost links.
Ooo, so you think there's a hidden directory on his desktop and by dragging dekstop items to it they're being moved into that directory and so vanishing from the desktop? That's sneaky, I'd never have thought of that! :shock:
Running Mint 19.2 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

User avatar
blueocean
Level 5
Level 5
Posts: 765
Joined: Sun Jul 08, 2018 11:50 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by blueocean » Wed Oct 02, 2019 11:02 pm

murray wrote:
Wed Oct 02, 2019 10:37 pm
blueocean wrote:
Wed Oct 02, 2019 8:38 pm
Try this:
Menu>type nemo>desktop>from upper bar select>view>ck mark in hidden. Is there a hidden folder showing? would have a . in front. like this .My-Stuff. If so delete it after looking for your lost links.
Ooo, so you think there's a hidden directory on his desktop and by dragging dekstop items to it they're being moved into that directory and so vanishing from the desktop? That's sneaky, I'd never have thought of that! :shock:
Just a wild guess. I tried to simulate it without success. Maybe it's a Skylake processor :lol:
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

zilcro
Level 2
Level 2
Posts: 61
Joined: Tue Mar 21, 2017 5:37 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by zilcro » Thu Oct 03, 2019 11:11 am

Thanks for the "View > Show Hidden Files" tip; the missing file icons were in my /home/user/ directory. Running a restore with Timeshift fixed the "disappearing" behaviour.

User avatar
blueocean
Level 5
Level 5
Posts: 765
Joined: Sun Jul 08, 2018 11:50 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by blueocean » Thu Oct 03, 2019 11:45 am

Good for Timeshift thanks to Tony George a great guy and friend.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
secureIT
Level 3
Level 3
Posts: 182
Joined: Wed Dec 05, 2018 1:26 pm

Re: "Black Hole" Area On Desktop Eats Icons

Post by secureIT » Fri Oct 04, 2019 2:25 pm

@ zilcro

nice that the job has been done, but is it possible for you, to put the thread on "solved" ?, so that we not call the "black hole" again :P
In der Ruhe liegt die Kraft ! .......... The strenght is to be found in serenity !

User avatar
ricardogroetaers
Level 4
Level 4
Posts: 233
Joined: Sat Oct 27, 2018 3:06 am
Location: Rio de Janeiro, Brasil

Re: [SOLVED] "Black Hole" Area On Desktop Eats Icons

Post by ricardogroetaers » Thu Oct 31, 2019 12:25 am

Since Linux Mint 17.x, Xfce has invisible borders around desktop icons.
Any object crossing this border will be devoured.

Nothing to do with hidden files. I enable the display of hidden files on the desktop.

Avoid placing icons on your desktop that represent disk drives or folders, except "links to url *".
* Note: This term is a translation, I don't know if the meaning is clear. If you get confused I will try to explain further.

Note that I do not enable Show on Desktop:
( ) Removable Devices (all of them)
( )Start*
* I replace this with a shortcut (launcher) for Thunar File Manager.
( ) file system

Look at the picture if the English translation is not clear.

Image

You should work with the size of icons and fonts to try to minimize the size of the invisible border.

If the devoured object is a file, a shortcut, you can open the devouring object and bring the devoured object back.

If the devoured object is a disk drive, it will complicate things.
Does anyone know by memory the name of all the files and folders contained in a disk drive?

Note: The text has been translated to English by software. If something got confused or incomprehensible, let me know. I will try to explain in other words.

Post Reply

Return to “Xfce”