Can not set desktop background using "Desktop Settings" menu

Forum rules
Before you post please read how to get help
Post Reply
mintmdrescher
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2015 9:33 am

Can not set desktop background using "Desktop Settings" menu

Post by mintmdrescher »

Hi member,

I wonder what I messed at that point. When I try changing the background image using xfdesktop-settings, I can not select any custom image. No matter if I have a jpg, tiff or any other format, no image file is selectable but grayed out.
However, I can use "Set as Wallpaper" in Xviewer.
michael-hi
Level 3
Level 3
Posts: 102
Joined: Sun Mar 19, 2017 2:31 pm

Re: Can not set desktop background using "Desktop Settings" menu

Post by michael-hi »

Hi, mintmdrescher

There is one possible reason this might happen. If you hover the mouse over the "Folder" field on XFCE's Desktop settings, you get a popup saying "Choose the folder to select wallpapers from". In other words the idea is not to select the image file you want but instead to select the folder it is contained in. That is why the image files themselves are greyed out. If you select the folder, then all the image files in that folder will be displayed as thumbnails in the Desktop settings and you can click on one to select it.

Unless you select a different folder, the system will by default show files (or more likely shortcuts) in /usr/share/xfce4/backdrops. You could copy the image file you want to use into that folder (as root) then reopen the Desktop settings and select it. Or simply point the Desktop settings to a different folder eg one you have created within your Home folder.

Another way, as you have done, is to display the image in Xviewer, or right-click on it in Thunar, and "Set as wallpaper".

(A similar problem is when the image thumbnails in the Desktop settings are themselves greyed out. That will happen if the "Style" setting has been altered to "None". Change it back to something else eg "Zoomed".)
Post Reply

Return to “Xfce”