Can't type in Whisker menu search box after upgrading to 20

Forum rules
Before you post please read how to get help
Post Reply
User avatar
lonely_llama
Level 2
Level 2
Posts: 94
Joined: Mon Jul 22, 2019 12:08 am

Can't type in Whisker menu search box after upgrading to 20

Post by lonely_llama »

After updating 19.3 to 20, the Whisker menu has to be reopened a few times for the search box to become typable in. Sometimes when I open it, even clicking on the search box doesn't produce a mouse cursor, have to close and reopen before it shows up.

This is intermittent.
Last edited by lonely_llama on Wed Jul 15, 2020 5:18 am, edited 2 times in total.
User avatar
xenopeek
Level 24
Level 24
Posts: 24915
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Can't type in Whisker menu search box after upgrading to 20

Post by xenopeek »

I haven't noticed such on a fresh install.

What does apt policy xfce4-whiskermenu-plugin tell you? You should have version 2.4.3-1 installed from ubuntu focal repository.

If that looks okay, perhaps try removing the whiskermenu settings file ~/.config/xfce4/panel/whiskermenu-1.rc or rename it to something other. Then either log out and log back in or restart the panel with xfce4-panel -r to see if that improves it.
Image
User avatar
lonely_llama
Level 2
Level 2
Posts: 94
Joined: Mon Jul 22, 2019 12:08 am

Re: Can't type in Whisker menu search box after upgrading to 20

Post by lonely_llama »

Thanks, that worked! :D
User avatar
lonely_llama
Level 2
Level 2
Posts: 94
Joined: Mon Jul 22, 2019 12:08 am

Re: Can't type in Whisker menu search box after upgrading to 20

Post by lonely_llama »

Annnd it's again busted.
User avatar
xenopeek
Level 24
Level 24
Posts: 24915
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Can't type in Whisker menu search box after upgrading to 20

Post by xenopeek »

Did you change any settings of the menu or customize it in any way?

Is it immediately reproducible after booting your system or does it take longer before you can reproduce it?

Maybe worth a try to create a new user account as a test. Log in to that and see if you can reproduce the same on that. If so it's some issue with the software; otherwise it's an issue somewhere with settings on your own user account.
Image
User avatar
lonely_llama
Level 2
Level 2
Posts: 94
Joined: Mon Jul 22, 2019 12:08 am

Re: Can't type in Whisker menu search box after upgrading to 20

Post by lonely_llama »

It happens at any time, and only since upgrading to 20. I haven't made any non standard customizations if that's what you meant - just sorted menus alphabetically and moved the log off/shut down buttons to the bottom of the panel, and all this was already done before upgrading.
secureIT
Level 4
Level 4
Posts: 288
Joined: Wed Dec 05, 2018 1:26 pm

Re: Can't type in Whisker menu search box after upgrading to 20

Post by secureIT »

Hi,
please navigate to home/YOURNAME/.config/xfce4/panel/whiskermenu-1.rc
or if there are more whiskermenu-.,,,,,(),.rc files
doubleclick them (these are txt files)
..... and post the contet of it/them
.
User avatar
lonely_llama
Level 2
Level 2
Posts: 94
Joined: Mon Jul 22, 2019 12:08 am

Re: Can't type in Whisker menu search box after upgrading to 20

Post by lonely_llama »

Here it is -

Code: Select all

favorites=firefox.desktop,pix.desktop,org.gnome.Calculator.desktop,xed.desktop,mintinstall.desktop,xfce4-taskmanager.desktop
recent=synaptic.desktop,mintupdate.desktop,menulibre-telegram.desktop,bitwarden.desktop,quiterss.desktop
button-icon=linuxmint-logo-ring-symbolic
button-single-row=false
show-button-title=false
show-button-icon=true
launcher-show-name=true
launcher-show-description=true
launcher-show-tooltip=true
item-icon-size=2
hover-switch-category=true
category-show-name=true
category-icon-size=1
load-hierarchy=true
view-as-icons=false
recent-items-max=10
favorites-in-recent=true
display-recent-default=false
position-search-alternate=true
position-commands-alternate=true
position-categories-alternate=true
stay-on-focus-out=false
confirm-session-command=true
menu-width=450
menu-height=500
menu-opacity=66
command-settings=xfce4-settings-manager
show-command-settings=true
command-lockscreen=xflock4
show-command-lockscreen=true
command-switchuser=dm-tool switch-to-greeter
show-command-switchuser=false
command-logoutuser=xfce4-session-logout --logout --fast
show-command-logoutuser=false
command-restart=xfce4-session-logout --reboot --fast
show-command-restart=false
command-shutdown=xfce4-session-logout --halt --fast
show-command-shutdown=false
command-suspend=xfce4-session-logout --suspend
show-command-suspend=false
command-hibernate=xfce4-session-logout --hibernate
show-command-hibernate=true
command-logout=xfce4-session-logout
show-command-logout=true
command-menueditor=menulibre
show-command-menueditor=true
command-profile=mugshot
show-command-profile=true
search-actions=5

[action0]
name=Man Pages
pattern=#
command=exo-open --launch TerminalEmulator man %s
regex=false

[action1]
name=Web Search
pattern=?
command=exo-open --launch WebBrowser https://duckduckgo.com/?q=%u
regex=false

[action2]
name=Wikipedia
pattern=!w
command=exo-open --launch WebBrowser https://en.wikipedia.org/wiki/%u
regex=false

[action3]
name=Run in Terminal
pattern=!
command=exo-open --launch TerminalEmulator %s
regex=false

[action4]
name=Open URI
pattern=^(file|http|https):\\/\\/(.*)$
command=exo-open \\0
regex=true
Post Reply

Return to “Xfce”