19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Forum rules
Before you post please read how to get help
Post Reply
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

Hello! I have an interesting problem that I never face it before. Last night I did shut down normally my laptop and left it plugged in, then I started my computer and I had some problems with filesystem. OS does not started, I could see only ttys and could not login anyone.

Then I restarted with the power button and OS showed me BusyBox and also wanted me to use fsck for filesystem. I used it as fsck /dev/sda8 (filesystem), it worked but then I got very interesting and faulty desktop environment.


What happened? How can I fix this problem? Or is it possible to fix?

And also I haven't upgraded Mint before.
Last edited by cryark on Sun Aug 02, 2020 7:18 am, edited 3 times in total.
User avatar
Kadaitcha Man
Level 10
Level 10
Posts: 3117
Joined: Mon Aug 27, 2012 10:17 pm

Re: Desktop Environment Fails!

Post by Kadaitcha Man »

cryark wrote:
Sat Aug 01, 2020 8:12 am
... but then I got very interesting and faulty desktop environment.
Looking at that image, I think that the meaning of "very interesting and faulty desktop environment" is known only to you. You might want to describe the problem because that looks like someone's regular desktop.
It's pronounced kad-eye-cha, not kada-itcha.
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: Desktop Environment Failed Suddenly! XFCE Looks Like Faulty GNOME / Pantheon

Post by cryark »

OK, thanks for warning.

I used default desktop environment of XFCE before, things have changed suddenly. It was looking like this:

https://www.linuxmint.com/pictures/scre ... a/xfce.png

And also looking like faulty, look top-left corner and top-right bar. There are 2 wifi symbols.



I didn't do anything to change desktop environment, how can I return it to default?

By the way I can't get updates.
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 https://repo.steampowered.com/steam stable InRelease
Hit:3 http://ppa.launchpad.net/kdenlive/kdenl ... ble/ubuntu bionic InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:5 https://download.mono-project.com/repo/ubuntu vs-bionic InRelease
Err:1 http://dl.google.com/linux/chrome/deb stable InRelease
Unknown error executing apt-key
Hit:7 http://archive.canonical.com/ubuntu bionic InRelease
Err:2 https://repo.steampowered.com/steam stable InRelease
Unknown error executing apt-key
Hit:9 http://packages.microsoft.com/repos/vscode stable InRelease
Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Err:3 http://ppa.launchpad.net/kdenlive/kdenl ... ble/ubuntu bionic InRelease
Unknown error executing apt-key
Hit:10 http://ppa.launchpad.net/mixxx/mixxx/ubuntu bionic InRelease
Err:4 http://archive.ubuntu.com/ubuntu bionic InRelease
Unknown error executing apt-key
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Ign:12 http://packages.linuxmint.com tricia InRelease
Err:5 https://download.mono-project.com/repo/ubuntu vs-bionic InRelease
Unknown error executing apt-key
Hit:13 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease
Err:7 http://archive.canonical.com/ubuntu bionic InRelease
Unknown error executing apt-key
Hit:14 http://packages.linuxmint.com tricia Release
Err:9 http://packages.microsoft.com/repos/vscode stable InRelease
Unknown error executing apt-key
Hit:15 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease
Get:11 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Err:10 http://ppa.launchpad.net/mixxx/mixxx/ubuntu bionic InRelease
Unknown error executing apt-key
Err:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
Unknown error executing apt-key
Err:13 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease
Unknown error executing apt-key
Err:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Unknown error executing apt-key
Err:16 http://packages.linuxmint.com tricia Release.gpg
Unknown error executing apt-key
Err:15 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease
Unknown error executing apt-key
Err:11 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Unknown error executing apt-key
Hit:17 https://deb.nodesource.com/node_14.x bionic InRelease
Err:17 https://deb.nodesource.com/node_14.x bionic InRelease
Unknown error executing apt-key
Fetched 252 kB in 1s (176 kB/s)
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/chrome/deb stable InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.steampowered.com/steam stable InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net/kdenlive/kdenl ... ble/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.ubuntu.com/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://download.mono-project.com/repo/ubuntu vs-bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.canonical.com/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://packages.microsoft.com/repos/vscode stable InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net/mixxx/mixxx/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.ubuntu.com/ubuntu bionic-security InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.ubuntu.com/ubuntu bionic-updates InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://packages.linuxmint.com tricia Release: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.ubuntu.com/ubuntu bionic-backports InRelease: Unknown error executing apt-key
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://deb.nodesource.com/node_14.x bionic InRelease: Unknown error executing apt-key
W: Failed to fetch http://dl.google.com/linux/chrome/deb/d ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://ppa.launchpad.net/kdenlive/kdenl ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://ppa.launchpad.net/mixxx/mixxx/ub ... /InRelease Unknown error executing apt-key
W: Failed to fetch https://download.mono-project.com/repo/ ... /InRelease Unknown error executing apt-key
W: Failed to fetch https://deb.nodesource.com/node_14.x/di ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://ppa.launchpad.net/obsproject/obs ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic/InRelease Unknown error executing apt-key
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/ ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/ ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://archive.canonical.com/ubuntu/dis ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://ppa.launchpad.net/openshot.devel ... /InRelease Unknown error executing apt-key
W: Failed to fetch https://repo.steampowered.com/steam/dis ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://packages.microsoft.com/repos/vsc ... /InRelease Unknown error executing apt-key
W: Failed to fetch http://packages.linuxmint.com/dists/tricia/Release.gpg Unknown error executing apt-key
W: Some index files failed to download. They have been ignored, or old ones used instead.
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

That's the default configuration for Xfce. It's what you would see if Mint had not customised Xfce.

It looks like all your customisation have been lost.

Do you have a separate home partition?

Is it mounted?

Is it corrupted?
Image
User avatar
MrEen
Level 21
Level 21
Posts: 14013
Joined: Mon Jun 12, 2017 8:39 pm

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by MrEen »

I cannot help with the apt-key error, but this will restore the desktop to it's defaults:

Code: Select all

xfce4-panel --quit ; pkill xfconfd ; rm -rf ~/.config/xfce4/panel ; rm -rf ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml ; xfce4-panel
This is something that happens about once a month to someone and the developers haven't been able to pin down the cause.
User avatar
blackcarajillo
Level 3
Level 3
Posts: 113
Joined: Wed Jun 22, 2016 12:33 pm

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by blackcarajillo »

For the key errors I would try to open the software sources and go to maintenance and then add the missing keys.
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

Thank you everyone for all, I had tried few things to fix it before it went down worse. Desktop was not loading, and important packages were missing. So I completely removed 19.3 Tricia and installed 20.0 Ulyana. Everything now seems like better.

And by the way all package management systems / tools were completely down. Nothing could not be installed because of important packages that are missing like coreutils.
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

cryark wrote:
Sun Aug 02, 2020 7:06 am
Thank you everyone for all, I had tried few things to fix it before it went down worse. Desktop was not loading, and important packages were missing. So I completely removed 19.3 Tricia and installed 20.0 Ulyana. Everything now seems like better.

And by the way all package management systems / tools were completely down. Nothing could not be installed because of important packages that are missing like coreutils.
Boot from a Live USB, start gparted and run a full check on your partitions. Make sure it's not a failing disk.
Image
lonestar144
Level 1
Level 1
Posts: 24
Joined: Tue May 24, 2016 11:10 pm

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by lonestar144 »

mr_raider wrote:
Sun Aug 02, 2020 2:39 pm

Boot from a Live USB, start gparted and run a full check on your partitions. Make sure it's not a failing disk.
Agreed. I had exactly the same issues not long ago, of course a fresh install would fix it temporarily, the issues came back. So I did a RAM test and HHD test, the HDD had many errors. Replaced HDD and all is good.
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

mr_raider wrote:
Sun Aug 02, 2020 2:39 pm
cryark wrote:
Sun Aug 02, 2020 7:06 am
Thank you everyone for all, I had tried few things to fix it before it went down worse. Desktop was not loading, and important packages were missing. So I completely removed 19.3 Tricia and installed 20.0 Ulyana. Everything now seems like better.

And by the way all package management systems / tools were completely down. Nothing could not be installed because of important packages that are missing like coreutils.
Boot from a Live USB, start gparted and run a full check on your partitions. Make sure it's not a failing disk.
Let me try, I'll back here soon.
lonestar144 wrote:
Sun Aug 02, 2020 2:49 pm
mr_raider wrote:
Sun Aug 02, 2020 2:39 pm

Boot from a Live USB, start gparted and run a full check on your partitions. Make sure it's not a failing disk.
Agreed. I had exactly the same issues not long ago, of course a fresh install would fix it temporarily, the issues came back. So I did a RAM test and HHD test, the HDD had many errors. Replaced HDD and all is good.
I had checked my RAMs before I removed 19.3, there were no problems but HDD might be.


* * * * * * *


I have just checked my harddisk with smartctl, no errors found.
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

Run a file check if the partition using gparted or the command line. Make sure your FS is not corrupted. Ext4 corruptions are rare, but they can be nasty.
Image
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

mr_raider wrote:
Tue Aug 04, 2020 5:27 pm
Run a file check if the partition using gparted or the command line. Make sure your FS is not corrupted. Ext4 corruptions are rare, but they can be nasty.
Thanks, I don't have any corruption with my Filesystem with LM 20 Ulyana. I think it was a crash only. Maybe the main reason was my triple boot or not getting updates for 2 weeks.
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

cryark wrote:
Wed Aug 05, 2020 11:07 am
mr_raider wrote:
Tue Aug 04, 2020 5:27 pm
Run a file check if the partition using gparted or the command line. Make sure your FS is not corrupted. Ext4 corruptions are rare, but they can be nasty.
Thanks, I don't have any corruption with my Filesystem with LM 20 Ulyana. I think it was a crash only. Maybe the main reason was my triple boot or not getting updates for 2 weeks.
Are you sharing home folders between different Linux distros?
Image
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

mr_raider wrote:
Wed Aug 05, 2020 12:28 pm
cryark wrote:
Wed Aug 05, 2020 11:07 am
mr_raider wrote:
Tue Aug 04, 2020 5:27 pm
Run a file check if the partition using gparted or the command line. Make sure your FS is not corrupted. Ext4 corruptions are rare, but they can be nasty.
Thanks, I don't have any corruption with my Filesystem with LM 20 Ulyana. I think it was a crash only. Maybe the main reason was my triple boot or not getting updates for 2 weeks.
Are you sharing home folders between different Linux distros?
No, I'm not sharing. Manjaro and LM have different home folders and I also have Windows 10. But something is going wrong again with LM 20 too, but I don't know what was the source of the problems. NVIDIA icon is lost suddenly from panel sometimes, additional icons are not aligment and pinned (this was happening from the first installation LM 20). Should I report them as bugs? Or do I have problems with my OS?

An example:
Image
Steam and Discord is not looking aligned. Is it known issue? And there is a new problem I see, volume icon is faulty now. I can't open it or I can't remove the hover effect on it.

By the way, I've just remembered. Recent days I've got a error, actually it was directly kernel panic. I was working on mobile development but my memory could have not been enough so approximately 50% swap was using. When I finished my job, I closed AVD Manager and VSCode then I saw everything was working slow, system has got snap freezes, weak buffers, etc.. Briefly, LM was not functional to daily usage. Then I restarted the system with

Code: Select all

shutdown -r
to make system comfortable. Probably, system could not renew itself after 90% of 8 GB ram usage (and 50% swap of 2 GB). And the result is there, restart is failed.
Image

And now, installations are so slow. I better restart my system or soon reinstall LM 20 with another desktop environment. Actually, what do you think about other environments? Are they more flawless than XFCE?
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

These errors do not point to desktop environement issue, but rather some kind of corruption.

XFCE is a fairly stable DE, and as stable as MATE or Cinnamon, or more stable in some case.

You can verify by creating a new user in the sr manager and logging in. That should have a default config for the desktop. If that's not right, your base install has an issue.

Are you pulling in KDE dependencies with any of your programs?
Image
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

mr_raider wrote:
Mon Aug 24, 2020 10:35 pm
These errors do not point to desktop environement issue, but rather some kind of corruption.

XFCE is a fairly stable DE, and as stable as MATE or Cinnamon, or more stable in some case.

You can verify by creating a new user in the sr manager and logging in. That should have a default config for the desktop. If that's not right, your base install has an issue.

Are you pulling in KDE dependencies with any of your programs?
I think the main reason might be Rufus or my flashdrive now if there's a corruption. Because I remember I had faced some weird things in installation before it was finished. A part was taken so long and seems like repeating.

I've just tried. In the new user panel, icons are aligned.
Image

And I installed Kdenlive yesterday but the fault is been there too before the installation. I have KDE Connect and its derivatives which came from default installation. Other users have KDE Connect and its derivatives too. But they don't have any problems with the panel.

Is there any way to see all KDE dependencies? I'm only able to see which programs are built on KDE by its name.
mr_raider
Level 7
Level 7
Posts: 1880
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by mr_raider »

cryark wrote:
Tue Aug 25, 2020 5:15 am
mr_raider wrote:
Mon Aug 24, 2020 10:35 pm
These errors do not point to desktop environement issue, but rather some kind of corruption.

XFCE is a fairly stable DE, and as stable as MATE or Cinnamon, or more stable in some case.

You can verify by creating a new user in the sr manager and logging in. That should have a default config for the desktop. If that's not right, your base install has an issue.

Are you pulling in KDE dependencies with any of your programs?
I think the main reason might be Rufus or my flashdrive now if there's a corruption. Because I remember I had faced some weird things in installation before it was finished. A part was taken so long and seems like repeating.

I've just tried. In the new user panel, icons are aligned.
Image

And I installed Kdenlive yesterday but the fault is been there too before the installation. I have KDE Connect and its derivatives which came from default installation. Other users have KDE Connect and its derivatives too. But they don't have any problems with the panel.

Is there any way to see all KDE dependencies? I'm only able to see which programs are built on KDE by its name.
When install the program do it from the command line. It will show you what packages are being downloaded.
Image
cryark
Level 1
Level 1
Posts: 10
Joined: Sat Aug 01, 2020 7:56 am

Re: 19.3 Tricia Failed Suddenly! XFCE Now Looks Like Faulty GNOME / Pantheon

Post by cryark »

mr_raider wrote:
Tue Aug 25, 2020 6:05 pm
cryark wrote:
Tue Aug 25, 2020 5:15 am
mr_raider wrote:
Mon Aug 24, 2020 10:35 pm
These errors do not point to desktop environement issue, but rather some kind of corruption.

XFCE is a fairly stable DE, and as stable as MATE or Cinnamon, or more stable in some case.

You can verify by creating a new user in the sr manager and logging in. That should have a default config for the desktop. If that's not right, your base install has an issue.

Are you pulling in KDE dependencies with any of your programs?
I think the main reason might be Rufus or my flashdrive now if there's a corruption. Because I remember I had faced some weird things in installation before it was finished. A part was taken so long and seems like repeating.

I've just tried. In the new user panel, icons are aligned.
Image

And I installed Kdenlive yesterday but the fault is been there too before the installation. I have KDE Connect and its derivatives which came from default installation. Other users have KDE Connect and its derivatives too. But they don't have any problems with the panel.

Is there any way to see all KDE dependencies? I'm only able to see which programs are built on KDE by its name.
When install the program do it from the command line. It will show you what packages are being downloaded.
Actually I mean, installed dependencies.
Post Reply

Return to “Xfce”