language applet...disappears from the panel

Forum rules
Before you post please read how to get help
Post Reply
User avatar
tivasyk
Level 1
Level 1
Posts: 15
Joined: Sun May 31, 2009 4:22 am
Location: kyiv, ukraine
Contact:

language applet...disappears from the panel

Post by tivasyk »

i guess this one is not specific to linux mint 7, but rather to xfce... i'll post here though.

setup: linux mint 7, xfce ce. language switcher applet in the panel with two language layouts (us (), ua (unicode)).

problem: sometimes the language applet...disappears from the panel -- no pattern detected, although i suspect pidgin... the two language layouts remain switchable until reboot. the ~/.xsession-errors contains several lines with xfce4-xkb-plugin error:

Code: Select all

(xfce4-xkb-plugin:10005): GLib-CRITICAL **: g_hash_table_destroy: assertion `hash_table != NULL` failed
this is annoying, want to fix it somehow...
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: language applet...disappears from the panel

Post by Husse »

Welcome to Mint
the two language layouts remain switchable until reboot
Please clarify, this seems to be the opposite of your problem
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
User avatar
tivasyk
Level 1
Level 1
Posts: 15
Joined: Sun May 31, 2009 4:22 am
Location: kyiv, ukraine
Contact:

Re: language applet...disappears from the panel

Post by tivasyk »

Husse wrote:Welcome to Mint
the two language layouts remain switchable until reboot
Please clarify, this seems to be the opposite of your problem
that's exactly what happens: the language selection applet fails and disappears from the panel (no more flag indicator), however the two layouts remain switchable (via hotkey combination) as set up previously =/
«it's quite easy if you don't know how» (c) douglas adams
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: language applet...disappears from the panel

Post by Husse »

I see - unfortunately this rings no bells
Remove the applet and add it again, possibly with a reboot in between
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
User avatar
tivasyk
Level 1
Level 1
Posts: 15
Joined: Sun May 31, 2009 4:22 am
Location: kyiv, ukraine
Contact:

Re: language applet...disappears from the panel

Post by tivasyk »

this issue just keeps haunting me through several different machines, several (partial and full) reinstalls, several (4 now?) different linux mint versions…

what i do: a) install linux mint with only us (alt. international) keyboard layout; b) first thing after initial boot i add keyboard layout applet to the panel and c) add ukrainian (unicode) layout as second, set up ctrl+shift as switch hotkey.

usually the setup doesn't survive reboot or suspend: the second layout just „disappears“ from the applet. sometimes it does in the middle of a session without no apparent reason or indication of an error.

there's some progress though: with previous linux mint versions the whole applet used to crash and disappear from the panel, now (lmde 201108 xfce rc) it remains and only the second layout disappears.

can anyone at least try to reproduce this?
«it's quite easy if you don't know how» (c) douglas adams
edv
Level 1
Level 1
Posts: 11
Joined: Mon Aug 15, 2011 4:53 am
Location: Vilnius, Lithuania

Re: language applet...disappears from the panel

Post by edv »

When you add applet to the panel do not move it, just leave it in it's default position. It worked for me on Xfce 4.4
There could also be a conflict if you use some kind of script in step c) and not just plain xfce4-xkb-plugin

Also if there is no need for a language indicator you could ditch xfce4-xkb and use this command instead :

Code: Select all

setxkbmap -option grp:switch,grp:ctrl_shift_toggle,grp_led:scroll us,ua &
User avatar
tivasyk
Level 1
Level 1
Posts: 15
Joined: Sun May 31, 2009 4:22 am
Location: kyiv, ukraine
Contact:

Re: language applet...disappears from the panel

Post by tivasyk »

thanks for the support!
edv wrote:When you add applet to the panel do not move it, just leave it in it's default position. It worked for me on Xfce 4.4
There could also be a conflict if you use some kind of script in step c) and not just plain xfce4-xkb-plugin
quite interesting set of conditions =/
edv wrote:Also if there is no need for a language indicator you could ditch xfce4-xkb and use this command instead :

Code: Select all

setxkbmap -option grp:switch,grp:ctrl_shift_toggle,grp_led:scroll us,ua &
yes, good old setxkbmap is what i inevitable fall back to each time when i run into this problem. only for me it's

Code: Select all

setxkbmap -option -layout "us(intl),ua(unicode)" -option "grp:ctrl_shift_toggle"
in the list of autostart.
«it's quite easy if you don't know how» (c) douglas adams
Post Reply

Return to “Xfce”