Network Browsing (SMB) in XFCE Edition not available?

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Wraeththu
Level 1
Level 1
Posts: 14
Joined: Tue Oct 30, 2007 7:54 pm

Network Browsing (SMB) in XFCE Edition not available?

Post by Wraeththu »

I am using teh main edition on my other PCs, but recently installed Mint8 XFCE on my media center PC (older IBM desktop with Pentium IV)

It runs fine by now, but I am really missig the network browsing in the file manager (or a seperate network browser) as it is in gnome or in WinXP

I Was indeed able to set up Samba with "sambe system Settings" tool (very useful indeed) and the network works fine when I type in an existing share, fpr _Example in XBMC..no problem there at all

But I really miss the network browser in the system..am I just blind or is there none...and could I add one if there isnt?

fbsduser
Level 1
Level 1
Posts: 19
Joined: Thu Apr 01, 2010 12:11 am

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by fbsduser »

There should be an option in the mint tools to create a "Network" folder with all your SMB shares in your home folder.

Capt Turk
Level 3
Level 3
Posts: 104
Joined: Mon Aug 31, 2009 8:40 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by Capt Turk »

Same problem here. I installed Nautilus and made a launcher on the desktop for it. I can browse the network with no problem now. :D

saquerocl
Level 1
Level 1
Posts: 23
Joined: Sun Jul 19, 2009 9:01 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by saquerocl »

Mint XFCE comes with pyNeighborhood, a GTK +2 samba browsing utility. You can find it at Menu -> Network. I'm sharing files with windows xp systems at work. I use Mint XFCE, by the way. I don't know if I'm using the utility properly but is working well for me:

1. Find the other machine ip address.
2. Put it in pyNeighborhood, and perform an scan. (Edit -> Add machine -> enter ip address and press ok)
3. Set other parameters. Is easy.
4. Depending the directory you indicate to mount the other machine files, go there and voilá. Now you can put this directory in lateral panel of thunar for easy find it.
5. You should mount the other file system after start your machine. This is: go Menu -> pyNeighborhood, select the other machine and say mount.

Sorry my english, I speak spanish.

User avatar
gychang
Level 3
Level 3
Posts: 138
Joined: Tue Dec 09, 2008 12:24 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by gychang »

Capt Turk wrote:Same problem here. I installed Nautilus and made a launcher on the desktop for it. I can browse the network with no problem now. :D
I was unable to "see" the XP machine upstairs when I installed LM8 XFCE on my laptop downstairs (wireless). SMB did not work for me. Is your setup similar?

gychang
--
cruising the desert
--

User avatar
gychang
Level 3
Level 3
Posts: 138
Joined: Tue Dec 09, 2008 12:24 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by gychang »

Wraeththu wrote:I am using teh main edition on my other PCs, but recently installed Mint8 XFCE on my media center PC (older IBM desktop with Pentium IV)

It runs fine by now, but I am really missig the network browsing in the file manager (or a seperate network browser) as it is in gnome or in WinXP

I Was indeed able to set up Samba with "sambe system Settings" tool (very useful indeed) and the network works fine when I type in an existing share, fpr _Example in XBMC..no problem there at all

But I really miss the network browser in the system..am I just blind or is there none...and could I add one if there isnt?
Were you able to use the network with your XFCE machine?, I was unable to get this working so gave up on XFCE but if there is a work around I would try again.

gychang
--
cruising the desert
--

whvann08
Level 3
Level 3
Posts: 135
Joined: Sun Sep 14, 2008 2:01 pm
Location: North Carolina, USA

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by whvann08 »

IN the menu you will see program for remote file system. this is under your systems tab. This program is called Gigolo. It works great. When you start it you just select windows shares but make sure that you have smb packages downloaded. You can see if you can set up any file for sharing. If you try to share a file and it want let you it should prompt you to download the needed files for smb. I had this problem it installed my smb packages and I set up everything through Gigolo. I tried pyneighborhood first but it didn't work then I tried the network file in thunar and that would show my network but would not show my files in my shares from my other computer. I think it works of the pyneighborhood. because that was the same problem I had with it. Gigolo would be your best bet. Just put in the name of the other computer on your network and the name of your shared file and thats all you have to do. It just works. It was what kept me from going back to the gnome edition.

Henry
Image

jon armand
Level 1
Level 1
Posts: 3
Joined: Thu Mar 27, 2008 1:13 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by jon armand »

Network browsing with xfce
Try this tutorial:
http://ubuntuforums.org/showthread.php?t=304131
It worked fine for me on several computers in the past. :D

altair4
Level 20
Level 20
Posts: 10051
Joined: Tue Feb 03, 2009 10:27 am

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by altair4 »

HowTo: Using Gigolo to Mount Remote Samba Shares: http://forums.linuxmint.com/viewtopic.php?f=42&t=52144

If you prefere a non GUI method:

Auto Mount Samba Shares on Boot ( GVFS Method ): http://forums.linuxmint.com/viewtopic.php?f=42&t=42713
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Scrotu%90
Level 1
Level 1
Posts: 2
Joined: Fri Aug 12, 2011 1:38 am

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by Scrotu%90 »

can someone please help me get this working in xubuntu 10.10? i've followed all the instructions on the first post, tried adding the -s switch to fusesmb, tried using gigolo...nothing has gotten me the ability to browse my windows home network.

i really want to stick with xubuntu, because it runs really well on generic levitra this old inspiron 8100 laptop i'm posting from...but i need network browsing ability and i'm getting so frustrated with this at this point that i'm just about ready to smash the thing.
Last edited by Scrotu%90 on Wed Sep 28, 2011 2:43 am, edited 1 time in total.

hozomean
Level 1
Level 1
Posts: 33
Joined: Mon Jun 06, 2011 2:06 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by hozomean »

thunar can also connect samba shares directly if you know the full address, just choose "Go" -> "Open Location..." and in the box type something like smb://ip-address/sharename

foutchj
Level 1
Level 1
Posts: 1
Joined: Sat Dec 03, 2011 6:26 pm

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by foutchj »

I've searched for hours. pyNeighbourhood works for me. Actually, I feel my search is over.

I'm using Linux Mint 11 64-bit, 2.6.38-8-generic -

Click Menu> Software Manager> Search for pyneighborhood

1) Install. 2) Open. 3) In the lower left pane, Click + and expand to the folder you want to access (I'm selecting "Users") 4) Click the connect button (It sort of looks like a light switch, but its a cable plugged into an outlet) 5) enter the Login that you would use if you were actually logging into the other computer (NOT your router login) and that is it

Hope that helps. Its perfect for me. :)

altair4
Level 20
Level 20
Posts: 10051
Joined: Tue Feb 03, 2009 10:27 am

Re: Network Browsing (SMB) in XFCE Edition not available?

Post by altair4 »

Make sure the following packages are installed:
gvfs-backends
gvfs-fuse

Then Run the following command:

Code: Select all

thunar smb://
Then drag and drag from the location bar the "smb:///" icon if you are using the Toolbar style location or "Windows Network" is you are using the Pathbar style location to the left panel. When you do that you will end up with a bookmark labeled "Windows Network". Use that not "Network" to browse to the shares.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Xfce”