Debian Xfce Edition RC approved

Forum rules
Before you post please read how to get help
User avatar
Hezy
Level 3
Level 3
Posts: 103
Joined: Tue Mar 30, 2010 6:09 pm
Location: Israel
Contact:

Re: Debian Xfce Edition RC approved

Post by Hezy »

phil wrote:I do not like the grey metal appearance of the desktop so I changed to black and changed the theme to to Redmond. The grey is too light and lacks contrast for my 85 year old eyes.
phil, I think your problem may also be related to fact that there is a big difference in font rendering between Ubuntu and the Debian. On Debian the fonts are thiner. I actually like the way fonts look in Debian, but I have the eyes of a 37 years old kid ;)

You may want to follow this forum thread: http://forums.linuxmint.com/viewtopic.php?f=141&t=55896
keep on rockin' in the free world

[https://github.com/hezy]

phil
Level 3
Level 3
Posts: 141
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Debian Xfce Edition RC approved

Post by phil »

No, I think it is the presence of a light or white background (sometimes called glare). Black background with white type is so much easier to read, at least for me. Right now, as i type this, my eyes are starting to water. Thanks a lot for all your advise, though.

As a few of you may know, I am a Registered Engineer in Colorado since 1955 and in Belize for the last few years and spent many years using CAD since its beginning, and using computers since the beginning of the IBM 704. Always used a black screen background if I could. Not a problem though, I just set up my desk top to the way I like it.

I really like to use Synaptic and hope it will remain fully functional even if Mint Update gets to working.

Over all I would consider Debian Xfce better than Mint 9 Xfce which I am using on my main computer, especially the 32 bit version. At this point I am wondering if there is a good explanation for the 64 bit version using more resources than the 32 bit version. Again, not very important though, I will just keep the test computer running until I can make up my mind.

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: Debian Xfce Edition RC approved

Post by wayne128 »

MerelyJim wrote:
...and just in case it comes up, "so why aren't you running the straight Debian_xfce release," I tried. It couldn't recognize my network interface (RJ45 or Wifi), and when I copied the drives onto a flash-drive, no USB devices were recognized. This, I think, is why distro's are going to around for a long time.
@MerelyJim,

for quite a while I could not get internet on straight Debian 6 xfce, which is the Stable/squeeze.

finally I got it working when I got myself to learn and do Debian netinstall iso from the Testing branch. It has to do with firmware preloading in my case for broadcom/tg3. Your NIC might be different.

Anyway if you are interested and have not tried Testing branch, here is the link http://cdimage.debian.org/cdimage/weekly-builds/
when I copied the drives onto a flash-drive, no USB devices were recognized
Perhaps you use USB flash for installation? If yes, then Debian saw that as 'CDROM' during installation and provide an entry to fstab for /dev/sdx, when you reboot and run it, USB drive become not accessible. You can just comment out or remove that entry in fstab .

jeffreyC
Level 4
Level 4
Posts: 321
Joined: Mon Jun 07, 2010 9:34 pm

Re: Debian Xfce Edition RC approved

Post by jeffreyC »

If you need non-free firmware it may be available here

http://cdimage.debian.org/cdimage/unoff ... /firmware/

I did not need this for my own use, but as I understand how to use it is to put it into a USB flash drive and when the installer needs it you point the installer to it.
I have not done this.
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0

MerelyJim
Level 3
Level 3
Posts: 120
Joined: Sat Sep 05, 2009 5:03 pm
Location: Fort Worth, Texas, USA
Contact:

Re: Debian Xfce Edition RC approved

Post by MerelyJim »

wayne128 wrote:
MerelyJim wrote:
...and just in case it comes up, "so why aren't you running the straight Debian_xfce release," I tried. It couldn't recognize my network interface (RJ45 or Wifi), and when I copied the drives onto a flash-drive, no USB devices were recognized. This, I think, is why distro's are going to around for a long time.
@MerelyJim,

for quite a while I could not get internet on straight Debian 6 xfce, which is the Stable/squeeze.

finally I got it working when I got myself to learn and do Debian netinstall iso from the Testing branch. It has to do with firmware preloading in my case for broadcom/tg3. Your NIC might be different.

Anyway if you are interested and have not tried Testing branch, here is the link http://cdimage.debian.org/cdimage/weekly-builds/
when I copied the drives onto a flash-drive, no USB devices were recognized
Perhaps you use USB flash for installation? If yes, then Debian saw that as 'CDROM' during installation and provide an entry to fstab for /dev/sdx, when you reboot and run it, USB drive become not accessible. You can just comment out or remove that entry in fstab .
Ah, I think you make my point for me; such measures need not be taken if you use a distro based on Debian, rather then the original. I appreciate Ubuntu, Mint, Crunchbang, and god's know how many others for little tricks like this, and well as the diversity of "local" apps that get fed upstream. Not saying that I won't try it, you understand, just not going to try it tonight. Thanks.

Oh, and I used an external DVD-burner, plugged in via USB...
Um... you have a back-up copy,right?
My attempt at a blog; http://jims2011.blogspot.com/

User avatar
historyb
Level 2
Level 2
Posts: 52
Joined: Sun Dec 17, 2006 5:12 pm

Re: Debian Xfce Edition RC approved

Post by historyb »

I tried it and it will not work with my wireless. All new distros expect ubuntu and the derivates don't work with it. The wireless is an Realtek SemiConductor Wireless

jeffreyC
Level 4
Level 4
Posts: 321
Joined: Mon Jun 07, 2010 9:34 pm

Re: Debian Xfce Edition RC approved

Post by jeffreyC »

The Realtek wireless is one that uses non-free firmware, if you have a way to install that it should work then.
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0

User avatar
historyb
Level 2
Level 2
Posts: 52
Joined: Sun Dec 17, 2006 5:12 pm

Re: Debian Xfce Edition RC approved

Post by historyb »

jeffreyC wrote:The Realtek wireless is one that uses non-free firmware, if you have a way to install that it should work then.
Thank you :)

jeffreyC
Level 4
Level 4
Posts: 321
Joined: Mon Jun 07, 2010 9:34 pm

Re: Debian Xfce Edition RC approved

Post by jeffreyC »

Here is a link to the package

http://packages.debian.org/wheezy/firmware-realtek

Good luck
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0

User avatar
etech
Level 1
Level 1
Posts: 1
Joined: Tue Mar 29, 2011 9:27 pm

Re: Debian Xfce Edition RC approved

Post by etech »

I am loving Linux Mint Debian Xfce on my Dell Mini 9. With 2MB of RAM and a 16G SSD, it hauls donkeys ;) Thanks to Clem and all the developers for a great & stable release.
etech - loves Xfce!

glitchathon
Level 2
Level 2
Posts: 85
Joined: Thu Mar 17, 2011 12:27 pm

Re: Debian Xfce Edition RC approved

Post by glitchathon »

gosa wrote:Not sure I've seen anything about this, so I thought I'd make a note of them in case someone has an answer/is experiencing the same:

1. I can't seem to find anywhere to activate "tap to click" on my elantech touchpad. I'm pretty sure this worked in the Gnome version of LMDE. (Or am I just hallucinating about that one?)
2. It seems that I have to open the power manager after every boot to get my netbook to understand it's running on battery and display a battery icon in the panel.

Ideas anyone?

BTW - This is on a Asus EeePC 1000HE
Regarding #2, I have the same problem. I have the power setting set to always display battery. But I have to go into power manager everytime to activate it.

gosa
Level 4
Level 4
Posts: 303
Joined: Mon Nov 01, 2010 5:12 am
Location: Spain

Re: Debian Xfce Edition RC approved

Post by gosa »

glitchathon wrote:
gosa wrote:Not sure I've seen anything about this, so I thought I'd make a note of them in case someone has an answer/is experiencing the same:

1. I can't seem to find anywhere to activate "tap to click" on my elantech touchpad. I'm pretty sure this worked in the Gnome version of LMDE. (Or am I just hallucinating about that one?)
2. It seems that I have to open the power manager after every boot to get my netbook to understand it's running on battery and display a battery icon in the panel.

Ideas anyone?

BTW - This is on a Asus EeePC 1000HE
Regarding #2, I have the same problem. I have the power setting set to always display battery. But I have to go into power manager everytime to activate it.
- Do you also miss the "On Battery"-tab in the power manager when you open it right after reboot? I only have two tabs: "On AC Power" and "General". Not until I untick/tick that I want to display battery does the "On Battery" tab show up.

That's how it was at least until I threw it out after a couple of days. Had some problems getting the different Frequency modes to stick as well which is quite important in a computer depending on battery.
Now I'm back on the "Original" version of LMDE and thinking about just adding XFCE as a DE and minifying that...

aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Debian Xfce Edition RC approved

Post by aljoriz »

FOR LMDE XFCE RC touchpad double click emulation:

go to the terminal and type:

Code: Select all

sudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf


then replace with:

Code: Select all

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "VertEdgeScroll" "1"
EndSection
Then save the file, close gedit

go back to the terminal and type: sudo reboot

log-in and test the touch pad by tapping on it to open files

as for the battery I have reported it on https://bugs.launchpad.net/linuxmint/+bug/740808
and here is clem's response to wit:
The solution was to switch the default session from running xfce-session to running startxfce4, as well as replacing gnome-power-manager with xfce4-power-manager.

This will be fixed in the stable ISO.

On your system, you can simply select the "Xfce Session" the next time you're in GDM. And replace gnome-power-manager with xfce4-power-manager.

glitchathon
Level 2
Level 2
Posts: 85
Joined: Thu Mar 17, 2011 12:27 pm

Re: Debian Xfce Edition RC approved

Post by glitchathon »

gosa wrote:
- Do you also miss the "On Battery"-tab in the power manager when you open it right after reboot? I only have two tabs: "On AC Power" and "General". Not until I untick/tick that I want to display battery does the "On Battery" tab show up.

That's how it was at least until I threw it out after a couple of days. Had some problems getting the different Frequency modes to stick as well which is quite important in a computer depending on battery.
Now I'm back on the "Original" version of LMDE and thinking about just adding XFCE as a DE and minifying that...
yep i also experienced that same problem. the "on battery" did not show up until I closed the power manager, unplugged the power (to go onto battery) and open the power manager back up. I did not try your method but I imagine it is the same bug.

gosa
Level 4
Level 4
Posts: 303
Joined: Mon Nov 01, 2010 5:12 am
Location: Spain

Re: Debian Xfce Edition RC approved

Post by gosa »

aljoriz wrote:To save some space - read the previous post by aljoriz for the quote... :wink:
/gosa
- Interesting... Thanks!

@glitchathon

Seems there's a solution to that problem now...

aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Debian Xfce Edition RC approved

Post by aljoriz »

Glad to have helped, I found that answer while googling the debian forums for the touch pad.. so I really shouldn't be :oops: thanked but the community as a whole

glitchathon
Level 2
Level 2
Posts: 85
Joined: Thu Mar 17, 2011 12:27 pm

Re: Debian Xfce Edition RC approved

Post by glitchathon »

nice, I fixed the battery situation with the above instructions.

A couple of situations I ran into that was more difficult than the main edition:
- ibus not installed by default. and languages need to be added through the terminal. this is easy enough to do but the main edition was nice in having a GUI language section that takes care of all of that for you.
- AFAIK, there was no easy way to share with other network windows machines. In the main edition, with samba, nautilus was easy to navigage to windows machines. On this XFCE RC edition, I had to install Gigolo, which did not work easily until I also installed gvfs-fuse. I then had to add my user to the fuse group, and then modify the ~/.local/share/applications/defaults.list so that Thunar is used to open folders by gvfs-open. Maybe there was an easy way but this was definitely a lot of hoops to go through just to have windows sharing capabilities which worked out of the box on the main edition.

Another small issue: I go to Disk Utility to mount the NTFS drive, and it provides a link to start browsing, but it wants to launch Nautilus and not Thunar. I see no preferences in the GUI to change it, so right now, I have to navigate to /media to find it. Easy enough but perhaps this can be fixed?

Other than those 2 things, i LOVE xfce! I can get a great dock going with the XFCE panels, without needing to install anything. I did remove a lot of gnome apps and replaced with xfce ones. However, i did find Rhythmbox performed better than Exaile and Guayadeque, and I could not get QuodLibet to work, so I stuck with the Rhythmbox.

rekik
Level 3
Level 3
Posts: 198
Joined: Wed May 06, 2009 5:24 pm

Re: Debian Xfce Edition RC approved

Post by rekik »

but it wants to launch Nautilus and not Thunar. I see no preferences in the GUI to change it, so right now, I have to navigate to /media to find it. Easy enough but perhaps this can be fixed?
This post may help

glitchathon
Level 2
Level 2
Posts: 85
Joined: Thu Mar 17, 2011 12:27 pm

Re: Debian Xfce Edition RC approved

Post by glitchathon »

rekik wrote:
but it wants to launch Nautilus and not Thunar. I see no preferences in the GUI to change it, so right now, I have to navigate to /media to find it. Easy enough but perhaps this can be fixed?
This post may help
Thanks, but in this case, I do not have Nautilus installed. So it is not a problem with default file manager. It is just that the disk utility expects Nautilus and when I click on to browse the mounted drive, I get an error. I am wondering if I should install an XFCE disk utility and not use the gnome one?

glitchathon
Level 2
Level 2
Posts: 85
Joined: Thu Mar 17, 2011 12:27 pm

Re: Debian Xfce Edition RC approved

Post by glitchathon »

i am wondering if the Mint team plans to include a GUI for customizing the xfce menu? Or is the intention that the Mint Menu will be fully working and the recommended menu for customizability? At the moment, with the regular menu, it seems there is no right clickability on menu items and no easy way to customize it.

Post Reply

Return to “Xfce”