[SOLVED] Xfce Debian and Chromium/Chrome

Forum rules
Before you post please read how to get help
GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

[SOLVED] Xfce Debian and Chromium/Chrome

Post by GregE »

I am having an issue with Chrome and Chromium when running under Xfce on my Dell notebook and EeePC900 netbook. Mostly, but not always, the program loads but it cannot load any web pages. Sometimes it works just fine.

I have also had this issue when trying out Xubuntu 11.04 beta.

On both Firefox works as it should.

I have tried combinations of command switches --memory-model=high, medium and low and the problem still manifests itself.

On my desktop running LMDE both Chrome and Chromium work as they should, and on a previous install of LMDE on the notebook Chrome worked flawlessly.

I have tried removing config files and starting afresh. I have even downloaded a Chromium nightly build and run from a bin folder in my home folder.

I can get the Chromium installed in my home folder to run consistently by starting it with a script that is included in the download - except all the script seems to do is write menus entries for the local copy then load Chromium from the local rather than system directory.

So, anyone else having Chrome issues running under Mint Xfce Debian? Any solutions?

I am using the AMD64 edition, with a 2.6.38 liquorix kernel. I have TOR installed, but have tried removing it and it made no difference. I also have updated Xorg and video drivers from Sid. I have tried booting from the standard Mint kernel and that did not help.

As it stands I can make Chromium load and run properly, just not in a conventional way.

Everything else is working well and I hope to keep Mint Xfce on my notebook for a long time.

EDIT.
I just had a fail even using the chrome-wrapper script, so now I have no consistent process.
Last edited by GregE on Sat Jul 02, 2011 2:04 am, edited 1 time in total.

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Xfce Debian and Chromium/Chrome

Post by GregE »

When you look under the network settings in Chrome when running under Gnome you can fiddle with proxies etc. When running under Xfce it just says it is an unsupported platform and it cannot do anything except take what the system offers.

I suspect this is why it is failing, Chrome does not support Xfce and something else has to happen to get the network settings going before Chrome will function.

EDIT:

A bit more testing and the EeePC does not have any issues with Chrome. So now it is 32bit v 64bit or some thing peculiar to the Dell 11z

I might just wipe the Dell and put on the 32bit version and see what happens.

EDIT 2

I reinstalled Mint Xfce Debian in 32bit and duplicated my entire setup and Chrome works fine.

I do not think this is solved, merely sidestepped. I also do not think this is a Mint issue but upstream Debian AMD64 and Google Chrome 64bit as I also experienced it with Xubuntu 11.04 beta.

Edit 3

Installing 32bit was a waste of time, eventually I ended up in the same place after setting up Samba shares. When pages fail to load in Chrome it is just a matter of killing the page and reloading and then it works. It is just that stalled page loads seem to happen often when running Xfce and rarely happen when running Gnome.

I give up at this point. My 32bit Mint Xfce Debian is otherwise rock solid and I am not going to bother going through the process of reverting to 64bit. And, all along, Firefox kept working correctly.

Edit 4

Hohum, the joke is on me I think. It seems to be just the bleeding edge versions of Chromium and Chrome Unstable. They are not called unstable for nothing. Although it still stands that they work under Gnome without problems.




:)

eloir
Level 1
Level 1
Posts: 1
Joined: Wed May 18, 2011 9:31 am

Re: Xfce Debian and Chromium/Chrome

Post by eloir »

I have the same problem with Acer Aspire 1410 (intel celeron u2300 dual core @1.2 GHz 64bit) and LMDE Xfce release 201104

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Xfce Debian and Chromium/Chrome

Post by GregE »

@eloir

I am guessing that if you just keep updating the problem will just go away eventually. I have actually installed Xubuntu 11.04 on my notebook and it now runs Chrome without problem. I know that when Xubuntu was in alpha it did manifest this problem. Hopefully there is some lib file or whatever that will filter down to Debian testing and the errors will just go away.

Now that Xfce 4.8 is in testing I hope to reinstall LMDE Xfce with a clean install. I was also plagued by the touch pad and keyboard not working on boot. I now know the workaround required to fix that.

Chrome only officially supports Gnome and KDE so users of other desktops have to fend for themselves.

cheers

greg

LifeInTheGrey
Level 3
Level 3
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Boston

Re: Xfce Debian and Chromium/Chrome

Post by LifeInTheGrey »

I have discovered the solution after a TON of digging, however I need some assistance automating it.

The problem is that Chromium/Chrome do not recognize the desktop session as gnome, mainly because the "GNOME_DESKTOP_SESSION_ID=default" tag is missing. If you run this command in terminal:

export GNOME_DESKTOP_SESSION_ID=default

this provides the missing tag. I run this, and magically Chromium/Chrome works just as it should. Sweet.

The problem is the fact I need to type this into terminal every time. I have tried to create a script to (a) run on boot, or (b) run on network up, however neither actually export the command properly. I've set them to be executable and insserv'd them, but no dice. I know it is just because of my complete lack of script knowledge ... I must believe this can be automated. Can someone that's handy with script writing please help? We can marked this guy solved!
the beauty of linux is that the rabbit hole goes as deep as you want it to go.

LifeInTheGrey
Level 3
Level 3
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Boston

Re: Xfce Debian and Chromium/Chrome

Post by LifeInTheGrey »

Okay ... this works, but I'm not sure how efficiently. I edited the .bashrc file:

1) Enter in terminal:
gksudo gedit /etc/bash.bashrc

2) Scroll to the bottom, and create a new line

3) Add this line:
export GNOME_DESKTOP_SESSION_ID=default

4) Save and exit

5) Reboot

Any recommendations (other scripts to piggyback, or another script that loads at boot), let me know.
the beauty of linux is that the rabbit hole goes as deep as you want it to go.

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Xfce Debian and Chromium/Chrome

Post by GregE »

@LifeInTheGrey

Impressive work and persistence.

I just reinstalled LMDE Xfce as a base for a Gnome3 setup and the problem was worse than ever. Chrome would not load anything.

It is working fine under Gnome-Shell

Thank you

LifeInTheGrey
Level 3
Level 3
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Boston

Re: Xfce Debian and Chromium/Chrome

Post by LifeInTheGrey »

GregE wrote:@LifeInTheGrey

Impressive work and persistence.

I just reinstalled LMDE Xfce as a base for a Gnome3 setup and the problem was worse than ever. Chrome would not load anything.

It is working fine under Gnome-Shell

Thank you
Appreciate it, but ... inherent flaw, because its tied to .bashrc, you must open a terminal session first before the fix is applied. It turns out that basically the exports that I was originally trying to create a script for DO work ... they just didn't stick! I ran the command in terminal and Chromium worked perfectly, but if I closed the terminal it suddenly stopped. Reopen and reecho, the fix is gone. The .bashrc fix appears to stick even after the closure of the terminal, however because it still requires the opening of a terminal I believe it can be better.

I have read that adding a path in a script followed by the "&" symbol gets it to remain open, e.g.:

#!bin/sh/
export GNOME_DESKTOP_SESSION_ID=default
/usr/bin/chromium-browser &
### BEGIN INIT INFO
# Provides: gdsi_default
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time
# Description: Enable service provided by daemon.
### END INIT INFO

However I have not had the time to test this just yet (work and wife come first). I will post my results when I get the chance, however if someone with more script knowledge can provide confirmation or edits to that, I would greatly appreciate it.
the beauty of linux is that the rabbit hole goes as deep as you want it to go.

LifeInTheGrey
Level 3
Level 3
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Boston

Re: Xfce Debian and Chromium/Chrome

Post by LifeInTheGrey »

Okay ... before anyone asks, I'm not normally this obsessed with solving a problem ... but I can't stand Firefox. Or Midori. Or pretty much anything other than Chromium. So I MUST solve this problem ... and I finally did.

No scripts, no modification of bash files ... a simple. clean elegant solution. In terminal, type this:

echo “GNOME_DESKTOP_SESSION_ID=default” >> /etc/environment

This sets the environment when a new task is executed (like, say, when you open Chromium). It works.
the beauty of linux is that the rabbit hole goes as deep as you want it to go.

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Xfce Debian and Chromium/Chrome

Post by GregE »

@LifeInTheGrey

I have applied your fix, logged out and in and it seems to do the trick. Only time will tell.

I just reinstalled LMDE Xfce on my Dell 11z, and added Chrome. So far so good ....

I did have Xubuntu installed and the problem did not happen with that setup, but now I have removed it so I cannot tell if Ubuntu applied something like your fix.

cheers

Edit:

24 hours later and Chrome has worked flawlessly. Problem solved.
Last edited by GregE on Sat Jul 02, 2011 1:23 am, edited 1 time in total.

affirmedatheist
Level 1
Level 1
Posts: 11
Joined: Thu Apr 29, 2010 7:20 pm

Re: Xfce Debian and Chromium/Chrome

Post by affirmedatheist »

LifeInTheGrey wrote:Okay ... before anyone asks, I'm not normally this obsessed with solving a problem ... but I can't stand Firefox. Or Midori. Or pretty much anything other than Chromium. So I MUST solve this problem ... and I finally did.

No scripts, no modification of bash files ... a simple. clean elegant solution. In terminal, type this:

echo “GNOME_DESKTOP_SESSION_ID=default” >> /etc/environment

This sets the environment when a new task is executed (like, say, when you open Chromium). It works.
Works fine on amd64 as well. :D

Thanks. I don't use Chromium often, but I do like all of my browsers to work. :P
LMDE XFCE x86_64, Kernel 3.0.0.1, XFCE 4.8 | Gentoo Linux, Kernel 3.0.6, KDE 4.7.2, -march:core2 | Windows Vista Home Premium x64
Core 2 Quad Q9400, Kingston (value) 8GB DDR2 800MHz, GeForce GTX 550Ti, 320GB + 250GB HDD, ASUS P5Q-Pro motherboard.

Jay-Kay
Level 1
Level 1
Posts: 3
Joined: Fri Aug 13, 2010 7:36 am

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by Jay-Kay »

i had issues with upgrade because of "gnome environment"... anyone else?

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by Sleven »

+1 LifeInTheGrey, your solution worked great. I had the same problems with Chrome after installing LMDE Xfce 64bit. Thanks for another easy fix, easy on my end that is, sounds like you put a great deal of effort into it.

Edit:
One small bug Grey, it didn't stick.
When I rebooted Chrome went back to the way it was.
I applied your fix and everything is fine.
Did I miss something?

2nd Edit:
While updating using apt-get the following error was generated:

Preconfiguring packages ...
Setting up install-info (4.13a.dfsg.1-6) ...
/etc/environment: line 1: “GNOME_DESKTOP_SESSION_ID=default”: command not found
dpkg: error processing install-info (--configure):
subprocess installed post-installation script returned error exit status 127
configured to not write apport reports
Errors were encountered while processing:
install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

???
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by GregE »

There should not be quotation marks in the file /etc/environment - which that error indicates. Worth checking.

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by Sleven »

That worked perfect GregE, I edited out the quotation marks, update is working and the fix still works after rebooting, thanks.
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by secipolla »

Just to add. Maybe that line could be added to ~/.profile ? Then it would be only for the interested user.

I use GNOME 3 but I have IceWM too and I notice that Chrome can't read the saved passwords sometimes (I had this problem a lot before when using LXDE/Openbox/IceWM - saved passwords vanishing forever). Now I'm thinking it may be due to the same bug (in GNOME I never had the passwords lost).

In my case I'll add the export command to ~/.icewm/startup so it's used only with IceWM. Let's see if it works.

rtrev
Level 3
Level 3
Posts: 111
Joined: Fri Oct 15, 2010 11:11 am

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by rtrev »

Nothing worked for me until I deleted the /etc/environment file completely. Then Chrome, for the first time ever, began to work in this XFCE (RC) distro.

Go figure.

rakemup
Level 1
Level 1
Posts: 17
Joined: Wed Oct 20, 2010 6:08 pm

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by rakemup »

I've tried the entry above (without the quotation marks) -- and when that didn't work I deleted the /etc/environment file completely. That did not work either. I'm running Xfce MintDebian and I've tried to install Chrome (stable) and I've tried Chromium. I get no errors when installing - but the program just will not launch. No issues with FF. Any other ideas?

Thanks!

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by GregE »

rakemup wrote:I've tried the entry above (without the quotation marks) -- and when that didn't work I deleted the /etc/environment file completely. That did not work either. I'm running Xfce MintDebian and I've tried to install Chrome (stable) and I've tried Chromium. I get no errors when installing - but the program just will not launch. No issues with FF. Any other ideas?

Thanks!
Hi, I have not read this thread for a while so a week has gone since your entry. If you are still trying might I suggest you open a terminal and type google-chrome and see what happens. All the above stuff is to do with Chrome starting and running to a point, but not being able to open any pages. That is different to what you are experiencing. It is possible all you need is a manually created menu entry, and then the /etc/environment fix.

rakemup
Level 1
Level 1
Posts: 17
Joined: Wed Oct 20, 2010 6:08 pm

Re: [SOLVED] Xfce Debian and Chromium/Chrome

Post by rakemup »

Thanks for the reply. I just un-installed Chromium and then re-installed Chromium 13.0.782.107-r942 with Synaptic. "google-chrome" or "google-chromium" from the command line returns - command not found. "chromium" from the command line returns errors:

[3969:3980:1467480739:ERROR:shared_memory_posix.cc(158)] Creating shared memory in /dev/shm/.org.chromium.Chromium.ftTiqs failed: Too many levels of symbolic links
[3969:3980:1467480824:ERROR:shared_memory_posix.cc(161)] Unable to access(W_OK|X_OK) /dev/shm: Too many levels of symbolic links
[3969:3980:1467480911:FATAL:shared_memory_posix.cc(163)] This is frequently caused by incorrect permissions on /dev/shm. Try 'sudo chmod 1777 /dev/shm' to fix.
Aborted

sudo chmod 1777 /dev/shm ----- does not help

I do not have an /etc/environment file ------ removed last week

Post Reply

Return to “Xfce”