[SOLVED] Microphones on an HP HDX 16

Forum rules
Before you post please read how to get help
Post Reply
mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

[SOLVED] Microphones on an HP HDX 16

Post by mikecz »

I am slowly fixing all the glitches of Mint XFCE 201104 on my HP Pavilion HDX 16, and this is one that I think is due to my own unfamiliarity with audio setups under Linux.

The sound card works great (I had to add a line to /etc/modprobe.d/alsa-base.conf: options snd-hda-intel model=hp-m4) for playback, but I can't seem to get the internal mics to pick up, either under sound recorder or Skype.

Any pointers to how to go forward would be appreciated.

MikeC, who does know about computers. Really I do....
mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

Re: [SOLVED] Microphones on an HP HDX 16

Post by mikecz »

HOORAY! I FIGURED IT OUT!

First, for the HP HDX16, you need to add the following to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=hp-hdx

Though some HP laptops may also need:

options snd-hda-intel model=hp-m4

The machine has 2 mics, but apparently only 1 is being recognized (I don't know if its a HW fault, but I somehow doubt it).

In the ALSA Mixer, the device is called "Capture", and to select it as a source you need to make it visible using the Select Controls button at the bottom. Each "Capture" device has 2 sliders: the one on the left has a link button under it to cause the 2 sliders to move in sync, and the one on the right has the selector button to make the device active (this was a point of confusion for me, since to make it active you click on the button and it turns red; I thought that would mute the microphone the way clicking on the buttons on the speakers controls do). On my machine there is a "Capture 1" device that I thought was the 2nd mic, but I don't think it is; the 2 sliders may represent both physical mics as one logical device, but frankly I'm not going to tinker with it now that its working.

However, confusingly, the Pulseaudio Volume Control panel calls this device “Microphone 2“. To set Pulseaudio to see it, in the Pulseaudio control panel go to the Input Devices tab > Internal Audio Analog Stereo > Port: Microphone 2.

This may not be quite as technical as some other posts hereabouts, but it seems to have been something that no one has been able to puzzle out, and I figured it would be a nice thing to document once and for all.

MikeC
Post Reply

Return to “Xfce”