Setting font size in Mint Control Center solved

Forum rules
Before you post please read how to get help
Post Reply
cavgirl
Level 1
Level 1
Posts: 24
Joined: Mon Dec 03, 2007 5:46 pm

Setting font size in Mint Control Center solved

Post by cavgirl » Sun Dec 09, 2007 6:44 pm

Hi,
I'm running Daryna XFCE which I really like. I also have an EEE pc and think Mint would do well on it. But... the text in the MCC itself (I don't mean the system wide font) is tiny when you try to run the os at 800x480. Eg, the tabbed buttons that run along the top (Hardware, Desktop etc) are absolutely fine, but the options within each 'tabbed' area... the font is microscopic. Even when it's running on 1200x800, I notice that the font there is still small, but at least then it matters less. Before I even *try* to put this onto the Eee, does anyone know how this can be solved? Thanks.

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Setting font size in Mint Control Center

Post by Husse » Fri Dec 14, 2007 8:25 am

The fonts look larger in a higher resolution?
They should look smaller, and with the resolutions you mention, considerably smaller.
Seems to me that there is something else going on
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Bmoth
Level 1
Level 1
Posts: 1
Joined: Sun Jan 06, 2008 6:29 pm

Re: Setting font size in Mint Control Center

Post by Bmoth » Sun Jan 06, 2008 6:42 pm

Hi,

I also have a similar problem in terms of font size using Darnya and XFCE. I am using a Samsung X50 with ATI X700 running at 1280 x 800 resolution using the ATI driver. All menu headings etc are fine however the text within individual windows is very small (too small to read). For example, when opening a web page in FIrefox it is necessary to manually increase the font size (by either using Ctrl plus the mouse wheel or Ctrl +) so that the content can be read. I have previously installed and run Ubuntu Gutsy and gnome versions of cassandra and had no problem. Below is a copy of my xorg.conf. Any help would be greatly appreciated.

Code: Select all

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Identifier     "Default Layout"
	Screen         "Default Screen" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
	InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ImPS/2"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
	Identifier  "Synaptics Touchpad"
	Driver      "synaptics"
	Option	    "SendCoreEvents" "true"
	Option	    "Device" "/dev/psaux"
	Option	    "Protocol" "auto-dev"
	Option	    "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
	Identifier  "stylus"
	Driver      "wacom"
	Option	    "Device" "/dev/input/wacom"
	Option	    "Type" "stylus"
	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier  "eraser"
	Driver      "wacom"
	Option	    "Device" "/dev/input/wacom"
	Option	    "Type" "eraser"
	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier  "cursor"
	Driver      "wacom"
	Option	    "Device" "/dev/input/wacom"
	Option	    "Type" "cursor"
	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
	Identifier  "Samsung"
	Option	    "DPMS"
EndSection

Section "Device"

	#Added from the compiz.org/ATI site
	Identifier  "ATI Technologies Inc [Radeon X700 Pro (PCIE)]"
	Driver      "fglrx"
	Option	    "DRI" "on"
	Option	    "VideoOverlay" "on"
	Option	    "ColorTiling" "on"
	Option	    "EnablePageFlip" "true"
	Option	    "AccelMethod" "XXA"
	Option	    "XAANoOffscreenPixmaps" "on"
	Option	    "AGPMode" "8"
	Option	    "AGPFastWrite" "yes"
	Option	    "RenderAccel" "on"
	#Some experimental options!
	Option	    "OpenGLOverlay" "off"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Default Screen"
	Device     "ATI Technologies Inc [Radeon X700 Pro (PCIE)]"
	Monitor    "Samsung"
	DefaultDepth     24
	SubSection "Display"
		Modes    "1280x800" 
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

Section "Extensions"
	Option	    	"Composite" "Enable"
	Option 		"DAMAGE" "true"
	Option 		"RENDER" "true"
EndSection

#Added as per 
# http://linux.wordpress.com/2007/11/22/update-running-compiz-fusion-using-ati-cards-and-aiglx/

Section "ServerFlags"
  	Option 		"IgnoreABI" 	"on"
	Option 		"AIGLX" 	"true"
EndSection


McLovin
Level 5
Level 5
Posts: 761
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: Setting font size in Mint Control Center

Post by McLovin » Mon Jan 07, 2008 12:23 pm

Are you both using ATI cards?

skan
Level 1
Level 1
Posts: 7
Joined: Wed Jan 16, 2008 7:29 pm

Re: Setting font size in Mint Control Center

Post by skan » Wed Jan 16, 2008 7:32 pm

Hello
Same problem for me, It's really difficult to read the menus,
I'm using an Nvidia MX440

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Setting font size in Mint Control Center

Post by Husse » Thu Jan 17, 2008 7:07 am

Welcome to Mint skan
Which driver do you use?
MX440 is an old card and should have the legacy driver
This can be a driver problem
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

skan
Level 1
Level 1
Posts: 7
Joined: Wed Jan 16, 2008 7:29 pm

Re: Setting font size in Mint Control Center

Post by skan » Thu Jan 17, 2008 9:16 am

Hi
Mint installs it automaticlly something like nvidia-96xx
Everythig works properly (that's the reason I like Mint) with 3D acceleration, thus I guess the driver is OK.
I've also tried with sh NVIDIA-Linux-x86-96.43.01-pkg1.run and several options, and I end up with the same problem, everything seems to be OK but the font is really small, now is even smaller than before and I can't use XServer nor change the options because I'm not able to read anytinhg.
How can I change font size from the keyboard?

skan
Level 1
Level 1
Posts: 7
Joined: Wed Jan 16, 2008 7:29 pm

Re: Setting font size in Mint Control Center

Post by skan » Thu Jan 17, 2008 9:38 am


skan
Level 1
Level 1
Posts: 7
Joined: Wed Jan 16, 2008 7:29 pm

Re: Setting font size in Mint Control Center

Post by skan » Thu Jan 17, 2008 5:17 pm

I've found the best solution is to add this line

Xft.dpi: 96

to the file .Xresources on your base directory

you may need to create it
echo "Xft.dpi: 96" >> ~/.Xresources

User avatar
Zwopper
Level 10
Level 10
Posts: 3077
Joined: Fri Nov 30, 2007 12:20 pm
Location: Deep in the Swedish woods
Contact:

Re: Setting font size in Mint Control Center

Post by Zwopper » Sun May 11, 2008 10:31 am

skan wrote:I've found the best solution is to add this line

Xft.dpi: 96

to the file .Xresources on your base directory

you may need to create it
echo "Xft.dpi: 96" >> ~/.Xresources
It worked like a charm, thank you!
Image
My artwork at deviantART | My Band - Electric Alchemea
CREA DIEM!

Lenovo U330P | i5 | 16GB | 128GB - SSD | Elemantary OS 0.4

sp00ki

Re: Setting font size in Mint Control Center solved

Post by sp00ki » Fri Jul 04, 2008 2:43 pm

Fix works brilliantly-- another addition to the notebook!

Thanks.

infamous
Level 2
Level 2
Posts: 72
Joined: Mon Aug 04, 2008 4:21 pm

Re: Setting font size in Mint Control Center solved

Post by infamous » Sun Sep 14, 2008 10:42 am

Now if someone could tell me how to fix it for gnome and kde I would be happy.

rhodry
Level 4
Level 4
Posts: 343
Joined: Mon Jun 04, 2007 7:32 am

Re: Setting font size in Mint Control Center solved

Post by rhodry » Sun Sep 14, 2008 9:48 pm

If you run (at a terminal prompt):

$ xdpyinfo |grep dimension and
$ xdpyinfo |grep resolution

you will see the dimension and resolution settings being provided to your X server by your monitor.

In my experience on a 1280x1024 monitor under any Ubuntu-based opsys you will get a result of 95x96 for the dpi figure. And fonts are usually pretty crappy for me in Ubuntu/Mint etc.

You can try putting the following two lines in your /etc/X11/xorg.conf file in the "Devices" section:

Option "UseEdidDpi" "False"
Option "DPI" "96 x 96"

This tells the X server to ignore dpi settings coming from the monitor and to set it at 96 dpi.

This should work for any window manager because the server loads before the session.

It may or may not help but it will set your dpi to a known figure?!

Rhodry.

Post Reply

Return to “Xfce”