XFCE & "initrd.img-2.6.39-2-686-pae"

Forum rules
Before you post please read how to get help
Post Reply
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

Hello, I'm back to test the new marvels!

I use LinuxMint 11 32-bit & 64-bit without a glitch on different computers, but I have a strange problem with Linux Mint Xfce 32-bit, with a PIV processor.

After the last upgrade, I got this message :


update-initramfs: Generating /boot/initrd.img-2.6.39-2-686-pae
cp: impossible d'évaluer « /lib/libacl* »: Aucun fichier ou dossier de ce type
E: /usr/share/initramfs-tools/hooks/live failed with return 1.
update-initramfs: failed for /boot/initrd.img-2.6.39-2-686-pae with 1.
dpkg : erreur de traitement de initramfs-tools (--configure) :

I suspect the PIV processor to be unable to deal with "pae" instructions... What to you think about this?

Eventually, how to return to a 686 version without "pae" set, without mess?

Thanks a lot in advance for your help!

:)
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by xenopeek »

I'm not sure about the non-english text in there :) But PAE should not be the problem; this is a feature provided by all Pentium Pro and above processors, so also on your Pentium IV (source: http://en.wikipedia.org/wiki/Physical_Address_Extension).

The 2.6.39-2 kernel won't boot on my machine with LM 11 GNOME. I'd rollback to 2.6.38-8.
Image
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

First, many thanks for your very fast answer!

It's very strange, as I have no problem at all, with others processors...

As I dont know if a "standard 2.6.39-2" exists, I don't remenber how to rollback smoothly to 2.6.38-8: can you provide me the reminder and/or the how-to?

Thanks again for your help!

:)
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by xenopeek »

You can select an older kernel during GRUB boot. If by default your GRUB boot menu doesn't show (it only does on dualboot install, or if you configured it to), press and hold shift during boot to get to it. Select an older kernel from there, to see if that works alright.
Image
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

Merci Vincent !

J'avais complètement oublié, le coup du "shift" au démarrage, pour voir les autres entrées du menu Grub !

The only last kernel is "2.6.32-5-686" and I used it...

Just for the fun I tempted "sudo apt-get update && sudo apt-get upgrade" and again I got this message:


Paramétrage de initramfs-tools (0.99) ...
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-2.6.39-2-686-pae
cp: impossible d'évaluer « /lib/libacl* »: Aucun fichier ou dossier de ce type
E: /usr/share/initramfs-tools/hooks/live failed with return 1.
update-initramfs: failed for /boot/initrd.img-2.6.39-2-686-pae with 1.
dpkg : erreur de traitement de initramfs-tools (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
configured to not write apport reports
Des erreurs ont été rencontrées pendant l'exécution :
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

May be I have a broken package?

It has been for such a long time since I used the console (the LinuxMint distributions are too good) and, I don't remember how to hunt the broken packages...

Thanks in advance, for your help!


:)
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

No broken packages using Synaptic (personalized filter)...

I tried also "sudo apt-get install initramfs-tools --reinstall" without success...

I understand nothing more there!

Any suggestions?

:)
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by xenopeek »

Oops, I thought you got those errors during boot. This does indeed look like broken package. You can try to open the Package Manager (Synaptic) and from the Edit menu select "Fix Broken Packages".
Image
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

Bizarre, vous avez dit bizarre ?

No success too...

I saw this info: http://packages.debian.org/fr/sid/linux ... 6.39-2-486

It's about a Linux-image-2.6.39-2-486 (2.6.39-3) for older PCs (with only one processor, I imagine).

Under Synaptic, I found and installed "2.6.39-486" and removed "2.6.39-2-686-pae", but there is still a problem with "initramfs-tools":


Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.39-2-486
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

I think I will retry everything from scratch...

:)
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

Fresh new install on PIV board, with no problem, this time!?!?

"Gestionnaire de logiciels" (ie. mintinstall) is not running correctly: may be a temporary Repo issue?

Thanks a lot again,

:)
Last edited by Melchior on Sun Jul 10, 2011 8:02 am, edited 1 time in total.
Melchior
Level 1
Level 1
Posts: 7
Joined: Sat Apr 21, 2007 6:23 am

Re: XFCE & "initrd.img-2.6.39-2-686-pae"

Post by Melchior »

Finally, I found the problem:

raise ImportError("The _imagingft C module is not installed")
ImportError: The _imagingft C module is not installed

And I think I found an old solution here, for the same problem: http://forums.linuxmint.com/viewtopic.p ... 8&p=446333 but python version is 2.6.6.14 now!

Re: Software Manager Hangs on Gathering Information
by andyfang on Sun Jul 10, 2011 4:27 am

I found the solution !
when package "python-imaging" version is 1.1.7.3
this error will happen.
so .
get the "python-imaging" version 1.1.7.2 from Debian stable package ,
http://packages.debian.org/squeeze/python-imaging
than, remove python-imaging 1.1.7.3 and install 1.1.7.2
you can get the right result.

Thanks again,

:)
Post Reply

Return to “Xfce”