Hibernate button and functionality not present by default

Forum rules
Before you post please read how to get help
Post Reply
lindsey
Level 1
Level 1
Posts: 24
Joined: Tue Sep 20, 2011 1:53 am

Hibernate button and functionality not present by default

Post by lindsey »

A similar problem was not resolved in this previous thread. The hibernate button is missing and the OP claims that though it can be brought back by mounting swap, the button is not functional.

I don't understand why hibernate is not present by default. I feel I shouldn't have to troubleshoot this.

Symptoms:

Computer 1 (LMDE): Hibernate button missing
Computer 2 (also LMDE): Hibernate button logs you out instead

I mean, come on... I really wanted to give LMDE a chance but this is just offputting...

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Hibernate button and functionality not present by defaul

Post by AlbertP »

At me, hibernate or sleep logs me off first, and then after a few seconds the computer goes into hibernate/sleep.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

lmintnewb
Level 7
Level 7
Posts: 1568
Joined: Fri Apr 01, 2011 5:13 pm

Re: Hibernate button and functionality not present by defaul

Post by lmintnewb »

For me, using another distro. When I want to suspend, I just open a terminal and type sudo pm-suspend, enter pw and whamo comp goes into suspend mode. Believe ya need to have a power manager package installed. Think this gnu/nix OS uses the one from xfce and of course you'd need a working swap. With the entries for it correct in /etc/fstab and similar.

So for you ... sudo pm-hibernate may accomplish what you're after too. Not as friendly as a button to push though. Also use at your own risk, as am not using lmde/etc. Though it is o course a Debian based OS here.

LM it seems is still new to using Debian as their OS base. May take them awhile to iron out some issues. Never tried it myself. Does seem to be some strange happenings going on with LM Debian. Making it a challenge to auto login ( cause of gdm3 apparently) and not having hibernate setup by default is a lil odd. Have faith that they're working on it and will work it out.

lindsey
Level 1
Level 1
Posts: 24
Joined: Tue Sep 20, 2011 1:53 am

Re: Hibernate button and functionality not present by defaul

Post by lindsey »

Thanks for your thoughts guys.

Computer 2's hibernate function was enabled by creating a new swap space. I'd assumed one would be created by default as it has been with all my Debian installations on guided install, but not the case with LMDE.

Computer 1 is still unable to hibernate. I'll have to recheck if it has swap space set up properly, but it's odd that hibernate is available by default on one computer (incidentally, the older one) and not on the other. I just think it should be an outright default. When people have to hack about or troubleshoot simple things like this, they begin to lose faith in the distro...

lindsey
Level 1
Level 1
Posts: 24
Joined: Tue Sep 20, 2011 1:53 am

Re: Hibernate button and functionality not present by defaul

Post by lindsey »

Works on computer 1 now. Not sure what did it, I certainly didn't change anything. Somehow it was being erratic. Perhaps my first attempt to hibernate was somehow interrupted... We may never know now, but thanks guys, truly.

Edit: Spoke too soon. Nup, doesn't work again. Just triggers lock out screen, but doesn't actually hibernate.

Post Reply

Return to “Xfce”