Page 1 of 1

Problem with forum software?

Posted: Sat Mar 21, 2015 11:35 am
by Cosmo.
Do we have a problem with the forum?

At the time of writing I have big diffuculties on whatever I do here:
Logging in, Reading posts, submitting post, going back from a post to the table of contents of the board.

I have seen in the last few minutes at least 5 times a page telling me:
General Error
SQL ERROR [ mysql4 ]

Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (11) [2002]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
Another symptom is, that I have partially to wait several minutes, until a thread gets opened, if I click on it's title. This does happen regardless, if I am logged in or not. Also does the message indicate, that the problem seems to be in the forum's software.
But this does not happen every time. I just made a preview for this post and I got it in between a second (as normal). Maybe the server has some hiccup,

Otherwise my Internet connections does not show any special behavior, so I do not believe the problem is on my side.

P.S. I tried to identify the correct board for this thread. If I should be wrong with choosing this one, please give me an advice for the future.

Re: Problem with forum software?

Posted: Sat Mar 21, 2015 2:25 pm
by xenopeek
Might have been that there were problems earlier today, but it seems mostly fine now (it's a bit slower sometimes). Thanks for reporting it; we'll monitor the situation.

Re: Problem with forum software?

Posted: Sat Mar 21, 2015 4:05 pm
by Maik
Just read the posts above, clicked the 'back' button on my browser - and got the same General Error message as Cosmo.

Re: Problem with forum software?

Posted: Sat Mar 21, 2015 4:31 pm
by jimallyn
That sort of thing happens to me now and then, too. It's usually back to normal in a few minutes.

Re: Problem with forum software?

Posted: Sat Mar 21, 2015 6:13 pm
by WinterTroubles
Mint servers see huge spikes in traffic due to the high level of anticipation for the recently announced Betsy RC......

....... Possibly? :mrgreen:

Re: Problem with forum software?

Posted: Thu Apr 09, 2015 11:04 am
by Cosmo.
One day or so after my report above things worked well again - until today.

Some probably interesting details:
This time I did not get the mysql error page.
What happened was this: I visited a thread with unread posts (red icon), I wanted to reply: nothing. FF showed for 2 minutes the activity circle in the tab, and that was it. Not even a timeout error.
I refreshed the page, again 2 minutes of activity showing in the tab, and that's it. Not even the red icons changed to white ones.

I cleared the cache, I restarted FF, nothing helped. I tried it for half an hour, before I gave up. The symptoms were always the same. I could not leave the thread, I could do nothing.

What is interesting is the fact, that I could browse at the same time in another tab As said, the cache has been cleared, so all came from the server, but I intentionally went to entries, I did never visit before and obviously the domain worked just as expected, whereas there was this reproducible problem in the forum.
That means in the consequence, that either or the software or the database behind it has a problem (IMHO).

Obviously I can now use the forum again, this is about 2.5 hours later. I find it important enough to report this (mainly for the admins).

I submitted my post, this worked in a second, and came as usual to the page, where you can choose, whether you want to go to your submitted post or to somewhere else. I choose seeing my post and that again took 20 to 30 seconds, IMO far to long as being normal.

Re: Problem with forum software?

Posted: Thu Apr 09, 2015 11:45 am
by karlchen
Hm, have not been affected by any such problem today.

Re: Problem with forum software?

Posted: Wed Apr 15, 2015 3:55 pm
by dialt1
it's odd. I haven't any problem with it.

Re: Problem with forum software?

Posted: Fri Apr 17, 2015 8:26 am
by /dev/urandom
Ah, good old phpBB with its unstable database connectors.