[Antergos] Firefox with CSD has useless border around window - in maximized window!

Chat about just about anything else
Post Reply
cvan997
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2016 3:40 pm

[Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by cvan997 » Sun Mar 18, 2018 7:57 am

Firefox with CSD (Client Side Decorator) has useless border around window - in maximized window!
In GNOME Shell no has this border. In Cinnamon has.
Other program do not have this border neither on the GNOME Shell nor on the Cinnamon.
Problem is in Firefox + CSD + Cinnamon.

I use Antergos(Arch) + Cinnamon.

It is ugly and interferes with selecting tabs and scrolling with the scroll bar.

How hide this border?

User avatar
xenopeek
Level 24
Level 24
Posts: 22762
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by xenopeek » Sun Mar 18, 2018 8:26 am

For help with Antergos I suggest you use their support forum: https://forum.antergos.com/category/29/cinnamon

This forum is for help with Linux Mint.
Image

cvan997
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2016 3:40 pm

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by cvan997 » Sun Mar 18, 2018 9:21 am

Thanks, but I suppose that the error can occur in Cinnamon also on the Linux Mint. That solving the problem is the same on every system.

User avatar
xenopeek
Level 24
Level 24
Posts: 22762
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by xenopeek » Mon Mar 19, 2018 3:34 am

Linux Mint is using Firefox 59. I installed Firefox 60 beta from the PreBeta PPA and can see your observation (I think) when the titlebar is disabled in Firefox and the window theme of Cinnamon is set to Mint-X. It puts a dark gray border around the maximized Firefox window that isn't put around other maximized windows. Switching to Mint-Y window theme, or reverting disabling of the titlebar, removes the dark gray border.

What versions of all the software and themes Antergos uses I don't know so there can be other differences.

Firefox 60 with titlebar disabled, on Linux Mint 18.3 Cinnamon with Mint-X theme (zoomed x8):
Image

with Mint-Y theme:
Image

We'll have to see if once Firefox 60 is released it actually has this feature and implements it as it currently does (as this feature was supposed to be in Firefox 59 but was modified and delayed to Firefox 60). The Mint-X theme designer is aware of your observation.
Image

cvan997
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2016 3:40 pm

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by cvan997 » Mon Mar 19, 2018 4:41 am

xenopeek wrote:
Mon Mar 19, 2018 3:34 am
We'll have to see if once Firefox 60 is released it actually has this feature and implements it as it currently does (as this feature was supposed to be in Firefox 59 but was modified and delayed to Firefox 60). The Mint-X theme designer is aware of your observation.
And what can I modify now so that the border disappears?
I have to use Dev Edition (actually Beta) because otherwise old add-ons do not work (and so some of them stopped working).
One of these additions was Hide Caption Titlebar Plus, but it stopped working even in Dev Editon(Mozilla removes rests of old API - But I fight as much as I can).
Mozilla offered replacement, but it was underdeveloped.

User avatar
xenopeek
Level 24
Level 24
Posts: 22762
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by xenopeek » Mon Mar 19, 2018 4:46 am

xenopeek wrote:Switching to Mint-Y window theme [...] removes the dark gray border.
Image

cvan997
Level 1
Level 1
Posts: 5
Joined: Tue Jul 05, 2016 3:40 pm

Re: [Antergos] Firefox with CSD has useless border around window - in maximized window!

Post by cvan997 » Mon Mar 19, 2018 5:47 am

xenopeek wrote:
Mon Mar 19, 2018 4:46 am
xenopeek wrote:Switching to Mint-Y window theme [...] removes the dark gray border.
Oh, sorry. I misunderstood this.
It actually works. Thanks.

Post Reply

Return to “Open chat”