.

Chat about just about anything else
Post Reply
LLS
Level 2
Level 2
Posts: 98
Joined: Sat Nov 18, 2017 9:38 am

.

Post by LLS »

.
Last edited by LLS on Wed Mar 11, 2020 9:52 am, edited 1 time in total.

sleeper12
Level 7
Level 7
Posts: 1957
Joined: Thu May 25, 2017 3:22 pm

Re: How to stop web page redirecting

Post by sleeper12 »

Not sure if it will help, but you might want to update Firefox to 69.0.

User avatar
murray
Level 5
Level 5
Posts: 673
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: How to stop web page redirecting

Post by murray »

If you briefly see the .co.uk page before the .com appears then that suggests that the redirection is being done in client-side Javascript rather than server-side. You could try stopping the page as soon as it's loaded (eg hitting the Esc key or clicking the X in the toolbar). Another way to stop it would be in about:config set accessibility.blockautorefresh to true (however this will stop all pages from refreshing/redirecting).
Running Mint 19.3 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

LLS
Level 2
Level 2
Posts: 98
Joined: Sat Nov 18, 2017 9:38 am

Post by LLS »

.
Last edited by LLS on Wed Mar 11, 2020 9:52 am, edited 1 time in total.

sleeper12
Level 7
Level 7
Posts: 1957
Joined: Thu May 25, 2017 3:22 pm

Re: How to stop web page redirecting

Post by sleeper12 »

Does it do the same in Firefox Private Window or on a different browser? In any case, you really should update Firefox to the latest version.

User avatar
BG405
Level 8
Level 8
Posts: 2020
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: How to stop web page redirecting

Post by BG405 »

I found this on the Mozilla Support forum:
This is a feature called "Domain Guessing", described here: https://support.mozilla.com/en-US/kb/se ... n-guessing

You can turn it off by setting browser.fixup.alternate.enabled to false in about:config.
Maybe this will help? .. It IS really annoying, isn't it! :|
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

User avatar
murray
Level 5
Level 5
Posts: 673
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: How to stop web page redirecting

Post by murray »

LLS wrote:
Mon Sep 23, 2019 3:27 am
No that doesnt seem to stop it redirecting. I'd have thought that manually typing in the web address www etc might stop it.
Its not that big of a deal but none the less annoying.
Yeah there's different ways to do redirects, so it depends on how the site is doing them.

Could you share the site with us and then we can try different methods?
Running Mint 19.3 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

cliffcoggin
Level 5
Level 5
Posts: 779
Joined: Sat Sep 17, 2016 6:40 pm
Location: England

Re: How to stop web page redirecting

Post by cliffcoggin »

Wouldn't a VPN achieve what LLS wants to do? If I understand correctly VPNs are supposed to deceive the internet about a computer's real location.
Cliff Coggin
Mint 19.2 Cinnamon

mediclaser
Level 4
Level 4
Posts: 385
Joined: Tue Mar 20, 2018 2:28 pm

Re: How to stop web page redirecting

Post by mediclaser »

Have you tried "NoScript"? It's a browser extension available for FF and Chromium.
If you're looking for a greener Linux pasture, you won't find any that is greener than Linux Mint. ;)

User avatar
BG405
Level 8
Level 8
Posts: 2020
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: How to stop web page redirecting

Post by BG405 »

mediclaser wrote:
Tue Sep 24, 2019 4:02 pm
NoScript
+1, but note it does take a little setting-up a.k.a. allowing "trusted" scripts for the various sites you use, especially at first. It should work, though. :wink:
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Post Reply

Return to “Open chat”