[SOLVED] No Partition Table on live image flash drive... ?!?!?

Chat about just about anything else
Post Reply
User avatar
Portreve
Level 8
Level 8
Posts: 2219
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida
Contact:

[SOLVED] No Partition Table on live image flash drive... ?!?!?

Post by Portreve » Sun Oct 06, 2019 6:59 pm

I ran across an article the other day on Enso OS, which is another Ubuntu-based distro that uses XFCE and a variety of other combined bits assembled with an eye to working well and also looking very nice.

I wanted to check it out myself, so I downloaded and flashed the ISO to a known-good flash drive, but when I try to boot from it, my MBP does not see it as a bootable device. I've used the ubiquitous USB Image Writer utility that comes with LM, I've tried balenaEtcher... no difference.

Now, why did I title this thread the way I did when I'm asking about flashing a distro's live image?

When I use gparted to check out the flash drive after writing the image, it tells me there is no partition table present. I can wipe the flash drive and set it up as just a normal flash drive, and it definitely then has a partition table. Whether I set it up with MBR or GPT, It's there and everything's cool.

But, the moment I flash this live image, it claims there's no partition table.

The curious thing is, for a storage medium claimed not to have a partition table, LM sure has no problem mounting the live image-generated partition and showing me everything that's on there, including efi-related data files which, presumably, should be what's required to make this work.

The reason I posted this thread is that, while not being able to try out Enso won't be the end of the world, I'm really stumped by this, and I truly would like to at least boot the darn thing and see what it's like.
Last edited by Portreve on Mon Oct 07, 2019 1:31 am, edited 1 time in total.
Please be polite and remember to mark your fixed problem [SOLVED].

Presently running Linux Mint Cinnamon 19.3 beta.

Also looking for a new job.

User avatar
JerryF
Level 11
Level 11
Posts: 3957
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: No Partition Table on live image flash drive... ?!?!?

Post by JerryF » Sun Oct 06, 2019 7:12 pm

First thing I would do is check the downloaded ISO to see if it's ok.

Download it again and then write the newly-downloaded ISO to the flash drive.
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: No Partition Table on live image flash drive... ?!?!?

Post by athi » Sun Oct 06, 2019 8:11 pm

Mint live USB/DVD uses the ISO 9660 file system.
https://en.wikipedia.org/wiki/ISO_9660
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

User avatar
JerryF
Level 11
Level 11
Posts: 3957
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: No Partition Table on live image flash drive... ?!?!?

Post by JerryF » Sun Oct 06, 2019 8:19 pm

athi wrote:
Sun Oct 06, 2019 8:11 pm
Mint live USB/DVD uses the ISO 9660 file system.
https://en.wikipedia.org/wiki/ISO_9660
OP wants to try out Enso OS and unfortunately, I have no experience with that.
IF your problem has been solved, please edit your ORIGINAL post and add [SOLVED] to the beginning of the Subject Line. It helps other members when browsing posts.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: No Partition Table on live image flash drive... ?!?!?

Post by athi » Sun Oct 06, 2019 8:50 pm

Downloaded Enso OS ISO and burn to USB with USB Image Writer and was able to boot into the Enso live session in legacy mode with UEFI with CSM mode on my Elitebook 840 G1. Changed the boot option to UEFI only (no CSM) and was unable to boot into USB. Looks like Enso is legacy BIOS/CSM only with no UEFI support. Intel based MBP is EFI only and this looks to be the reason that Portreve is unable to boot the Enso live USB on his MBP.

I would try Enso live USB on a legacy BIOS or UEFI with CSM machine.

Edit: VM with legacy BIOS or CSM should also work.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6883
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: No Partition Table on live image flash drive... ?!?!?

Post by Spearmint2 » Sun Oct 06, 2019 9:08 pm

my understanding of the USB LIVE utility in Mint, is that it simply "dd" the ISO image onto the flash, so it looks and acts like a CD or DVD, and those use a table of contents instead of a MBR. Perhaps if you make a partition, since that puts an MBR on the flash, and then run the utility to "burn" the ISO image onto the flash, it will work. I've run across a few BIOS, older usually, that for some reason want a FAT partition at least on them first, which I typically create the smallest FAT16 with 16MB, and then everything else happens after that.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
Portreve
Level 8
Level 8
Posts: 2219
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida
Contact:

Re: No Partition Table on live image flash drive... ?!?!?

Post by Portreve » Mon Oct 07, 2019 1:21 am

athi wrote:
Sun Oct 06, 2019 8:50 pm
Downloaded Enso OS ISO and burn to USB with USB Image Writer and was able to boot into the Enso live session in legacy mode with UEFI with CSM mode on my Elitebook 840 G1. Changed the boot option to UEFI only (no CSM) and was unable to boot into USB. Looks like Enso is legacy BIOS/CSM only with no UEFI support. Intel based MBP is EFI only and this looks to be the reason that Portreve is unable to boot the Enso live USB on his MBP.

I would try Enso live USB on a legacy BIOS or UEFI with CSM machine.

Edit: VM with legacy BIOS or CSM should also work.
Ah ha!

Thank you, athi.
Please be polite and remember to mark your fixed problem [SOLVED].

Presently running Linux Mint Cinnamon 19.3 beta.

Also looking for a new job.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: [SOLVED] No Partition Table on live image flash drive... ?!?!?

Post by athi » Mon Oct 07, 2019 8:06 am

You are welcome, surprised that any distribution now is not UEFI ready.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

User avatar
Portreve
Level 8
Level 8
Posts: 2219
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida
Contact:

Re: [SOLVED] No Partition Table on live image flash drive... ?!?!?

Post by Portreve » Mon Oct 07, 2019 10:26 am

athi wrote:
Mon Oct 07, 2019 8:06 am
You are welcome, surprised that any distribution now is not UEFI ready.
Yeah, I agree. And, the real head scratcher here is it's based on a uEFI-ready distro!

Where's The Firetruck, Batman? :wink:
Please be polite and remember to mark your fixed problem [SOLVED].

Presently running Linux Mint Cinnamon 19.3 beta.

Also looking for a new job.

Post Reply

Return to “Open chat”