Page 1 of 1

[SOLVED] No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 6:59 pm
by Portreve
I ran across an article the other day on Enso OS, which is another Ubuntu-based distro that uses XFCE and a variety of other combined bits assembled with an eye to working well and also looking very nice.

I wanted to check it out myself, so I downloaded and flashed the ISO to a known-good flash drive, but when I try to boot from it, my MBP does not see it as a bootable device. I've used the ubiquitous USB Image Writer utility that comes with LM, I've tried balenaEtcher... no difference.

Now, why did I title this thread the way I did when I'm asking about flashing a distro's live image?

When I use gparted to check out the flash drive after writing the image, it tells me there is no partition table present. I can wipe the flash drive and set it up as just a normal flash drive, and it definitely then has a partition table. Whether I set it up with MBR or GPT, It's there and everything's cool.

But, the moment I flash this live image, it claims there's no partition table.

The curious thing is, for a storage medium claimed not to have a partition table, LM sure has no problem mounting the live image-generated partition and showing me everything that's on there, including efi-related data files which, presumably, should be what's required to make this work.

The reason I posted this thread is that, while not being able to try out Enso won't be the end of the world, I'm really stumped by this, and I truly would like to at least boot the darn thing and see what it's like.

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 7:12 pm
by JerryF
First thing I would do is check the downloaded ISO to see if it's ok.

Download it again and then write the newly-downloaded ISO to the flash drive.

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 8:11 pm
by athi
Mint live USB/DVD uses the ISO 9660 file system.
https://en.wikipedia.org/wiki/ISO_9660

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 8:19 pm
by JerryF
athi wrote:
Sun Oct 06, 2019 8:11 pm
Mint live USB/DVD uses the ISO 9660 file system.
https://en.wikipedia.org/wiki/ISO_9660
OP wants to try out Enso OS and unfortunately, I have no experience with that.

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 8:50 pm
by athi
Downloaded Enso OS ISO and burn to USB with USB Image Writer and was able to boot into the Enso live session in legacy mode with UEFI with CSM mode on my Elitebook 840 G1. Changed the boot option to UEFI only (no CSM) and was unable to boot into USB. Looks like Enso is legacy BIOS/CSM only with no UEFI support. Intel based MBP is EFI only and this looks to be the reason that Portreve is unable to boot the Enso live USB on his MBP.

I would try Enso live USB on a legacy BIOS or UEFI with CSM machine.

Edit: VM with legacy BIOS or CSM should also work.

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Sun Oct 06, 2019 9:08 pm
by Spearmint2
my understanding of the USB LIVE utility in Mint, is that it simply "dd" the ISO image onto the flash, so it looks and acts like a CD or DVD, and those use a table of contents instead of a MBR. Perhaps if you make a partition, since that puts an MBR on the flash, and then run the utility to "burn" the ISO image onto the flash, it will work. I've run across a few BIOS, older usually, that for some reason want a FAT partition at least on them first, which I typically create the smallest FAT16 with 16MB, and then everything else happens after that.

Re: No Partition Table on live image flash drive... ?!?!?

Posted: Mon Oct 07, 2019 1:21 am
by Portreve
athi wrote:
Sun Oct 06, 2019 8:50 pm
Downloaded Enso OS ISO and burn to USB with USB Image Writer and was able to boot into the Enso live session in legacy mode with UEFI with CSM mode on my Elitebook 840 G1. Changed the boot option to UEFI only (no CSM) and was unable to boot into USB. Looks like Enso is legacy BIOS/CSM only with no UEFI support. Intel based MBP is EFI only and this looks to be the reason that Portreve is unable to boot the Enso live USB on his MBP.

I would try Enso live USB on a legacy BIOS or UEFI with CSM machine.

Edit: VM with legacy BIOS or CSM should also work.
Ah ha!

Thank you, athi.

Re: [SOLVED] No Partition Table on live image flash drive... ?!?!?

Posted: Mon Oct 07, 2019 8:06 am
by athi
You are welcome, surprised that any distribution now is not UEFI ready.

Re: [SOLVED] No Partition Table on live image flash drive... ?!?!?

Posted: Mon Oct 07, 2019 10:26 am
by Portreve
athi wrote:
Mon Oct 07, 2019 8:06 am
You are welcome, surprised that any distribution now is not UEFI ready.
Yeah, I agree. And, the real head scratcher here is it's based on a uEFI-ready distro!

Where's The Firetruck, Batman? :wink: