Page 1 of 1

Trouble cloning hard drive (read errors)

Posted: Mon Jun 01, 2020 6:05 pm
by DrCharles
I am trying to clone the 500 GB hard drive (about 210 GB in use) on a Windows 7 64-bit machine. No failures so far, but every hard drive fails eventually... Bought a new 500 GB drive, plugged it into another SATA connector on the motherboard, formatted, ran chkdsk /f /r on both the old and the new disks, so far so good.

I have unsuccessfully tried Clonezilla, GParted and ddrescue. All have the same problem - indicating some bad sectors on the source disk. The first two wouldn't boot (period) - just steady beeping and a black screen.

Ddrescue with if=/dev/sda, of=/dev/sdb, conv=sync, noerror took about 4.5 hours and recovered 99.99% of the data. Then it would boot Windows as far as the logon screen. But when I enter my password, a light blue background (not the BSOD) persisted indefinitely with a "Build 7601 This copy of Windows is not genuine" in the lower right corner. None of my icons, no mouse pointer, non responsive thereafter.

Since this isn't a Windows forum ;) I will only mention briefly that attempts with the installation disc to create an image were also unsuccessful (mentioning read errors on the source drive too).

What am I doing wrong? :?:

I thought ddrescue would make a bit-for-bit copy, so even if there are a few bad sectors on the disk, the cloned disk should be just that - a clone. I ran into similar problems trying to clone my Linux Mint/Win 7 dual boot drive on the laptop, too. Any help gratefully received! thanks.

Re: Trouble cloning hard drive (read errors)

Posted: Tue Jun 02, 2020 12:05 am
by DrCharles
I'm still not sure where the HDD read errors come from since Windows and programs have all been working normally for years... but I would like to know why all the cloning software I tried had difficulty coping with errors.

Anyway I did manage to get the clone drive booted in safe mode and watched the drivers load. I learned that at least one asw*.sys file (which some Googling on my Linux Mint 19.3 laptop showed me is part of Avira Anti-Virus) was causing Windows to hang.

So I manually renamed all those files to .xxx and then had to use the install disc's System Repair option to fix it (again).

Finally I was able to start Windows normally, repair and then uninstall Avira.
Now everything seems to be working again.

I don't want to put SOLVED yet since the drive obviously did not clone as easily as expected (e.g. dd if=/dev/sda of=/dev/sdb) :lol:

Re: Trouble cloning hard drive (read errors)

Posted: Tue Jun 02, 2020 12:19 am
by Pierre
in the Windows System, the Avira Anti-Virus will start Before the Operating System will start,
- - in order to protect that very Operating System . .

but, that same Avira Anti-Virus can also cause some issues in Booting up the Windows System,
& where possible, it does pay to remove or disable the Avira Anti-Virus, before your attempt in Cloning the HDD itself.

also, since there was an indication of some bad sectors on the source disk,
then the DataDump aka DD would be the better method, as it will ignore, where possible, any such errors.
:)