Need help installing newer version of Mesa

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
motm
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 11:00 pm

Need help installing newer version of Mesa

Post by motm » Thu Nov 15, 2018 2:38 am

So on Synaptic, the newest version of Mesa is 18.0.5, but I am trying to see if I can run games on Steam through Proton, which is asking for 18.1.X or 18.2.X. I've tried running games anyway and they all give an error that Valve mentioned would happen, which is that the games don't detect DX11. Valve says to download newer versions of Mesa through this guy's repository, but this is for Ubuntu, and I do not know how to get them to install in Mint:
https://launchpad.net/~paulo-miguel-dia ... untu/pkppa

Can anyone help me install this? I may also need llvm updated, I am not sure yet because Valve's site doesn't mention how up-to-date I need to be on that.

I'm on a default install of Mint 19 with default updates installed and my graphics card is an R9 270X.

User avatar
smurphos
Level 12
Level 12
Posts: 4392
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Need help installing newer version of Mesa

Post by smurphos » Thu Nov 15, 2018 3:03 am

This instructions for adding a PPA to mint are identical to those for ubuntu. For Mint 19 you need a PPA which provides packages for bionic - the one you've linked to does so just follow the instructions on the page under the heading Adding this PPA to your system. Once done you'll see a Mesa update pop up in Update Manager
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Graphics Cards & Monitors”