[solved] Now NVidia driver works but Cinnamon crashes

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
SignorBari
Level 1
Level 1
Posts: 12
Joined: Thu Oct 24, 2013 6:44 pm

[solved] Now NVidia driver works but Cinnamon crashes

Postby SignorBari » Mon Nov 11, 2013 5:10 pm

So after my last round of attempts, I uninstalled the nvidia-319 driver. I've now installed the newest nvidiadriver, 331.20. This worked. The installation went okay and it built the module without error. Previously I may have had a kernel related issue, since I have 3.11 installed. I needed the upgrade to run my wifi card. The package I installed previously should have had the patches for that, but I guess that wasn't good enough.

In any case, the video card now works. If I run optirun glxspheres or glxgears, I am clearly getting the accelerated graphics. But I can only get Cinnamon fallback mode. Cinnamon crashes immediately after login.

If I try to use nvidia-xconfig, it builds a xorg.conf file that makes my video go to 640x480. I don't want to try that again.

If I run glxgears without optirun, I get this error:

Code: Select all

Xlib:  extension "GLX" missing on display ":0.0".
ERROR (603): Could not obtain RGB visual with requested properties


This suggests there's a .conf file somewhere I need to edit, I just can't figure out which one.
Last edited by SignorBari on Tue Nov 12, 2013 8:35 pm, edited 1 time in total.

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: Now NVidia driver works but Cinnamonc rashes

Postby clfarron4 » Mon Nov 11, 2013 6:22 pm

What is the model of your card and is it one with "Optimus"?

If you aren't sure about "Optimus", post output to the following commands:

Code: Select all

lspci | grep VGA
lspci | grep 3D
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

SignorBari
Level 1
Level 1
Posts: 12
Joined: Thu Oct 24, 2013 6:44 pm

Re: Now NVidia driver works but Cinnamonc rashes

Postby SignorBari » Mon Nov 11, 2013 6:24 pm

It's an nvidia gtx 765m w/optimus.



Here is another clue: inxi -Fx tells me this:

Code: Select all

Graphics:  Card: Intel Haswell Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.13.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: Now NVidia driver works but Cinnamonc rashes

Postby clfarron4 » Mon Nov 11, 2013 6:28 pm

Because this is an nVidia card with Optimus, the default behaviour is to power both cards, but only use the Intel Integrated card with BumbleBee installed.

So, you'll need to set-up BumbleBee to:
1) use the nVidia card when you want it.
2) power down the nVidia card when you aren't using it.

Don't ask me how to set it up though, because I've never owned an nVidia card.
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

SignorBari
Level 1
Level 1
Posts: 12
Joined: Thu Oct 24, 2013 6:44 pm

Re: Now NVidia driver works but Cinnamonc rashes

Postby SignorBari » Tue Nov 12, 2013 8:33 pm

After a bit of googling and rooting about in the Bumblebee wiki, I first tried reinstalling bumblebee, which didn't help, and then I reinstalled mesa with

Code: Select all

 sudo apt-get install --reinstall libgl1-mesa-glx xserver-xorg-core


per the advice of the wiki. This has restored Cinnamon, but now optirun doesn't find the driver. But since I now know there's a working driver, that should be just a configuration issue. I just have to figure out where to point it. But I think I can call this thread solved.


Return to “Graphic Cards & Monitors”

Who is online

Users browsing this forum: No registered users and 3 guests