Backlight adjustment doesn't work

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sun Sep 09, 2012 6:17 am

Backlight adjustment doesn't work

Post by frankrice »

Hi all.

That's my first post and I would try to be the more precise I could.

I've got an HP Pavilion dv7 and just installed Linux mint. I got ubuntu before and got the same issue.
When I press the volume up or volume down keys it works well but when I try to adjust the brightness it doesn't works.
The slider appears and changes but it takes no effect. That's the graphic card:

PavimintX ~ # lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M Series]

I've tried adding this on /etc/X11/xorg.conf

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "RegistryDwords" "EnableBrightnessControl=1"

and this on grub.cfg


But no result. Help me please.

Level 1
Level 1
Posts: 29
Joined: Mon Jan 02, 2012 4:19 pm

Re: Backlight adjustment doesn't work [SOLVED]

Post by wub »

I believe I have the same problem. I have an Acer Timeline 4830T (uses CPU for graphics, sound, etc) and I got very excited when I found this post ( ... ss#p623806). I tried the settings mentioned there, and it makes no difference. My function + arrow key combinations work for sound, and for brightness, the graphic widget appears on the screen and the bar changes length, but the display does not change. The Cinnamon screen setting for brightness does not make any difference either.

UPDATE: I have solved this problem, for me at least, by discovering that after I edited /etc/default/grub to change GRUB_CMDLINE_LINUX_DEFAULT so that it looked like this:

GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash acpi_osi=Linux acpi_backlight=vendor"

I HAD TO RUN sudo update-grub OR THE CHANGES WON'T TAKE EFFECT!! (sheepish grin... - I can't get the smiley to display either, btw).

Now that I have run update-grup, I no longer see the cute brightness widget on the screen when I press Fn + up/down arrow, but my screen moves through 9 levels of brightness very nicely.

Best of luck to anyone who has this problem, hope this helps.

Post Reply

Return to “Graphics Cards & Monitors”