How to install the Nvidia proprietary drivers in LinuxMint

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
4ttila
Level 1
Level 1
Posts: 13
Joined: Tue Dec 27, 2016 3:20 am

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby 4ttila » Tue Dec 27, 2016 9:50 am

Original issue :"The problem I have is that whenever I install the Proprietary Nvidia driver - any version! - the Cinnamon crashes at startup. I am using Linux Mint 18.1 64 Bit on a Lenovo G580 with an NVIDIA G635 GPU. I have parallel a 32-bit Ubuntu installed as well. On Ubuntu I had the experience that on 32-bit OS the Video Card drivers were perfect, while the video card driver has killed killed 64-bit Ubuntu upon installing. I decided to try Linux Mint 64-bit, and it is already much better because it has a fallback mode.

After a while I have realized that if I set the prime to use the Intel card with the Nvidia driver installed, the Cinnamon does not crash at startup, but performance in 3D games has become terrible even for games, which run perfectly well on 32-bit OS. (I suspect it is not just the Os that is using the Intel card instead of the Nvidia, but the games as well)

I would like to find a way to run the Linux Mint 18.0 64-bit directly on the Nvidia card, However this seems to be impossible now due to the OS/driver issue. I have seen several solutions on the web. I have updated to the latest Kernel, I have used various Nvidia-drivers, but the situation never changed no matter what driver version I have installed, and also Kernel Update did not make the issue go away, despite some claim it would.

What do You suggest to do in such situations? Should I install some software to make cinnamon use the factory driver properly? Is there a major issue with Nvidia-drivers on 64-bit Ubuntu derivates? "

A possible solution/workaround?:

"It appears the issue is mostly solved.

I have previously upgraded to the latest kernel
Also after I have set nvidia driver as the driver I have used the command to set Intel as primary card before reboot

At this point the Os was stable, but 3D applications still struggled. So I have done the following:
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

After this the 3D performance is still not as fine as on a 32-bit OS, but the situation is much better! So I recommend those people who still have have issues after the original stepts, to install bumblebee and test the results. I will do so myself, but I hope this will be considered a solution."

DeepMind
Level 1
Level 1
Posts: 5
Joined: Sat Feb 04, 2017 4:12 pm

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby DeepMind » Sat Feb 04, 2017 4:39 pm

Dear all,

I am by far not a Linux expert like you guys, however, I would like to share my latest experience with you installing two Nvidia Titan X Pascal on a Asus X99-E-WS USB 3.1 motherboard.
Details can be found there: https://ubuntu-mate.community/t/installing-two-nvidia-titan-x-pascal-gpus-in-ubuntu-mate/11191.

As outlined in the referenced post the secure boot mode was the root cause of my problems.
The only way to resolve the problems was to disable the secure boot mode by deleting the corresponding keys in the BIOS. Afterwards the installation of the proprietary drivers worked fine.

Best
Alex

Ang3lus
Level 1
Level 1
Posts: 42
Joined: Sat Feb 18, 2017 6:20 am
Location: South Africa

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby Ang3lus » Fri Feb 24, 2017 12:23 pm

hi all

i get up to

sudo ./n.run


then terminal says

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.


if i check my system info i get this

Graphics: Card: NVIDIA GK107 [GeForce GT 640] bus-ID: 01:00.0 chip-ID: 10de:0fc1
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz
GLX Renderer: GeForce GT 640/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 367.57 Direct Rendering: Yes


iam just trying to make the text look better as at the moment the text in alll windows is killing my eyes
No more windows os since 23 February 2017
Running Linux Mint Cinnamon x64

veronx
Level 1
Level 1
Posts: 3
Joined: Mon Feb 05, 2007 10:46 am
Location: Poland, ZNIN

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby veronx » Fri Apr 07, 2017 1:31 pm

I just switched in BIOS to use IGFX (integrated graphics), then I just installed newest nvidia driver from repo :
ppa:graphics-drivers

restart , switched back to using PCIE graphics and my geforce 1060 running very well now :)

trebushet
Level 1
Level 1
Posts: 1
Joined: Tue Jul 04, 2017 12:37 pm

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby trebushet » Tue Jul 04, 2017 1:18 pm

The instructions have changed somewhat for Mint 18.2 Sonya.

I spent an hour trying to figure out how to install the latest beta driver NVIDIA-Linux-x86_64-384.47.run.
I hosed my system and Cinnamon crashed because I tried to upgrade to 384.47 while being on the Mint recommended nvidia-375 proprietary driver. This caused the 384.47 to install until the last step where it failed. I was able to reboot and switch to nouveau from Driver Manager but when I rebooted again, Cinnamon warned that it was running in fallback mode, but I could not do anything as the mouse, tab, or enter keys did not work to get out of the warning window. Cntrl+ALT+F1 did work, so I was able to fix with the instructions below.

Make sure you switch to the nouveau driver before trying to update to the latest Nvidia driver from their website, if you use "Driver Manager" from System Settings in Mint, to install the nvidia-375 (recommended) driver.

Here are the commands I used:


1. Hit "Cntrl + ALT + F1" to get to command line.

2. libdrm-nouveau1a was not found so I only removed the following:

Code: Select all

sudo apt-get purge xserver-xorg-video-nouveau nvidia*
sudo update-initramfs -u -k all

3. reboot
4. Cntrl + ALT + F1
5. Stop lightdm

Code: Select all

sudo service lightdm stop

6. Install latest driver. Pressed "Yes" for all the prompts.

Code: Select all

sudo ./NVIDIA-Linux-x86_64-384.47.run

7. reboot

Success:
inxi -SPARM -GCDN -v1 -xGCRS
System: Kernel: 4.10.0-26-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya

Graphics: Card: NVIDIA GK104 [GeForce GTX 760] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1200@59.95hz, 1920x1200@59.95hz
GLX Renderer: GeForce GTX 760/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.47 Direct Rendering: Yes

uggaboogah
Level 1
Level 1
Posts: 1
Joined: Tue Jul 18, 2017 9:42 pm

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby uggaboogah » Tue Jul 18, 2017 10:27 pm

trebushet wrote:The instructions have changed somewhat for Mint 18.2 Sonya.

5. Stop lightdm

Code: Select all

sudo service lightdm stop



Thanks for posting your solution. Question though.... hasn't Mint been using the systemd method of services for a while now, and therefore use the systemctl command to manage services? Do both systemctl and service work? What is best practice?

lmuserx4849
Level 4
Level 4
Posts: 496
Joined: Wed Dec 17, 2014 2:55 am

Re: How to install the Nvidia proprietary drivers in LinuxMint

Postby lmuserx4849 » Wed Jul 19, 2017 1:59 am

uggaboogah wrote:
trebushet wrote:The instructions have changed somewhat for Mint 18.2 Sonya.

5. Stop lightdm

Code: Select all

sudo service lightdm stop



Thanks for posting your solution. Question though.... hasn't Mint been using the systemd method of services for a while now, and therefore use the systemctl command to manage services? Do both systemctl and service work? What is best practice?


service is a bash wrapper around systemctl. It's there for compatibility reasons.

Code: Select all

===> file -L $(type service | cut -f3 -d $'\x20')
/usr/sbin/service: POSIX shell script, ASCII text executable


Ubuntu 16.04, April, 2016 was assimilated by systemd. LM 18 was based on (scroll to the bottom) this version.
LM 17.3 (LTS April 2019), had a combination of upstart and sysvinit.

Does service command work with systemd?
SysVinit to Systemd Cheatsheet

I'd probably transition to systemctl, because the more you use it the more you'll learn. But it you ever use a non-systemd distro, it might be confusing.


Return to “Graphic Cards & Monitors”