nvidia module loaded but not recognized by X!

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
nellicus
Level 1
Level 1
Posts: 3
Joined: Fri Jun 08, 2012 10:53 am

nvidia module loaded but not recognized by X!

Postby nellicus » Thu Nov 29, 2012 3:00 pm

Hi all,

I'm losing my mind on this

I got the nvidia module loaded but X doesn't want to recognize it - I see errors but not sure what is wrong

nell0@delirio ~ $ lspci | grep --color VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [Quadro K2000M] (rev a1)

nell0@delirio ~ $ dpkg -l | egrep nvidia
ii nvidia-current 304.64-0ubuntu1~quantal~xup1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 304.64-0ubuntu1~quantal~xup1 amd64 Tool for configuring the NVIDIA graphics driver

nell0@delirio ~ $ lsmod | grep --color nvidia
nvidia 11284047 0

nell0@delirio ~ $ egrep --color -i nvidia /var/log/Xorg.0.log -B2 -A2
[ 743.429] (II) LoadModule: "glx"
[ 743.429] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[ 743.434] (II) Module glx: vendor="NVIDIA Corporation"
[ 743.434] compiled for 4.0.2, module version = 1.0.0
[ 743.434] Module class: X.Org Server Extension
[ 743.434] (II) NVIDIA GLX Module 304.64 Tue Oct 30 11:18:32 PDT 2012
[ 743.435] Loading extension GLX
[ 743.435] (==) Matched intel as autoconfigured driver 0
--
[ 743.453] (==) intel(0): hotplug detection: "enabled"
[ 743.476] (--) RandR disabled
[ 743.484] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[ 743.485] (II) intel(0): Setting screen physical size to 508 x 285
[ 743.493] (II) XKB: generating xkmfile /tmp/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm

nell0@delirio ~ $ glxinfo
name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".


Anyone has got a clue? other debug I can provide?

Thanks

nellicus
Level 1
Level 1
Posts: 3
Joined: Fri Jun 08, 2012 10:53 am

Re: nvidia module loaded but not recognized by X!

Postby nellicus » Thu Nov 29, 2012 3:03 pm

does it have to do with?

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [Quadro K2000M] (rev a1)

reading of bumblebee/optimus - no idea what they are! :D

McLovin
Level 5
Level 5
Posts: 788
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: nvidia module loaded but not recognized by X!

Postby McLovin » Thu Nov 29, 2012 5:01 pm

did you install the nvidia driver? and if you did, after you installed it, did you run the command to configure the xorg.conf files

Code: Select all

sudo nvidia-xconfig


Return to “Graphic Cards & Monitors”

Who is online

Users browsing this forum: No registered users and 2 guests