Cannot change brightness

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
combination
Level 1
Level 1
Posts: 5
Joined: Wed May 01, 2013 5:38 pm

Cannot change brightness

Post by combination »

Hello,

I recently moved to mint and I'm unable to change the brightness of my display.
Not only does the option bar not show up under "Brightness and Lock", it does also not work via command line.

I got a DELL Inspiron 5521, linux mint 14 cinammon x64.
I've followed the guide How to enable backlight brightness controls, but it didn't help.

lspci | grep VGA gets me:

Code: Select all

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]
I'm only using the intel chip, as I don't need the ati (the ati is actually disabled)

I tried setting it via

Code: Select all

sudo setpci -s 00:02.0 f4.b=00
but without success.
ls -l /sys/class/backlight/ gives me: total 0
xbacklight does not work, neither does xgamma.

Adding "acpi_backlight=vendor" to grub left me with a black screen and I needed to boot into recovery.
combination
Level 1
Level 1
Posts: 5
Joined: Wed May 01, 2013 5:38 pm

Re: Cannot change brightness

Post by combination »

I just noticed my radeon is actually not disabled, and I can no longer disable it via echoing "OFF" to vgaswitcheroo

Code: Select all

cannot access /sys/kernel/debug/vgaswichteroo/switch: No such file or directory
but debugsfs is mounted and I can't remount it:

Code: Select all

sudo mount -t debugfs none /sys/kernel/debug

mount: none already mounted or /sys/kernel/debug busy
mount: according to mtab, none is already mounted on /sys/kernel/debug

Code: Select all

inxi -G
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller 
           Card-2: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series] 
           X.Org: 1.13.4 drivers: (unloaded: fbdev) FAILED: vesa,intel Resolution: 1920x1080@0.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits) GLX Version: 2.1 Mesa 9.2.0
Any idea how I can deactivate the radeon? I don't need it and maybe that's the first step to fixing my brightness issues
User avatar
roblm
Level 12
Level 12
Posts: 4455
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot change brightness

Post by roblm »

I'm not the most knowledgeable person on this subject but since no one else has responded, then perhaps we can figure this out working
together. Were you previously using a different Linux distribution, where the brightness could be controlled? Looking at the command:
sudo setpci -s 00:02.0 f4.b=00
usually the value 00 is for minimum brightness but this is opposite for some laptops. You can try using the value FF for maximum brightness.
You tried the command: ls -l /sys/class/backlight/
and said it gave you total of "0". I assume you mean that no folder names were listed. If not then open Nemo and go to "/sys/class/backlight"
and be sure there are no folders listed. Some laptops use the "/proc/acpi" folder to store brightness information, for example:
/proc/acpi/sony/brightness

Also in the BIOS do you have a setting for changing the graphics driver which lists the options: Integrated, Discreet and Switchable?

I'll stop at this point until I hear from you.
combination
Level 1
Level 1
Posts: 5
Joined: Wed May 01, 2013 5:38 pm

Re: Cannot change brightness

Post by combination »

roblm wrote:I'm not the most knowledgeable person on this subject but since no one else has responded, then perhaps we can figure this out working
together. Were you previously using a different Linux distribution, where the brightness could be controlled?
Nope I havn't used linux before
roblm wrote:Looking at the command:
sudo setpci -s 00:02.0 f4.b=00
usually the value 00 is for minimum brightness but this is opposite for some laptops. You can try using the value FF for maximum brightness.
Tried both, no success
roblm wrote: You tried the command: ls -l /sys/class/backlight/
and said it gave you total of "0". I assume you mean that no folder names were listed. If not then open Nemo and go to "/sys/class/backlight"
and be sure there are no folders listed.
No folders in there, nothing at all
roblm wrote:Some laptops use the "/proc/acpi" folder to store brightness information, for example:
/proc/acpi/sony/brightness
Nope, just:

Code: Select all

sudo ls -la /proc/acpi/
total 0
dr-xr-xr-x   3 root root 0 Jun  7 22:01 .
dr-xr-xr-x 215 root root 0 Jun  8  2013 ..
dr-xr-xr-x   3 root root 0 Jun  7 22:05 button
-r--------   1 root root 0 Jun  7 22:01 event
-rw-r--r--   1 root root 0 Jun  7 22:05 wakeup
roblm wrote: Also in the BIOS do you have a setting for changing the graphics driver which lists the options: Integrated, Discreet and Switchable?
Unfortunately not, I got this new "UEFI" BIOS :/
roblm wrote: I'll stop at this point until I hear from you.
Thanks anyways!
User avatar
roblm
Level 12
Level 12
Posts: 4455
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot change brightness

Post by roblm »

Your laptop has a particularly difficult problem since no entries are found in /sys/class/backlight or /proc/acpi, which indicates no method of
backlight control has been found. I have only seen this in two other messages I have read from other people with similar brightness problems,
out of about 200 messages. I assume you haven't tried installing any proprietary driver for your Radeon card.

As far as I know, the vga_switcheroo command only works to switch GPUs if your system has a so called hardware mux (multiplexer) with a
setting in the BIOS to control it, but even then not all systems can use this, and it only works with the open source drivers. The following
command is supposed to check your system if this command is available: grep -i switcheroo /boot/config-*

To see if there is any brightness control try using the xrandr command:
xrandr --output LVDS1 --X (values below 1.0 decrease brightness)

For “X” you can try using .7
where LVDS1 is the connected output name found by running the command:
xrandr --verbose

Here is the result for my desktop computer. It only shows the top 3 lines.

rlm1@linuxmint ~ $ xrandr --verbose
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
DVI-I-1 connected 1280x1024+0+0 (0x65) normal (normal left inverted right x axis y axis) 376mm x 301mm

The connected output name is DVI-I-1
For my computer the command would be:
xrandr --output DVI-I-1 --brightness .7

You probably should first try upgrading to Mint 15 which has the newer 3.8.0-19 kernel.

You can also try editing the grub file by replacing:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to one of the following lines. You can try this with UEFI BIOS and then again with the Legacy BIOS option.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force noapic nolapic"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor”
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_osi=Linux”
GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi=Linux acpi_backlight=vendor"

Save the file and then open the Terminal and type: sudo update-grub, and reboot but be prepared for a similar problem you had when you
tried this with "acpi_backlight=vendor"

You can try installing a proprietary driver in System Tools > System Settings > Software Sources > Additional Drivers.
User avatar
physe
Level 1
Level 1
Posts: 10
Joined: Mon Apr 30, 2012 3:44 am

Re: Cannot change brightness

Post by physe »

I have an Acer Aspire 3830TG (i3-2310m with integrated graphics + Nvidia Optimus VGA gt540m).
This worked for me:
  • sudo gedit /etc/default/grub
Change:

Code: Select all

GRUB_CMDLINE_LINUX=""
to:

Code: Select all

GRUB_CMDLINE_LINUX="acpi_osi=Linux"
combination
Level 1
Level 1
Posts: 5
Joined: Wed May 01, 2013 5:38 pm

Re: Cannot change brightness

Post by combination »

roblm wrote:Your laptop has a particularly difficult problem since no entries are found in /sys/class/backlight or /proc/acpi, which indicates no method of
backlight control has been found. I have only seen this in two other messages I have read from other people with similar brightness problems,
out of about 200 messages. I assume you haven't tried installing any proprietary driver for your Radeon card.

As far as I know, the vga_switcheroo command only works to switch GPUs if your system has a so called hardware mux (multiplexer) with a
setting in the BIOS to control it, but even then not all systems can use this, and it only works with the open source drivers. The following
command is supposed to check your system if this command is available: grep -i switcheroo /boot/config-*
grep -i switcheroo /boot/config-*
CONFIG_VGA_SWITCHEROO=y
To see if there is any brightness control try using the xrandr command:
xrandr --output LVDS1 --X (values below 1.0 decrease brightness)
xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 (0x17e) normal (normal) 0mm x 0mm
...
You probably should first try upgrading to Mint 15 which has the newer 3.8.0-19 kernel.

You can also try editing the grub file by replacing:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to one of the following lines. You can try this with UEFI BIOS and then again with the Legacy BIOS option.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force noapic nolapic"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor”
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_osi=Linux”
GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi=Linux acpi_backlight=vendor"

Save the file and then open the Terminal and type: sudo update-grub, and reboot but be prepared for a similar problem you had when you
tried this with "acpi_backlight=vendor"

You can try installing a proprietary driver in System Tools > System Settings > Software Sources > Additional Drivers.
I've tried those settings before, and they've left me with a black screen after boot..
I have the strange feeling that something is really really wrong with my mint installation - or it just doesn't work out with my hardware..
vgaswitcheroo was working before and without changing anything, it stopped working (as I said I already had the gpu disabled and it was working fine, except the brightness). Also, I can no longer access protected WiFis (http://forums.linuxmint.com/viewtopic.php?f=49&t=136298) which basically forces me to move away from mint at that point of time. Too much trouble, too much time wasted :( And the worst thing is, I did not even change anything (no driver changed, no updates, etc...)

Thank you for your help nevertheless
User avatar
roblm
Level 12
Level 12
Posts: 4455
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cannot change brightness

Post by roblm »

The test for the vgaswitcheroo switch shows it is available. Even if you disabled the radeon driver, I doubt if your brightness problem would be
fixed. To test for this, you could prevent the radeon driver from loading by adding the line "blacklist radeon"
to the "/etc/modprobe.d/blacklist.conf" file. Then in the Terminal type "sudo update-initramfs -u". But this will not power off the ati video card. You
would still need to use vgaswitcheroo.

I would install Mint 15 to get the newer kernel. It may also correct your other wireless problem. If that doesn't help, then I would
consider trying an even newer kernel at this site:
http://kernel.ubuntu.com/~kernel-ppa/mainline/

Sometimes installing an older kernel has helped.

The other option is installing the latest AMD catalyst proprietary driver. This may work better than installing the proprietary fglrx driver from
System Tools > System Settings > Software Sources > Additional Drivers.
combination
Level 1
Level 1
Posts: 5
Joined: Wed May 01, 2013 5:38 pm

Re: Cannot change brightness

Post by combination »

Hey,

I'm going to upgrade to Mint 15 the next days (basically fresh install) ;)
I don't think that disabling the radeon would fix the brightness problem, but I don't need the radeon anyways so I wanted to eliminate that first..

I also tried compiling the AMD driver, but then X couln't start anymore .. Anyways, I'm going to upgrade and then I'll give it another try
Post Reply

Return to “Graphics Cards & Monitors”