Problem: Mint13 Mate ATI Radeon X1600 driver no 3D accell

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
DanielR
Level 4
Level 4
Posts: 242
Joined: Mon Sep 23, 2013 1:22 pm

Problem: Mint13 Mate ATI Radeon X1600 driver no 3D accell

Post by DanielR »

Hello all,

I 'm totally new to the Linux world but installing Mint13 Mate 32bit on my laptop seemed to be without problems at first. The problems started after I discovered a severe performance problem with my graphics card (Wine running S.T.A.L.K.E.R. SOC). My laptop is a HP nc8430, Intel T2500, 4GB RAM and an ATI Radeon X1600 256MB.

I searched the net for tips or solutions and tried to install the fglrx driver through the package manager. It didn't work so I uninstalled it. Currently the Radeon driver is installed. However, I do not get any graphics accelleration. "glxinfo | grep direct" and "glxinfo | grep render" don't give any output and glxgears returns a "Segmentation fault".

Being not very literate regarding Linux commands and procedures, I would appreciate any assistance to get the X1600 "flying". BTW, under WInXP S.T.A.L.K.E.R. SOC performs quite well with a moderate enablement of graphics features. So it ain't the X1600 which sucks. However, beeing new to the Linux world, I am aware that to a yet unknown extend the problem is sitting in front of the monitor ... :?

Any help and guidance is much appreciated
DanielR
Level 4
Level 4
Posts: 242
Joined: Mon Sep 23, 2013 1:22 pm

Re: [Update] Mint13 Mate ATI X1600 driver no 3D accell

Post by DanielR »

Somtimes the Windows philosophy "Reboot is good" seems to work wonders on other OS as well. glxgears is working again, I need to test the rest.

Can anyone help me tweaking the 3D performance of the X1600 graphics?
DanielR
Level 4
Level 4
Posts: 242
Joined: Mon Sep 23, 2013 1:22 pm

Re: Problem: Mint13 Mate ATI Radeon X1600 driver no 3D accel

Post by DanielR »

Still not happy with the performance of my Radeon X1600 graphics. After having uninstalled the fglrx driver, I have installed the open source Radeon driver.
Did some educated guessing/searching in my Xorg.0.log and came across a few errors.
There are 2 errors regarding fglrx:

[ 16.116] (II) LoadModule: "fglrx"
[ 16.119] (WW) Warning, couldn't open module fglrx
[ 16.119] (II) UnloadModule: "fglrx"
[ 16.119] (II) Unloading fglrx
[ 16.119] (EE) Failed to load module "fglrx" (module does not exist, 0)

and

[ 16.121] (II) LoadModule: "fglrx"
[ 16.124] (WW) Warning, couldn't open module fglrx
[ 16.125] (II) UnloadModule: "fglrx"
[ 16.125] (II) Unloading fglrx
[ 16.125] (EE) Failed to load module "fglrx" (module does not exist, 0)

Some leftovers since I uninstalled the fglrx driver? Or is there something else to be removed to get rid of these errors?

Here is another section from the Xorg.0.log which puzzles me:

[ 16.260] [drm] failed to load kernel module "radeon"
[ 16.260] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.

Anything worrying or the "usual" behaviour for a X1600 card? Acceleration seems to have been initialised. However, on some games like S.T.A.L.K.E.R. in Wine or running Doom in the Doomsday engine is more like a PowerPoint presentation than an acceptable frame rate. Also the scrolling in Firefox is far from smooth.
DanielR
Level 4
Level 4
Posts: 242
Joined: Mon Sep 23, 2013 1:22 pm

[SOLVED] Mint13 Mate ATI Radeon X1600 driver no 3D accell

Post by DanielR »

Well, I found the problem. After some research I came across the parameter "radeon.modeset=1". According to http://www.x.org/wiki/radeonBuildHowTo/ it should be added to grub like this: GRUB_CMDLINE_LINUX="radeon.modeset=1" to enable Kernel-based ModeSetting.

Unfortunately my initial grub showed the following lines:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"
GRUB_CMDLINE_LINUX=""
There were 2 errors with this.
1. the "radeon.dpm=1" parameter does not work with my 3.2 kernel (12.04 precise), it is intended for the 3.11 and later kernels. It should enable power management for the video card. But apparently not for 3.2 kernel.
2. the "radeon.modeset=1" was missing altogether.

So I modified the two lines in grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="radeon.modeset=1"
After update-grub and a reboot, glmark2 shows the following info:
OpenGL Information
GL_VENDOR: X.Org R300 Project
GL_RENDERER: Gallium 0.4 on ATI RV530
GL_VERSION: 2.1 Mesa 8.0.4
versus the former, software rendering information:
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20
Frame rate of the glmark2 is way above the 100fps mark. The overall glmark2 Score is now 306 (it was 18 before).

I will now start testing the 3D performance with my games. if all runs well, it's another nail in the coffin for Windows :P

dmesg also gives a lot more info for "radeon":
dmesg |grep radeon
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxx ro radeon.modeset=1 quiet splash vt.handoff=7
[ 13.010782] [drm] radeon kernel modesetting enabled.
[ 13.010865] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 13.010873] radeon 0000:01:00.0: setting latency timer to 64
[ 13.014346] radeon 0000:01:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[ 13.014350] radeon 0000:01:00.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[ 13.014417] radeon 0000:01:00.0: irq 46 for MSI/MSI-X
[ 13.014424] radeon 0000:01:00.0: radeon: using MSI.
[ 13.014455] [drm] radeon: irq initialized.
[ 13.025898] [drm] radeon: 256M of VRAM memory ready
[ 13.025900] [drm] radeon: 512M of GTT memory ready.
[ 13.034838] [drm] radeon: 1 quad pipes, 2 z pipes initialized.
[ 13.080093] radeon 0000:01:00.0: WB enabled
[ 13.843584] [drm] radeon: ring at 0x0000000010001000
[ 13.843800] [drm] radeon: ib pool ready.
[ 13.845485] [drm] radeon: power management initialized
[ 14.740516] fbcon: radeondrmfb (fb0) is primary device
[ 14.740757] fb0: radeondrmfb frame buffer device
[ 14.740769] [drm] Initialized radeon 2.12.0 20080528 for 0000:01:00.0 on minor 0
Post Reply

Return to “Graphics Cards & Monitors”