(Solved!): Install Nvidia Drivers on Optimus System

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

(Solved!): Install Nvidia Drivers on Optimus System

Post by Sandman007 » Thu May 15, 2014 4:48 pm

So I am trying to install the nvidia-drivers on My Asus G46vw Optimus System. I have followed guides here on teh forums but they do not seem to work for me. Driver Manager doesn't show anything. I can get the drivers installed but I do not think I can get the nouveau driver blacklisted. Using a couple of terminal commands I can see teh Nvidia drier is in fact installed but not activated. Any help would be awesome.

Keep in mind I am not interest in Bumblebee. I have gotten teh Nvidia 331 drivers with Nvidia-Prime working on Ubuntu.
Last edited by Sandman007 on Tue May 20, 2014 4:09 pm, edited 1 time in total.

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: Install Nvidia Drivers on Optimus System

Post by clfarron4 » Thu May 15, 2014 5:54 pm

If you are not disabling the on-board graphics card (typically the Intel one) AND you want to use the nVidia drivers, then you must use BumbleBee.
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Thu May 15, 2014 6:09 pm

clfarron4 wrote:If you are not disabling the on-board graphics card (typically the Intel one) AND you want to use the nVidia drivers, then you must use BumbleBee.
That's not really true anymore. That's the beauty of nvidia-prime. I can have both the intel drive and Nvidia drivers installed. Then Nvidia-prime allows me to switch GPUs manually.

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: Install Nvidia Drivers on Optimus System

Post by clfarron4 » Fri May 16, 2014 9:22 am

Sandman007 wrote:
clfarron4 wrote:If you are not disabling the on-board graphics card (typically the Intel one) AND you want to use the nVidia drivers, then you must use BumbleBee.
That's not really true anymore. That's the beauty of nvidia-prime. I can have both the intel drive and Nvidia drivers installed. Then Nvidia-prime allows me to switch GPUs manually.
I forgot Ubuntu released nvidia-prime.

Have you had a look at this guide to black-listing?
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Fri May 16, 2014 12:42 pm

Yes. That method works great for me on Ubuntu 14.04 but not no LM16

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: Install Nvidia Drivers on Optimus System

Post by clfarron4 » Fri May 16, 2014 4:53 pm

Sandman007 wrote:Yes. That method works great for me on Ubuntu 14.04 but not no LM16
Strange... Should work.

Have you tried removing the nouveau drivers as well?
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install Nvidia Drivers on Optimus System

Post by zerozero » Fri May 16, 2014 7:19 pm

clfarron4 wrote:
Sandman007 wrote:Yes. That method works great for me on Ubuntu 14.04 but not no LM16
Strange... Should work.

Have you tried removing the nouveau drivers as well?
LM 16 is based on Ubuntu 13.10; was nvidia-prime working on saucy? or only now in trusty?
LM17 (in RC atm) is based in trusty; it should work.
Image

[ bliss of ignorance ]

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Fri May 16, 2014 10:32 pm

clfarron4 wrote:
Sandman007 wrote:Yes. That method works great for me on Ubuntu 14.04 but not no LM16
Strange... Should work.

Have you tried removing the nouveau drivers as well?
yes

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Fri May 16, 2014 10:38 pm

zerozero wrote:
clfarron4 wrote:
Sandman007 wrote:Yes. That method works great for me on Ubuntu 14.04 but not no LM16
Strange... Should work.

Have you tried removing the nouveau drivers as well?
LM16 is based on Ubuntu 13.10; was nvidia-prime working on saucy? or only now in trusty?
LM17 (in RC atm) is based in trusty; it should work.
I'm not a 100% sure but I want to say I didn't start using Nvidia-Prime until the Beta builds of Ubuntu 14.04 started rolling gout so I do not know if Nvidia-Prime works on 13.10. Considering the Release notes of LM17 specifically state "No optimus support (yet)." Do you think I could still get the Nvidia-Prime package with Proprietary drivers going just like Ubuntu 14.04? I am going to give LM17 a go tomorrow anyways so I guess I'll find out.

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 10:32 am

I just got finished install LM17, So I will update my post in a bit if I get the drivers working properly

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install Nvidia Drivers on Optimus System

Post by zerozero » Sat May 17, 2014 10:49 am

https://github.com/linuxmint/Roadmap
NEW
system: optimus cards don't work, nvidia-prime only supports LightDM
This is the issue.
Image

[ bliss of ignorance ]

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 11:09 am

zerozero wrote:https://github.com/linuxmint/Roadmap
NEW
system: optimus cards don't work, nvidia-prime only supports LightDM
This is the issue.
That's funny cause I have it working :). I blacklisted Nouveau. Removed the xorg-nouveau driver completely. Installed 331 drivers through driver manager. Install Nvidia-Prime. And bam! Using Nvidia driver with Cinnamon/MDM on LM17. What;s funny is on LM16 The driver manager wouldn't detect my 660M. LM17 showed drivers for it practically immediately. I didn't even have to wait a minute,

Edit: So I guess I lied. I didn't realize that the Nvidia card was switched off through Nvidia-Settings. I enabled the card and went to fallback mode :(

Can I just switch to Lightdm and that solve my issues?
Last edited by Sandman007 on Sat May 17, 2014 11:15 am, edited 2 times in total.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install Nvidia Drivers on Optimus System

Post by zerozero » Sat May 17, 2014 11:13 am

it would be interesting if you could give feedback in the blog >> http://blog.linuxmint.com/?p=2615
adding the more details as you can.
Image

[ bliss of ignorance ]

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 11:15 am

zerozero wrote:it would be interesting if you could give feedback in the blog >> http://blog.linuxmint.com/?p=2615
adding the more details as you can.
See edit above :(

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install Nvidia Drivers on Optimus System

Post by zerozero » Sat May 17, 2014 11:20 am

Sandman007 wrote:Can I just switch to Lightdm and that solve my issues?
theoretically yes, nothing should stop nvidia-prime from work in LM17 if it works out-of-the-box in the same package base (trusty);
if the issue is the display manager (lightdm vs mdm) installing lightdm should solve the problem.
Image

[ bliss of ignorance ]

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 11:31 am

zerozero wrote:
Sandman007 wrote:Can I just switch to Lightdm and that solve my issues?
theoretically yes, nothing should stop nvidia-prime from work in LM17 if it works out-of-the-box in the same package base (trusty);
if the issue is the display manager (lightdm vs mdm) installing lightdm should solve the problem.
Ok I think I will give that a try then. If you go to the bottom of this thread barnaby1 posted a script that supposedly makes Nvidia-Prime with MDM work on LM16 for him.

http://forums.linuxmint.com/viewtopic.php?f=59&t=154023

However he isn't completely clear. Is he editing /etc/mdm/mdm.conf? If so that doews not work for me. Any ideas why?

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 11:52 am

zerozero wrote:
Sandman007 wrote:Can I just switch to Lightdm and that solve my issues?
theoretically yes, nothing should stop nvidia-prime from work in LM17 if it works out-of-the-box in the same package base (trusty);
if the issue is the display manager (lightdm vs mdm) installing lightdm should solve the problem.
OK so I installed lightdm and switched to it. At first I got stuck on teh boot logo after rebooting. but I switched to a terminal and did "startx". I got to my desktop but was in fallback mode with lighdm :(. And yes I did actually switch to lightdm by running teh reconfigure command.

Guide I used: http://www.noobslab.com/2014/01/install ... er-in.html

***EDIT***
OK so I have lightdm working.I get stuck at the boot logo for some reason but after doing a startx I get into Cinnamon!! no falback mode :). But I am in software running mode for some reason. This is using my Intel card. Not the Nvdia

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Sat May 17, 2014 12:06 pm

I know I am kind of all over the place with this one but here is some output.

i

Code: Select all

nxi -G
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller 
           Card-2: NVIDIA GK107M [GeForce GTX 660M] 
           X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1366x768@60.1hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits) GLX Version: 2.1 Mesa 10.1.0

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Mon May 19, 2014 1:56 pm

OK so supposedly a few days ago The following packages received updates after the release of Linux Mint 17 RC to fix support for NVIDIA Optimus cards: mdm, ubuntu-drivers-common and nvidia-prime. However after updating my system, installing 331 drivers, and removing nouveau package server-xorg-video-nouveau and blacklisting teh kernel module I STILL can't use my Nvidia card without Cinnamon crashing. I checked to make sure all three updates applied. I removed the nvidia drivers and reinstalled them through Driver Manager. No dice. modprobe nouveau shows nothing so its removed.

Sandman007
Level 1
Level 1
Posts: 20
Joined: Tue Apr 15, 2014 7:45 pm

Re: Install Nvidia Drivers on Optimus System

Post by Sandman007 » Tue May 20, 2014 12:09 pm

bump. Any Help?

Post Reply

Return to “Graphics Cards & Monitors”