LM 13 and ATI Radeon 6410D GPU [SOLVED]

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
FLlinux

LM 13 and ATI Radeon 6410D GPU [SOLVED]

Post by FLlinux »

I got LM 13 installed and I've got the Additional Drivers on the screen for the video card. I'm a little confused by what I have read so I would like to get some clarification. I had to edit in GRUB and put nomodeset xforcevesa to get the video to work. I downloaded using my windows machine from the AMD website two drivers for linux, version 12.8 and 12.4. If what I am reading is correct, it is advisable to NOT use those drivers and instead use only the ATI/AMD proprietary FGLRX graphics driver?

Thanks.
Last edited by FLlinux on Fri May 23, 2014 9:50 am, edited 1 time in total.

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: LM 13 and ATI Radeon 6410D GPU

Post by clfarron4 »

The easiest way to do it is with the fglrx package provided in the "Additional Drivers". If you need updated drivers, add the Xedgers repository.

You can download the Linux drivers from the AMD website, but they're not nicely packaged in the .deb format for you to install. These are essentially the same as the fglrx package in the Ubuntu repositories, but the fglrx package has been well tested (and known to generally work).
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

FLlinux

Re: LM 13 and ATI Radeon 6410D GPU

Post by FLlinux »

clfarron4 wrote:The easiest way to do it is with the fglrx package provided in the "Additional Drivers". If you need updated drivers, add the Xedgers repository.

You can download the Linux drivers from the AMD website, but they're not nicely packaged in the .deb format for you to install. These are essentially the same as the fglrx package in the Ubuntu repositories, but the fglrx package has been well tested (and known to generally work).
I did as you said and selected the fglrx package and now my video is broken. It says X Server won't start and that it is disabled. It says to restart mdm when it is configured correctly. What do I do now?

User avatar
clfarron4
Level 5
Level 5
Posts: 511
Joined: Thu Sep 19, 2013 6:20 pm
Contact:

Re: LM 13 and ATI Radeon 6410D GPU

Post by clfarron4 »

OK, first remove xforcevesa from the boot parameters and make sure that nomodeset is set and then boot (you might have to do this in GRUB).

If that fails, then you'll need to boot with the parameter runlevel=3 to get you into getty, log-in, remove fglrx and reboot.
Problems? Tell us EXACTLY what you've done and what you expected to happen, IN DETAIL. That will save us questions, and we should get along better,

I have dysgraphia. This means I might have understood you incorrectly through no fault of my own.

FLlinux

Re: LM 13 and ATI Radeon 6410D GPU

Post by FLlinux »

clfarron4 wrote:OK, first remove xforcevesa from the boot parameters and make sure that nomodeset is set and then boot (you might have to do this in GRUB).If that fails, then you'll need to boot with the parameter runlevel=3 to get you into getty, log-in, remove fglrx and reboot.
Ok. Thanks. I did some things last night in Terminal and I turned it on this morning and it worked. :D

Post Reply

Return to “Graphics Cards & Monitors”