NVIDIA with SLI

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
abadaba
Level 1
Level 1
Posts: 2
Joined: Sat Nov 15, 2008 1:47 pm

NVIDIA with SLI

Postby abadaba » Sat Nov 15, 2008 2:31 pm

I'm having an issue after installing Nvidia 177 from the hardware drivers app. My install for Mint gos wonderfully with no issues! After i reboot I'm prompted about my hardware drivers. I select to activate the Nvidia 177 drivers. It downloads, activates the drivers etc. Upon reboot I'm no longer able to load Gnome. I only get the text based version of Mint. Yet if i do a complete reformat and install of Mint it boots right up into Gnome no problems. I have two Nvidia 8800GTs running in SLI mode. I have converted all of my machines to Mint and i have to say I've ran into no issues until now. Any help would be greatly appreciated.


System
Dell XPS 630
2x Nvidia 8800GT in SLI mode
4 gigs corsair dominator 1600mhz
2x WD 15K RPM raptors RAID0

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NVIDIA with SLI

Postby Husse » Sun Nov 16, 2008 9:59 am

I suppose you mean that after the second install of Mint you don't install the nvidia drivers
Is this the 64 bit version?
If not that's the explanation
If my memory serves me right the nvidia drivers have a problem in 32 bits system with much memory
You can remove 2 GB memory - it can't be used properly anyway if you have a dual channel memory controller
With a single channel controller remove one GB the fourth GB only causes problems in 32 bits
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

abadaba
Level 1
Level 1
Posts: 2
Joined: Sat Nov 15, 2008 1:47 pm

Re: NVIDIA with SLI

Postby abadaba » Sun Nov 16, 2008 11:44 am

After doing some research i got it to work perfectly. I added the BusId "01:00:00" of the first card, enabled multigpu=on and everything works flawlessly! I am running 32 bit mode due tot he fact mint 6 doesn't have a 64 bit version yet. As soon as 64 bit is released i will be switching over. Right now the OS only sees 3GB of ram which i'm fine with for now. Just incase others would like to know the steps i went through if they find this post; please see the below instructions.


This problem should affect anyone with a SLI setup with 2 or 3 nvidia video cards, the first time you reboot after installing the nvidia restricted driver (which will happen if you turn on desktop effects on a newly installed Ubuntu / SLI system). X Windows will fail to start saying "No Screen Found" and you will be stuck at a text login prompt! Doh!!!!


Fast fix instructions for the experienced:

1. The BusId fix described in this thread has to go into the "Device" section in /etc/X11/xorg.conf, not into the "Screens" section.
2. Use lspci | grep -i vga to find your cards BusIDs. They will be something like 01:00.0 or 02:00.0. These would translate to BusId "01:00:00" or BusId "02:00:0" in the xorg.conf.
3. Edit /etc/X11/xorg.conf with sudo, find Section "Device" and try one or the other BusId line.
4. Test X windows with startx. Use ctrl-alt-backspace to get out of X windows. Try the other BusID line if the first one doesn't work.
5. Once you have it working, Restart gdm with sudo /etc/init.d/gdm restart. Rejoice.



Very Gentle instructions for beginners:

You will be starting from a broken system that only boots into text mode, and it will be prompting you for a username. Type the commands shown in boldface. Everything else is just a copy of what happened on my system so you know what else you will be seeing.

1. Login with your username/password you usually login with. If you don't have a password set, just hit enter.

Code:

Code: Select all

yourmachine login: yourusername
Password: mypassword


2. Remove any old possibly broken install of v173 or v177 nvidia drivers...

Code:

Code: Select all

$ sudo apt-get purge nvidia-glx-173 nvidia-glx-177
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package nvidia-glx-173 is not installed, so not removed
The following packages will be REMOVED:
  nvidia-glx-177*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 25.8MB disk space will be freed.
Do you want to continue [Y/n]? [Enter]
(Reading database ... 111389 files and directories currently installed.)
Removing nvidia-glx-177 ...
Purging configuration files for nvidia-glx-177 ...
dpkg - warning: while removing nvidia-glx-177, directory `/usr/lib/tls' not empty so not removed.
Processing triggers for man-db ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place

3. Reinstall the v177 nvidia driver

Code:

Code: Select all

$ sudo apt-get install nvidia-glx-177
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  nvidia-glx-177
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/8931kB of archives.
After this operation, 25.8MB of additional disk space will be used.
Selecting previously deselected package nvidia-glx-177.
(Reading database ... 111345 files and directories currently installed.)
Unpacking nvidia-glx-177 (from .../nvidia-glx-177_177.80-0ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Setting up nvidia-glx-177 (177.80-0ubuntu2) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place


4. Let nvidia-xconfig make you a new /etc/X11/xorg.conf file:
Code:

Code: Select all

$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'


5. List the video card busID's with lspci:
Code:

Code: Select all

$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)


On my system, the cards are 01:00.0 and 02:00.0. These would go into xorg.conf as BusId "01:00:00" and BusId "02:00:00" respectively. Your setup will probably show different numbers in the first field, and you might even have 3 video cards if you're using 3-way SLI.


Next you have to take a guess which card is which. You have a 50/50 chance of getting it right...

Write down the two bus ID's on a piece of paper so you have them for the next step.

6. Edit /etc/X11/xorg.conf and add the BusId line to the Device section. (use your favourite text editor instead of pico if you want)
Code:

Code: Select all

$  sudo pico /etc/X11/xorg.conf

Hit Ctrl-W and type: Section "Device" to search for the right section.

Pico will find the Device section. Mine looked like this:

Code:

Code: Select all

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
EndSection


Add in the your first guess for the BusId line, so it looks like this:
Code:

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BusId "01:00:00"
EndSection


Now save the file with Ctrl-O and then exit pico with Ctrl-X. You will be back at a $ command prompt.

7. See if X Windows starts using startx!
Code:

Code: Select all

$  startx


With any luck you see X-Windows startup!

If you see just a black screen or nothing happens, you go back to step 6 and edit xorg.conf, putting in the other possible BusId line.. Then re-try startx and it should work. You can stop X windows now with ctrl-alt-backspace to get back to the prompt so you can repeat step 6.

The debugging output you see go by can be found in /var/log/Xorg.0.log, which you can look at with less /var/log/Xorg.0.log (use space bar for next page, b for previous page, g for start of file, G for end of file, and q to quit).


Now it's time to stop the X windows we started with "startx" and try and start the gdm login manager:

8. Stop X-Windows if it's running. Press: Ctrl-Alt-Backspace and X will die, leaving you back at the $ command prompt

9. repeat steps 6 and 7 again until you get the right BusId.
Once you have a working configuration, restart gdm (the graphical login screen):
Code:

Code: Select all

$ sudo /etc/init.d/gdm start

the usual Ubuntu login screen should start!

10. Graphical Linux is now back, rejoice!

11. You should now be able to go into System -> preferences -> Appearance in Ubuntu and turn on the enhanced effects in the Visual Effects tab. Try dragging windows around and shaking them. Also try breaking them out to the left or right to switch them to a different desktop. Try Windows-Tab instead of Alt-Tab to do fancy 3D window switching. Cool!

monkeyboy00

Re: NVIDIA with SLI

Postby monkeyboy00 » Sun Nov 30, 2008 2:35 am

I just wanted to thank you for the walk through, it worked like a charm.

hodge
Level 1
Level 1
Posts: 3
Joined: Sat Jan 10, 2009 10:59 pm

Re: NVIDIA with SLI

Postby hodge » Sun Jan 11, 2009 12:23 am

Just want to let you know that you're my hero! I installed Mint about 7 times tonight trying to get this thing straightened out, and following your simple instructions got me up and running in no time!

suamme1

Re: NVIDIA with SLI

Postby suamme1 » Sat Jan 31, 2009 6:12 pm

Just a quick note to those who found this from a search, but the same instructions also apply in Ubuntu 8.10 and worked great.

Thanks!

jag1182
Level 2
Level 2
Posts: 51
Joined: Thu Jan 17, 2008 11:38 pm

Re: NVIDIA with SLI

Postby jag1182 » Sun Feb 22, 2009 12:35 am

Just had to tell you that I hadn't had a problem until I tried to load Felicia X64, then had the problem you described - and this worked great! Thank you for giving such clear and complete instructions - you earned hero status for certain.
MSI 990FXA-GD80; AMD FX 8120; GeForce GTX 550T 2GB; 8 GBGSkill Ripjaws X 10666; Lite On iHBS1120942 BD/DVD/CD; HP DVD writer 1270i; Seagate Barracuda 1TB HD; Hitachi 1 TB HD; Maxtor 160 GB HD; Broadcom Nextreme Gigabit Ethernet Plus Network Interface Card

Mikeyp926
Level 1
Level 1
Posts: 9
Joined: Fri Feb 20, 2009 3:06 pm

Re: NVIDIA with SLI

Postby Mikeyp926 » Wed Feb 25, 2009 7:38 pm

Thank you so much for these instructions!
I have experienced this problem multiple times with both Ubuntu 8.10 and Mint, and this post finally helped me fix it.
Thanks!!

Aljado
Level 1
Level 1
Posts: 4
Joined: Wed Feb 04, 2009 3:27 am

Re: NVIDIA with SLI

Postby Aljado » Sun Mar 01, 2009 3:59 pm

Another one posting thanks for successful resolution. I had problems in editing xorg.conf, but that turns out no file was found because I wasn't logged in as root. Quick sudo su and off I went.

So delighted, this problem has had me pulling my hair out. Thanks a million

Lantesh
Level 6
Level 6
Posts: 1212
Joined: Sat Apr 12, 2008 1:02 pm

Re: NVIDIA with SLI

Postby Lantesh » Mon Apr 13, 2009 3:35 pm

I am not running an SLI setup, but I've bookmarked this thread in case I ever do. Thanks for the information! 8)

Raggedyman
Level 1
Level 1
Posts: 1
Joined: Sun Apr 19, 2009 9:06 pm

Re: NVIDIA with SLI

Postby Raggedyman » Sun Apr 19, 2009 9:18 pm

Tagging this thread along with my sincere thanks! I've been working all day trying to get different versions of linux working and Mint was my third distro. This post in particular fixed everything.....woohoo! Looks like I've found my new home......goodbye WINDOZE!

johnshack113
Level 1
Level 1
Posts: 3
Joined: Thu May 07, 2009 9:18 am

Re: NVIDIA with SLI

Postby johnshack113 » Thu May 07, 2009 9:58 am

total linux newbie here.

I have had this issue from the start and have reinstalled mint a total of 6 times. i even lost my windows partition and had to start from scratch! lol oh well, its all in the learning.
I was wondering if there is a way to install working drivers from the start instead of installing broken ones, uninstalling them through terminal and then installing working ones.
So far, after a few times of my system dying on its arse to the nvidia driver error (lots of DRDY ERR etc and no login ability) i am frightened of touching the driver at all.

i used the following in terminal to find my busIDs:
lspci | grep -i vga

which it reported were 03.00.0 and 05.00.0

my /etc/X11/xorg.conf file has the section Device bit but the only line there is : Identifier "Configured Video Device"
so where do i put my busIDs and how should the line look?

I REALLY don't want to activate the broken driver again because i can't login at all once I do that and i end up having to reinstall. nightmare.

Many thanks for any advice proffered and I apologize if I'm missing something obvious. Never had to literally instruct an operating system to recognise my hardware so specifically before.

Johnboy

User avatar
monkeyboy
Level 5
Level 5
Posts: 791
Joined: Mon Oct 13, 2008 11:30 am

Re: NVIDIA with SLI

Postby monkeyboy » Thu May 07, 2009 11:14 am

Hey Guy. From a fresh working install its the same process as listed in the above walk through except you just launch the terminal and ignore the portion of the instructions that have you purging the broken driver and go right to the install part . The rest of the process is given step by step in the walk through and as long as I watch my syntax it never fails. The instructions don't list the 180 series driver as an option but it works for me so you might want to give it a try. Good Luck
If you don't like it, make something better
If you can't make something better, adapt
If you can't do either ball your panties up and cry.

Complaining is like masticating most anyone can do it.
However doing it in public is really hardcore.

johnshack113
Level 1
Level 1
Posts: 3
Joined: Thu May 07, 2009 9:18 am

Re: NVIDIA with SLI

Postby johnshack113 » Thu May 07, 2009 1:17 pm

uh-oh!

following the walkthrough i got to step 4 and got this message

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

what now?! lol

johnshack113
Level 1
Level 1
Posts: 3
Joined: Thu May 07, 2009 9:18 am

Re: NVIDIA with SLI

Postby johnshack113 » Thu May 07, 2009 2:10 pm

update after faffing:

Did the busId thing in pico and guessed right i think. only put in one of my graphics cards. put busid 03:00:0 rather than 05:00:0 as i would imagine this would be my main card.
anyhow, tried to use the startx thing and it told me i was not authorized.
fine, ok. i try some other time when this OS isn't winding me up so much. now i find i can't open anything from the mint menu. tried reload plug-ins but nothing. ended up having to restart.
luckily the video card driver seemed to work now, as confirmed by the little icon on the task bar.
so i figure i download the linux driver from nvidia and try that. no installer package of course so i figure i try follow instructions on nvidia site but nope, need to download YaST or some such then i can run the driver package.

all in all its very fiddly, very frustrating, un-user friendly stuff. i have the patience of a saint but this whole thing is driving me nuts.
so I'm gonna take a break from the immense frustration of trying to do something simple like install a driver and get drunk.
Many thanks for the help thus far, which seems to have worked a treat. but i really ought to do a degree before i try using linux lol

hyperlite1604
Level 1
Level 1
Posts: 1
Joined: Mon May 04, 2009 11:10 pm

Re: NVIDIA with SLI

Postby hyperlite1604 » Sat May 09, 2009 1:32 am

Thanks for this guide. I have been installing and reinstalling all night. This fixed the problem perfectly. I wish I would have found this hours ago. Oh well I guess this is part of the learning process. Thanks again.

User avatar
tsimonc
Level 1
Level 1
Posts: 19
Joined: Wed May 13, 2009 8:44 pm
Location: Australia, Canberra

Re: NVIDIA with SLI

Postby tsimonc » Thu Jun 04, 2009 7:33 am

I know that this will sound a little silly but I can't get past this part

$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)

I'm not 100% what I'm doing wrong but I'm guessing I'm typing it wrong or some thing but do I type "lspci | grep -i vga" if so I keep on getting told that this command is not found.
--------------------------------------------------------------------------------------------------
OS: LinuxMint7_64, Vista Basic_64
CPU: Intel Q9650---OC 3.6
Mobo: XFX 780i
RAM: DDR2 Geil 8GB
Graphics: XFX GTX 275
Cooling: Water Cooling.

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NVIDIA with SLI

Postby Husse » Thu Jun 04, 2009 7:49 am

And the first character in lspci is a lower case L?
If it is a one then the command will definitely not be found
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
tsimonc
Level 1
Level 1
Posts: 19
Joined: Wed May 13, 2009 8:44 pm
Location: Australia, Canberra

Re: NVIDIA with SLI

Postby tsimonc » Fri Jun 05, 2009 1:46 am

yeh it's a lower case L I think I'll just do a fresh install and try again seems to be playing up a bit.
--------------------------------------------------------------------------------------------------
OS: LinuxMint7_64, Vista Basic_64
CPU: Intel Q9650---OC 3.6
Mobo: XFX 780i
RAM: DDR2 Geil 8GB
Graphics: XFX GTX 275
Cooling: Water Cooling.

TomS
Level 1
Level 1
Posts: 9
Joined: Tue May 20, 2008 7:47 pm

Re: NVIDIA with SLI

Postby TomS » Sun Jun 14, 2009 5:12 pm

Has anyone used this solution with Mint 7? If so were are any changes necessary?

Thanks,

Tom


Return to “Graphic Cards & Monitors”