Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Lennyz
Level 1
Level 1
Posts: 30
Joined: Sun Jan 08, 2017 1:16 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby Lennyz » Sat Feb 18, 2017 8:16 am

nocom wrote:Anybody who got it running for the Rx480? I need the openCL functionality badly. I am sure I followed all instructions, but the platform still doesn't show up in clinfo. When I run inxi -Gx I get

Graphics: Card: Advanced Micro Devices [AMD/ATI] Device 67df
Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa)
Resolution: 1920x1200@77.00hz
GLX Renderer: N/A GLX Version: N/A

To me this seems to indicate that the RX480 is still not recognized?


Upgrade your kernel to at least 4.8 then follow my post:

viewtopic.php?p=1271515#p1271515

nocom
Level 1
Level 1
Posts: 16
Joined: Mon Jan 02, 2017 2:30 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby nocom » Sun Feb 19, 2017 7:08 am

I missed the upgrade of the kernel. Upgraded to 4.8.2, reinstalled and all works well now. Thanks a lot!

pixelnull
Level 1
Level 1
Posts: 7
Joined: Fri Jan 06, 2017 10:22 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby pixelnull » Fri Feb 24, 2017 5:52 am

I'm getting a segfault in xorg after install and reboot.

I have an R9 290, using 4.8.0-39-generic, username is in the video group, removed the radeon drivers, and I'm trying to install to 16.60 drivers.

No errors from the pro driver install...

Here is the error log from xorg.

Code: Select all

[    82.395]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[    82.395] X Protocol Version 11, Revision 0
[    82.395] Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
[    82.395] Current Operating System: Linux derpy 4.8.0-39-generic #42~16.04.1-Ubuntu SMP Mon Feb 20 15:06:07 UTC 2017 x86_64
[    82.395] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.8.0-39-generic root=UUID=7c0ad905-d415-45fa-81e1-50e4afe72934 ro quiet splash vt.handoff=7
[    82.395] Build Date: 02 November 2016  10:06:10PM
[    82.395] xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support)
[    82.395] Current version of pixman: 0.33.6
[    82.395]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    82.395] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    82.395] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 24 04:35:40 2017
[    82.395] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    82.396] (==) No Layout section.  Using the first Screen section.
[    82.396] (==) No screen section available. Using defaults.
[    82.396] (**) |-->Screen "Default Screen Section" (0)
[    82.396] (**) |   |-->Monitor "<default monitor>"
[    82.396] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    82.396] (==) Automatically adding devices
[    82.396] (==) Automatically enabling devices
[    82.397] (==) Automatically adding GPU devices
[    82.397] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    82.397] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    82.397]    Entry deleted from font path.
[    82.397] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    82.397]    Entry deleted from font path.
[    82.397] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    82.397]    Entry deleted from font path.
[    82.397] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    82.397]    Entry deleted from font path.
[    82.397] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    82.397]    Entry deleted from font path.
[    82.397] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   built-ins
[    82.397] (**) ModulePath set to "/opt/amdgpu-pro/lib/xorg/modules,/usr/lib/xorg/modules"
[    82.397] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    82.397] (II) Loader magic: 0x56198a483dc0
[    82.397] (II) Module ABI versions:
[    82.397]    X.Org ANSI C Emulation: 0.4
[    82.397]    X.Org Video Driver: 20.0
[    82.397]    X.Org XInput driver : 22.1
[    82.397]    X.Org Server Extension : 9.0
[    82.398] (++) using VT number 8

[    82.398] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    82.399] (II) xfree86: Adding drm device (/dev/dri/card0)
[    82.402] (--) PCI:*(0:1:0:0) 1002:67b1:1462:3081 rev 0, Mem @ 0xc0000000/268435456, 0xd0000000/8388608, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    82.402] (II) LoadModule: "glx"
[    82.402] (II) Loading /opt/amdgpu-pro/lib/xorg/modules/extensions/libglx.so
[    82.404] (II) Module glx: vendor="X.Org Foundation"
[    82.404]    compiled for 1.18.0, module version = 1.0.0
[    82.404]    ABI class: X.Org Server Extension, version 9.0
[    82.404] (==) AIGLX enabled
[    82.404] (==) Matched ati as autoconfigured driver 0
[    82.404] (==) Matched ati as autoconfigured driver 1
[    82.404] (==) Matched modesetting as autoconfigured driver 2
[    82.404] (==) Matched fbdev as autoconfigured driver 3
[    82.404] (==) Matched vesa as autoconfigured driver 4
[    82.404] (==) Assigned the driver to the xf86ConfigLayout
[    82.404] (II) LoadModule: "ati"
[    82.405] (WW) Warning, couldn't open module ati
[    82.405] (II) UnloadModule: "ati"
[    82.405] (II) Unloading ati
[    82.405] (EE) Failed to load module "ati" (module does not exist, 0)
[    82.405] (II) LoadModule: "modesetting"
[    82.405] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    82.405] (II) Module modesetting: vendor="X.Org Foundation"
[    82.406]    compiled for 1.18.4, module version = 1.18.4
[    82.406]    Module class: X.Org Video Driver
[    82.406]    ABI class: X.Org Video Driver, version 20.0
[    82.406] (II) LoadModule: "fbdev"
[    82.406] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    82.406] (II) Module fbdev: vendor="X.Org Foundation"
[    82.406]    compiled for 1.18.1, module version = 0.4.4
[    82.406]    Module class: X.Org Video Driver
[    82.406]    ABI class: X.Org Video Driver, version 20.0
[    82.406] (II) LoadModule: "vesa"
[    82.406] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    82.406] (II) Module vesa: vendor="X.Org Foundation"
[    82.406]    compiled for 1.18.1, module version = 2.3.4
[    82.406]    Module class: X.Org Video Driver
[    82.407]    ABI class: X.Org Video Driver, version 20.0
[    82.407] (==) Matched ati as autoconfigured driver 0
[    82.407] (==) Matched ati as autoconfigured driver 1
[    82.407] (==) Matched modesetting as autoconfigured driver 2
[    82.407] (==) Matched fbdev as autoconfigured driver 3
[    82.407] (==) Matched vesa as autoconfigured driver 4
[    82.407] (==) Assigned the driver to the xf86ConfigLayout
[    82.407] (II) LoadModule: "ati"
[    82.407] (WW) Warning, couldn't open module ati
[    82.407] (II) UnloadModule: "ati"
[    82.407] (II) Unloading ati
[    82.407] (EE) Failed to load module "ati" (module does not exist, 0)
[    82.407] (II) LoadModule: "modesetting"
[    82.407] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    82.407] (II) Module modesetting: vendor="X.Org Foundation"
[    82.407]    compiled for 1.18.4, module version = 1.18.4
[    82.408]    Module class: X.Org Video Driver
[    82.408]    ABI class: X.Org Video Driver, version 20.0
[    82.408] (II) UnloadModule: "modesetting"
[    82.408] (II) Unloading modesetting
[    82.408] (II) Failed to load module "modesetting" (already loaded, 0)
[    82.408] (II) LoadModule: "fbdev"
[    82.408] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    82.408] (II) Module fbdev: vendor="X.Org Foundation"
[    82.408]    compiled for 1.18.1, module version = 0.4.4
[    82.408]    Module class: X.Org Video Driver
[    82.408]    ABI class: X.Org Video Driver, version 20.0
[    82.408] (II) UnloadModule: "fbdev"
[    82.408] (II) Unloading fbdev
[    82.408] (II) Failed to load module "fbdev" (already loaded, 0)
[    82.408] (II) LoadModule: "vesa"
[    82.408] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    82.408] (II) Module vesa: vendor="X.Org Foundation"
[    82.408]    compiled for 1.18.1, module version = 2.3.4
[    82.408]    Module class: X.Org Video Driver
[    82.408]    ABI class: X.Org Video Driver, version 20.0
[    82.408] (II) UnloadModule: "vesa"
[    82.408] (II) Unloading vesa
[    82.409] (II) Failed to load module "vesa" (already loaded, 0)
[    82.409] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    82.409] (II) FBDEV: driver for framebuffer: fbdev
[    82.409] (II) VESA: driver for VESA chipsets: vesa
[    82.418] (II) modeset(0): using drv /dev/dri/card0
[    82.418] (WW) Falling back to old probe method for modesetting
[    82.419] (WW) Falling back to old probe method for fbdev
[    82.419] (II) Loading sub module "fbdevhw"
[    82.419] (II) LoadModule: "fbdevhw"
[    82.419] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    82.419] (II) Module fbdevhw: vendor="X.Org Foundation"
[    82.419]    compiled for 1.18.4, module version = 0.0.2
[    82.419]    ABI class: X.Org Video Driver, version 20.0
[    82.419] (WW) Falling back to old probe method for vesa
[    82.419] (II) modeset(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    82.419] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    82.420] (==) modeset(0): RGB weight 888
[    82.420] (==) modeset(0): Default visual is TrueColor
[    82.420] (II) Loading sub module "glamoregl"
[    82.420] (II) LoadModule: "glamoregl"
[    82.420] (II) Loading /opt/amdgpu-pro/lib/xorg/modules/libglamoregl.so
[    82.431] (II) Module glamoregl: vendor="X.Org Foundation"
[    82.431]    compiled for 1.18.4, module version = 1.0.0
[    82.431]    ABI class: X.Org ANSI C Emulation, version 0.4
[    82.431] (II) glamor: OpenGL accelerated X.org driver based.
[    82.445] (EE)
[    82.446] (EE) Backtrace:
[    82.446] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4e) [0x56198a1f7ade]
[    82.446] (EE) 1: /usr/lib/xorg/Xorg (0x56198a045000+0x1b6e69) [0x56198a1fbe69]
[    82.446] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f4028775000+0x354b0) [0x7f40287aa4b0]
[    82.446] (EE) 3: /usr/lib/x86_64-linux-gnu/dri/amdgpu_dri.so (0x7f4020965000+0x2342162) [0x7f4022ca7162]
[    82.446] (EE) 4: /usr/lib/x86_64-linux-gnu/dri/amdgpu_dri.so (0x7f4020965000+0x233cb7e) [0x7f4022ca1b7e]
[    82.446] (EE) 5: /usr/lib/x86_64-linux-gnu/dri/amdgpu_dri.so (eglInitialize+0xbf) [0x7f4022c9f36f]
[    82.446] (EE) 6: /opt/amdgpu-pro/lib/xorg/modules/libglamoregl.so (glamor_egl_init+0xf3) [0x7f4024614da3]
[    82.446] (EE) 7: /usr/lib/xorg/modules/drivers/modesetting_drv.so (0x7f4024e5d000+0x84bc) [0x7f4024e654bc]
[    82.446] (EE) 8: /usr/lib/xorg/Xorg (InitOutput+0xb0d) [0x56198a0ddf0d]
[    82.446] (EE) 9: /usr/lib/xorg/Xorg (0x56198a045000+0x57be4) [0x56198a09cbe4]
[    82.446] (EE) 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f4028795830]
[    82.446] (EE) 11: /usr/lib/xorg/Xorg (_start+0x29) [0x56198a087049]
[    82.446] (EE)
[    82.446] (EE) Segmentation fault at address 0x0
[    82.446] (EE)
Fatal server error:
[    82.446] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    82.446] (EE)
[    82.446] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    82.446] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    82.446] (EE)
[    82.452] (EE) Server terminated with error (1). Closing log file.


Anybody have any ideas?

pixelnull
Level 1
Level 1
Posts: 7
Joined: Fri Jan 06, 2017 10:22 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby pixelnull » Sat Feb 25, 2017 9:24 pm

bumping for help

pixelnull
Level 1
Level 1
Posts: 7
Joined: Fri Jan 06, 2017 10:22 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby pixelnull » Sun Feb 26, 2017 1:07 pm

So for those of you looking for the 16.30 drivers, I found a copy.

Available here: https://mega.nz/#F!XkcyhLSR!5xBgxu2MVgDM8Bp6CiHYVg

I found 2 versions of 16.30:
amdgpu-pro_16.30.3-306809.tar.xz <- Nobody here has talked about this version as it looks older. Still worth a try though,
amdgpu-pro_16.30.3-315407.tar.xz <- Version from OP that people are asking for.

I will try it instead of the 16.60 drivers to see if I get issues with it and report back. R9 290 here.

trailscout
Level 1
Level 1
Posts: 2
Joined: Fri Mar 03, 2017 5:51 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby trailscout » Fri Mar 03, 2017 5:54 pm

I keep getting stuck on amdgpu-pro-driver/amdgpu-pro-install

It says file not found, update the directory that it is in and says os not supported.

Mint cinnemon 18.1
RX 470
asus motherboard.
I just get on my pc the default display port 2560 x 1440

7an4o
Level 1
Level 1
Posts: 1
Joined: Mon Mar 06, 2017 8:27 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby 7an4o » Sat Mar 11, 2017 2:53 pm

Maybe this time I was just lucky, but still got to a decent functioning of amd rx460 in Linux Mint 18.1 Cinnamon (64-bit). Here is the sequence of steps:

1) installation of the Linux Mint 18.1 Cinnamon (64-bit) - !!! without system update after installing;
2) download drivers from the site AMD (my version was - AMDGPU-Pro Driver Version 16.40 for Ubuntu 16.04);
3) editing the file amdgpu-pro-install, namely it need only change the name of the operating system from Ubuntu and linuxmint, and save the changes;
4) installation of the device driver and logoff;
5) during the new log in system reports that Cinnamon fallen, but offers to work in alternate mode. It is necessary to take it;
6) installation of system updates, and reboot;
7) new logon - and Cinnamon works!

I hope that this method for the same fresh users as I am will no result to disappointment, but success.

P.S. You may ask how this method differs from that described by luckyduck99? At first glance nothing, but after using his code, the installation process does not run.

User avatar
vliscony
Level 2
Level 2
Posts: 70
Joined: Thu Jan 05, 2017 7:07 pm
Location: Bronx, NY
Contact:

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby vliscony » Sun Mar 19, 2017 5:59 pm

Results:

quote
rogier@123456 ~ $ cd Downloads
rogier@123456 ~/Downloads $ cd amdgpu-pro-16.60-379184 rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ amdgpu-pro-driver/amdgpu-pro-install
bash: amdgpu-pro-driver/amdgpu-pro-install: No such file or directory
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ amdgpu-pro-driver/amdgpu-pro-install
bash: amdgpu-pro-driver/amdgpu-pro-install: No such file or directory
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ amdgpu-pro-install
amdgpu-pro-install: command not found
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ l
amdgpu-pro_16.60-379184_amd64.deb
amdgpu-pro_16.60-379184_i386.deb
amdgpu-pro-dkms_16.60-379184_all.deb
amdgpu-pro-install*
amdgpu-pro-lib32_16.60-379184_amd64.deb
clinfo-amdgpu-pro_16.60-379184_amd64.deb
clinfo-amdgpu-pro_16.60-379184_i386.deb
gst-omx-amdgpu-pro_1.0.0.1-379184_amd64.deb
gst-omx-amdgpu-pro_1.0.0.1-379184_i386.deb
libdrm2-amdgpu-pro_2.4.70-379184_amd64.deb
libdrm2-amdgpu-pro_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-amdgpu1_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-amdgpu1_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-dev_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-dev_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-radeon1_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-radeon1_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-utils_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-utils_2.4.70-379184_i386.deb
libegl1-amdgpu-pro_16.60-379184_amd64.deb
libegl1-amdgpu-pro_16.60-379184_i386.deb
libgbm1-amdgpu-pro_16.60-379184_amd64.deb
libgbm1-amdgpu-pro_16.60-379184_i386.deb
libgbm1-amdgpu-pro-base_16.60-379184_all.deb
libgbm1-amdgpu-pro-dev_16.60-379184_amd64.deb
libgbm1-amdgpu-pro-dev_16.60-379184_i386.deb
libgl1-amdgpu-pro-appprofiles_16.60-379184_all.deb
libgl1-amdgpu-pro-dri_16.60-379184_amd64.deb
libgl1-amdgpu-pro-dri_16.60-379184_i386.deb
libgl1-amdgpu-pro-ext_16.60-379184_amd64.deb
libgl1-amdgpu-pro-ext_16.60-379184_i386.deb
libgl1-amdgpu-pro-glx_16.60-379184_amd64.deb
libgl1-amdgpu-pro-glx_16.60-379184_i386.deb
libglamor-amdgpu-pro-dev_1.18.3-379184_amd64.deb
libglamor-amdgpu-pro-dev_1.18.3-379184_i386.deb
libgles2-amdgpu-pro_16.60-379184_amd64.deb
libgles2-amdgpu-pro_16.60-379184_i386.deb
libopencl1-amdgpu-pro_16.60-379184_amd64.deb
libopencl1-amdgpu-pro_16.60-379184_i386.deb
libvdpau-amdgpu-pro_12.0.3-379184_amd64.deb
libvdpau-amdgpu-pro_12.0.3-379184_i386.deb
mesa-amdgpu-pro-omx-drivers_12.0.3-379184_amd64.deb
mesa-amdgpu-pro-omx-drivers_12.0.3-379184_i386.deb
opencl-amdgpu-pro-icd_16.60-379184_amd64.deb
opencl-amdgpu-pro-icd_16.60-379184_i386.deb
Packages
Release
vulkan-amdgpu-pro_16.60-379184_amd64.deb
vulkan-amdgpu-pro_16.60-379184_i386.deb
xserver-xorg-video-amdgpu-pro_1.2.99-379184_amd64.deb
xserver-xorg-video-amdgpu-pro_1.2.99-379184_i386.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.18.3-379184_amd64.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.18.3-379184_i386.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.18.3-379184_amd64.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.18.3-379184_i386.deb
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ nano amdgpu-pro-install
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ nano amdgpu-pro-install
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ l
amdgpu-pro_16.60-379184_amd64.deb
amdgpu-pro_16.60-379184_i386.deb
amdgpu-pro-dkms_16.60-379184_all.deb
amdgpu-pro-install*
amdgpu-pro-lib32_16.60-379184_amd64.deb
clinfo-amdgpu-pro_16.60-379184_amd64.deb
clinfo-amdgpu-pro_16.60-379184_i386.deb
gst-omx-amdgpu-pro_1.0.0.1-379184_amd64.deb
gst-omx-amdgpu-pro_1.0.0.1-379184_i386.deb
libdrm2-amdgpu-pro_2.4.70-379184_amd64.deb
libdrm2-amdgpu-pro_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-amdgpu1_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-amdgpu1_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-dev_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-dev_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-radeon1_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-radeon1_2.4.70-379184_i386.deb
libdrm-amdgpu-pro-utils_2.4.70-379184_amd64.deb
libdrm-amdgpu-pro-utils_2.4.70-379184_i386.deb
libegl1-amdgpu-pro_16.60-379184_amd64.deb
libegl1-amdgpu-pro_16.60-379184_i386.deb
libgbm1-amdgpu-pro_16.60-379184_amd64.deb
libgbm1-amdgpu-pro_16.60-379184_i386.deb
libgbm1-amdgpu-pro-base_16.60-379184_all.deb
libgbm1-amdgpu-pro-dev_16.60-379184_amd64.deb
libgbm1-amdgpu-pro-dev_16.60-379184_i386.deb
libgl1-amdgpu-pro-appprofiles_16.60-379184_all.deb
libgl1-amdgpu-pro-dri_16.60-379184_amd64.deb
libgl1-amdgpu-pro-dri_16.60-379184_i386.deb
libgl1-amdgpu-pro-ext_16.60-379184_amd64.deb
libgl1-amdgpu-pro-ext_16.60-379184_i386.deb
libgl1-amdgpu-pro-glx_16.60-379184_amd64.deb
libgl1-amdgpu-pro-glx_16.60-379184_i386.deb
libglamor-amdgpu-pro-dev_1.18.3-379184_amd64.deb
libglamor-amdgpu-pro-dev_1.18.3-379184_i386.deb
libgles2-amdgpu-pro_16.60-379184_amd64.deb
libgles2-amdgpu-pro_16.60-379184_i386.deb
libopencl1-amdgpu-pro_16.60-379184_amd64.deb
libopencl1-amdgpu-pro_16.60-379184_i386.deb
libvdpau-amdgpu-pro_12.0.3-379184_amd64.deb
libvdpau-amdgpu-pro_12.0.3-379184_i386.deb
mesa-amdgpu-pro-omx-drivers_12.0.3-379184_amd64.deb
mesa-amdgpu-pro-omx-drivers_12.0.3-379184_i386.deb
opencl-amdgpu-pro-icd_16.60-379184_amd64.deb
opencl-amdgpu-pro-icd_16.60-379184_i386.deb
Packages
Release
vulkan-amdgpu-pro_16.60-379184_amd64.deb
vulkan-amdgpu-pro_16.60-379184_i386.deb
xserver-xorg-video-amdgpu-pro_1.2.99-379184_amd64.deb
xserver-xorg-video-amdgpu-pro_1.2.99-379184_i386.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.18.3-379184_amd64.deb
xserver-xorg-video-glamoregl-amdgpu-pro_1.18.3-379184_i386.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.18.3-379184_amd64.deb
xserver-xorg-video-modesetting-amdgpu-pro_1.18.3-379184_i386.deb
rogier@123456 ~/Downloads/amdgpu-pro-16.60-379184 $ amdgpu-pro-install
amdgpu-pro-install: command not found
unquote

in short, the "amdgpu-pro-install command does not execute, even within the directory where it is listed? Am I missing something?
[b]LM18.2 with 4.8 kernel, ZaReason Valta xi991, Intel Core i-7 6 core, 64 GB RAM; Radeon RX480 8GB GDDR5; SSD 500 GB; HD 2x 2TB/8GB cache; CD/DVD RW, Blu-ray/DVD/CD burner; Bluetooth USB BT; card reader; Logitech OrbitSphere/AF; HP Officejet Pro 8630

User avatar
vliscony
Level 2
Level 2
Posts: 70
Joined: Thu Jan 05, 2017 7:07 pm
Location: Bronx, NY
Contact:

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby vliscony » Sun Mar 19, 2017 9:11 pm

something seemed to run when I ran this:

sudo ./amdgpu-pro-install

however, it was not enough, for, after a reboot," I am still running in "Software rendering mode."

Notice I had not used the old driver you described here, but simply used the latest driver the AMD site supplied. Be that as it may it did not work.
[b]LM18.2 with 4.8 kernel, ZaReason Valta xi991, Intel Core i-7 6 core, 64 GB RAM; Radeon RX480 8GB GDDR5; SSD 500 GB; HD 2x 2TB/8GB cache; CD/DVD RW, Blu-ray/DVD/CD burner; Bluetooth USB BT; card reader; Logitech OrbitSphere/AF; HP Officejet Pro 8630

User avatar
vliscony
Level 2
Level 2
Posts: 70
Joined: Thu Jan 05, 2017 7:07 pm
Location: Bronx, NY
Contact:

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby vliscony » Mon Mar 20, 2017 2:57 pm

For the record, I previously was running this card: GIGABYTE Ultra Durable 2 Series Radeon R7 250 DirectX 12 GV-R725OC-2GI (rev. 5.0) 2GB 128-Bit DDR3 PCI Express 3.0 x16 ATX Video Card

and it worked fine with the standard Radeon Drivers, it just could not provide the max resolution on my new UHD monitors. That became the reason for going up to the RX480 card, but until now I am in the soup...
[b]LM18.2 with 4.8 kernel, ZaReason Valta xi991, Intel Core i-7 6 core, 64 GB RAM; Radeon RX480 8GB GDDR5; SSD 500 GB; HD 2x 2TB/8GB cache; CD/DVD RW, Blu-ray/DVD/CD burner; Bluetooth USB BT; card reader; Logitech OrbitSphere/AF; HP Officejet Pro 8630

User avatar
vliscony
Level 2
Level 2
Posts: 70
Joined: Thu Jan 05, 2017 7:07 pm
Location: Bronx, NY
Contact:

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby vliscony » Wed Mar 22, 2017 3:04 pm

In my case it was Zareason support who came up with the answer: upgrade the kernel to 4.8, and i can now do UHD without a problem... except for one:
Chrome is not displaying properly, so I will start a separate thread about that.
[b]LM18.2 with 4.8 kernel, ZaReason Valta xi991, Intel Core i-7 6 core, 64 GB RAM; Radeon RX480 8GB GDDR5; SSD 500 GB; HD 2x 2TB/8GB cache; CD/DVD RW, Blu-ray/DVD/CD burner; Bluetooth USB BT; card reader; Logitech OrbitSphere/AF; HP Officejet Pro 8630

TurbulentSheep
Level 1
Level 1
Posts: 1
Joined: Mon May 01, 2017 3:54 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby TurbulentSheep » Mon May 01, 2017 3:59 am

Nothing worked for me until I saw Lennyz post.

All you have to do is:

1. Upgrade to a kernel that is at least 4.8.
2. Download the Ubuntu drivers from here: http://support.amd.com/en-us/kb-article ... Notes.aspx
3. Extract them
4. Look for the file "amdgpu-pro-install" open it with an editor and search for the word "ubuntu" replace it with "linuxmint" and then save the file.
5. Then open up terminal, go to the map where you extracted the files and there type:

./amdgpu-pro-install -y

6. Type this command in console:

sudo usermod -a -G video $LOGNAME

7. Reboot

And voila it's working


This finally fixed everything for me. Running 18.1 Cinnamon with an RX 460.

tchavei
Level 1
Level 1
Posts: 3
Joined: Thu Oct 05, 2017 9:41 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby tchavei » Thu Oct 05, 2017 9:53 pm

Hello

I'm trying to make the AMDgpu pro drivers work on my Linux mint 18.2 Sonya install. Unfortunately, after following the install procedure, the best I can come up with is having the drivers working in console mode (tested with a gpu miner, clinfo reports back correctly 1 platform and inxi -Gx reports radeonsi drivers)... No graphical interface (cinnamon) though... Either I end with a black screen and a blinking cursor or (using no modest) I get into cinnamon but with the error 'cinnamon has crashed. Do you want to restart it?' and it doesn't get passed this.

I tried the 4.8-0.35 kernel, I tried the latest 4.10 and even the 4.11 kernel. Nothing is working. I always used the 17.30 AMDgpu pro drivers.

Isn't there anything I could try to make this work properly?

I have a gigabyte R9 390 (8 GB I think). It does appear under mint 18.2 as r9 290 (when AMDgpu pro drivers aren't installed) which is wierd but ok.

Anybody can lend me a hand please?

Thx

Tony

briandh25
Level 1
Level 1
Posts: 16
Joined: Sun Sep 24, 2017 2:54 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby briandh25 » Sun Oct 08, 2017 4:39 pm

tchavei wrote:Hello

I'm trying to make the AMDgpu pro drivers work on my Linux mint 18.2 Sonya install. Unfortunately, after following the install procedure, the best I can come up with is having the drivers working in console mode (tested with a gpu miner, clinfo reports back correctly 1 platform and inxi -Gx reports radeonsi drivers)... No graphical interface (cinnamon) though... Either I end with a black screen and a blinking cursor or (using no modest) I get into cinnamon but with the error 'cinnamon has crashed. Do you want to restart it?' and it doesn't get passed this.

I tried the 4.8-0.35 kernel, I tried the latest 4.10 and even the 4.11 kernel. Nothing is working. I always used the 17.30 AMDgpu pro drivers.

Isn't there anything I could try to make this work properly?

I have a gigabyte R9 390 (8 GB I think). It does appear under mint 18.2 as r9 290 (when AMDgpu pro drivers aren't installed) which is wierd but ok.

Anybody can lend me a hand please?

Thx

Tony


I also have the same problem.

tchavei
Level 1
Level 1
Posts: 3
Joined: Thu Oct 05, 2017 9:41 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby tchavei » Sun Oct 08, 2017 6:03 pm

Well I got it working somehow. It's broken and kinda crazy but it's working lol.

I managed to find the old 16.40 drivers. I'm using the 4.10 kernel. I installed the drivers but found in the log that it failed to compile the kernel module. I decided to reboot and try it anyway...

Cinnamon is working with ati and AMDgpu (open source drivers) like before but from the console, opencl is working with the AMDgpu pro libraries... Solves my mining issues. Wolf amd miner gives me 750 H/s on xmr and I can work with cinnamon.

I believe that since the AMDgpu pro module isn't loaded, you don't have it in graphical environment but do have it in console mode.

I don't play games so I have no need for the pro drivers under cinnamon. For mining I do need them and a terminal window is good enough.

Regards
Tony

focamichi
Level 1
Level 1
Posts: 1
Joined: Thu Oct 12, 2017 4:53 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby focamichi » Thu Oct 12, 2017 5:23 pm

I also tried to update kernel to v10 as I saw at AMD site that newest version of driver 17.30 said it supported kernel v10. So I downloaded newest build of that amdgpu-pro driver. That latest version caused problems and didn't work with any kernel. "X-server not running" ... "unable to start graphical interface" and so on. My GPU is R9 390.

Until this bad update I was running kernel 4.8.0-58 with amdgpu-pro-17.30-458935 and that is a working combination. From my experience the driver 17.30 build 458935 is the last one that will work. Build 46xxxx will cause problems.

I have this driver 17.30 build 458935 stored here in safe. If it's difficult to find this version online anymore, I could send it to you some way (about 400MB package).

murilolocatelli
Level 1
Level 1
Posts: 1
Joined: Tue Oct 17, 2017 8:53 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby murilolocatelli » Tue Oct 17, 2017 9:01 am

On the site there isn't 16.30 version, only version 16.40: amdgpu-pro-16.40-348864.tar.xz

I tried with this driver, I followed all the steps, but at the time of running the installation script there was no error and no installation messages.

Can it be a difference in the driver version? Has anyone succeed with this version?

My OS is the Mint 18.2 - Kernel 4.12

Thank you!

User avatar
silfox2000
Level 1
Level 1
Posts: 37
Joined: Fri Sep 08, 2017 8:13 am

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby silfox2000 » Wed Oct 25, 2017 2:41 pm

focamichi wrote:Until this bad update I was running kernel 4.8.0-58 with amdgpu-pro-17.30-458935 and that is a working combination. From my experience the driver 17.30 build 458935 is the last one that will work. Build 46xxxx will cause problems.


After several attempts to install the latest build of the amdgpu-pro 17.30 driver, I downloaded what you recommended - build 458935 from here: https://www.touslesdrivers.com/index.ph ... _langue=en
With this build I was able to install the amdgpu-pro driver on Mint 18.2 with kernel 4.13.

rvpanoz
Level 1
Level 1
Posts: 5
Joined: Mon Nov 13, 2017 6:36 pm

Re: Get AMD drivers on Mint 18 [ONLY FOR R7, R9, OR RX CARDS]

Postby rvpanoz » Mon Nov 13, 2017 10:50 pm

hello

i followed the same procedure but i have serious problems.. I explain my situation viewtopic.php?f=59&t=257209&p=1387908#p1387908

if anyone can help me..


Return to “Graphic Cards & Monitors”