The mdm login screen not displayed on monitor connected via DisplayPort

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
chrisra
Level 1
Level 1
Posts: 28
Joined: Wed Dec 30, 2015 1:39 pm

The mdm login screen not displayed on monitor connected via DisplayPort

Post by chrisra » Wed Feb 08, 2017 9:30 am

Hi everybody,

I'm using a Dell XPS13 with Mint 17.3, Cinnamon 2.8.8. I have an external monitor connected to my laptop's mini-DisplayPort with a VGA adapter. I then close the laptop so the built-in monitor is turned off and I only use the external one.
Now the mdm login screen and also text terminals (tty1-6) are not displayed on that monitor, instead on my laptop's own, which isn't much use when it's closed. What's going wrong here? Is that something I can configure differently or is it a hardware support issue? Thanks a bunch for your help!

xrandr -q

Code: Select all

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 32767 x 32767
eDP1 connected (normal left inverted right x axis y axis)
   3200x1800      60.0 +
   2048x1536      60.0  
   1920x1440      60.0  
   1856x1392      60.0  
   1792x1344      60.0  
   1920x1200      60.0  
   1920x1080      59.9  
   1600x1200      60.0  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
DP1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.8  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        60.0  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Xorg.0.log when connecting the monitor, closing the laptop:

Code: Select all

[269924.368] (II) intel(0): resizing framebuffer to 1920x1200
[269924.368] (II) intel(0): switch to mode 1360x768@59.8 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[269924.385] (II) intel(0): switch to mode 1920x1200@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[269925.508] (II) intel(0): switch to mode 1920x1200@60.0 on DP1 using pipe 1, position (0, 0), rotation normal, reflection none
[269928.506] (II) intel(0): switch to mode 1920x1200@60.0 on DP1 using pipe 0, position (0, 0), rotation normal, reflection none
Xorg.0.log when switching to a text terminal, then switching back:

Code: Select all

[275447.746] (II) AIGLX: Suspending AIGLX clients for VT switch
[275486.075] (II) AIGLX: Resuming AIGLX clients after VT switch
[275486.075] (II) intel(0): switch to mode 1920x1200@60.0 on DP1 using pipe 0, position (0, 0), rotation normal, reflection none
For the sake of completeness, inxi -Fxz:

Code: Select all

System:    Host: simmel Kernel: 3.19.0-22-generic x86_64 (64 bit gcc: 4.8.2) Desktop: Cinnamon 2.8.8 (Gtk 3.10.8)
           Distro: Linux Mint 17.3 Rosa
Machine:   System: Dell product: XPS 13 9343
           Mobo: Dell model: 0310JH v: A00 Bios: Dell v: A05 date: 07/14/2015
CPU:       Dual core Intel Core i7-5500U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9577
           clock speeds: max: 3000 MHz 1: 2950 MHz 2: 2935 MHz 3: 2954 MHz 4: 2975 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1200@60.0hz
           GLX Renderer: Mesa DRI Intel Broadwell GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Card-3 Logitech Headset H340 driver: USB Audio usb-ID: 001-059
           Sound: Advanced Linux Sound Architecture v: k3.19.0-22-generic
Network:   Card: Broadcom BCM4352 802.11ac Wireless Network Adapter driver: wl bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 512.1GB (84.4% used) ID-1: /dev/sda model: SAMSUNG_SSD_PM85 size: 512.1GB temp: 0C
Partition: ID-1: / size: 46G used: 20G (46%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 424G used: 384G (96%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 69.0C mobo: 25.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 246 Uptime: 5 days Memory: 4720.1/7515.5MB Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28
Edit: After making this post I searched some more and found previous submissions of the same problem. My mistake was not noticing that "mdm" is filtered out by the search!
viewtopic.php?f=208&t=199665 (Mint 17.2, 2015, not resolved)
viewtopic.php?f=90&t=130641 (Mint 15, 2013, not resolved)

More interestingly, there is a longer discussion for a user having the opposite issue (second monitor only works before login), and finally solving it:
viewtopic.php?f=59&t=195114
I'll compare and see if I can find a solution.

User avatar
roblm
Level 9
Level 9
Posts: 2761
Joined: Sun Feb 24, 2013 2:41 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by roblm » Wed Feb 08, 2017 3:07 pm

chrisra wrote:More interestingly, there is a longer discussion for a user having the opposite issue (second monitor only works before login), and finally solving it:
viewtopic.php?f=59&t=195114
I'll compare and see if I can find a solution.
That topic doesn't pertain to your problem. First you should open System Settings > Display and be sure the checkbox next to Mirror Displays is marked. If it already is, then check the info in this topic:

viewtopic.php?f=59&t=226974

User avatar
chrisra
Level 1
Level 1
Posts: 28
Joined: Wed Dec 30, 2015 1:39 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by chrisra » Wed Mar 01, 2017 6:21 am

roblm wrote:First you should open System Settings > Display and be sure the checkbox next to Mirror Displays is marked.
Hi robim, thank you for this hint! Indeed if I turn on "mirror displays" the text terminal is displayed. (I haven't been able to test it for the mdm login screen yet.) Also when I enable mirroring, the physical screen is still off - which I can check by lifting the lid only a little bit.

So the question is, how do I make this the default? When I connect the laptop and close it, the setting it choses is to have only the main screen on, and the external one off, but not mirrored.

User avatar
roblm
Level 9
Level 9
Posts: 2761
Joined: Sun Feb 24, 2013 2:41 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by roblm » Wed Mar 01, 2017 12:28 pm

chrisra wrote:When I connect the laptop and close it, the setting it choses is to have only the main screen on, and the external one off, but not mirrored.
I don't understand how you can connect the laptop. Do you mean when you connect the external monitor and then close the laptop lid, then the laptop's screen is still on but the external monitor's screen turns off? But that doesn't make sense because you said just the opposite in your first post, that the laptop's screen turns off after closing the laptop lid and the external monitor is on?

Open the File Manager and go to /home/your-user-name/.config and post the contents of the monitors.xml file.

User avatar
chrisra
Level 1
Level 1
Posts: 28
Joined: Wed Dec 30, 2015 1:39 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by chrisra » Thu Mar 02, 2017 8:18 am

roblm wrote:
chrisra wrote:When I connect the laptop and close it, the setting it choses is to have only the main screen on, and the external one off, but not mirrored.
I don't understand how you can connect the laptop. Do you mean when you connect the external monitor and then close the laptop lid, then the laptop's screen is still on but the external monitor's screen turns off
Sorry, that was a typo! I meant to write "internal". Thanks for your patience! I've attached monitors.xml below. It doesn't change when I choose "mirror" in the Display configuration dialog (and "keep this configuration"). Interestingly, next time I open that dialog the option "mirror" is not selected anymore, but the behaviour is still fixed.

Code: Select all

<monitors version="1">
  <configuration>
      <clone>yes</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1680</width>
          <height>1050</height>
          <rate>60</rate>
          <x>0</x>
          <y>15</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="DP1">
          <vendor>ITE</vendor>
          <product>0x6512</product>
          <serial>0x00000000</serial>
          <width>1680</width>
          <height>1050</height>
          <rate>60</rate>
          <x>3200</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>no</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="DP1">
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>yes</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1024</width>
          <height>768</height>
          <rate>60</rate>
          <x>0</x>
          <y>20</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="DP1">
          <vendor>???</vendor>
          <product>0x0000</product>
          <serial>0x00000000</serial>
          <width>1024</width>
          <height>768</height>
          <rate>60</rate>
          <x>1024</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>yes</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>0</rate>
          <x>1920</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="DP1">
          <vendor>SAM</vendor>
          <product>0x0586</product>
          <serial>0x4d593234</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
</monitors>

User avatar
roblm
Level 9
Level 9
Posts: 2761
Joined: Sun Feb 24, 2013 2:41 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by roblm » Thu Mar 02, 2017 3:29 pm

I assume you want both screens mirrored at 1920x1200 because that's what is shown in the last configuration change made in System Settings > Display. Previously you have used 1680x1050 and 1024x768.

The monitors.xml file is misconfigured. Go to /home/your-user-name/.config and delete it. A new one will be created later. Open System Settings > Display and set the screens to be mirrored. Then use this command in the Terminal to open the Default file:

Code: Select all

gksudo xed /etc/mdm/Init/Default
Add this command at the bottom, just above the last line that says "exit 0".

Code: Select all

xrandr --output eDP1 --mode 1920x1080 --primary --output DP1 --same-as eDP1

Test by logging out and back in.

User avatar
chrisra
Level 1
Level 1
Posts: 28
Joined: Wed Dec 30, 2015 1:39 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by chrisra » Mon Mar 13, 2017 6:25 am

Porbably that messed-up monitors.xml comes from when I used xrandr to add a resolution for my screen that didn't exist before. (Burdened with a high-DPI display...) Now I followed your instructions, but then I again had to set the resolution for the laptop's display, because it went back up to 3200x1800. Now again the "mirror" box doesn't stay ticked, but contrary to before I can't show the TTY on my external display even after trying to make that setting.
I think I'll try to figure this out myself, at least now I know that monitors.xml exists.
(Here is now:

Code: Select all

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="DP1">
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>yes</clone>
      <output name="eDP1">
          <vendor>SHP</vendor>
          <product>0x1421</product>
          <serial>0x00000000</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>0</rate>
          <x>1920</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="DP1">
          <vendor>SAM</vendor>
          <product>0x0586</product>
          <serial>0x4d593234</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="HDMI1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
</monitors>
)

User avatar
roblm
Level 9
Level 9
Posts: 2761
Joined: Sun Feb 24, 2013 2:41 pm

Re: The mdm login screen not displayed on monitor connected via DisplayPort

Post by roblm » Mon Mar 13, 2017 12:40 pm

Since the two displays are not being configured correctly, it may be easier to use this method. First remove the xrandr command added to the /etc/mdm/Init/Default file. Then create two desktop launchers. The command used for the first will be:

Code: Select all

xrandr --output eDP1 --mode 1920x1080 --primary

That launcher is activated if the laptop's resolution is 3200x1800 when you get to the desktop. When you need to switch to the external monitor, turn it on and activate the second launcher, which is using this command. Then close the laptop's lid:

Code: Select all

xrandr --output DP1 --mode 1920x1080 --primary

When creating each launcher, mark the checkbox next to "Launch in Terminal?", and when you right click on the launcher and select Properties > Permissions, the checkbox next to “Allow executing file as a program” should be marked.

Post Reply

Return to “Graphics Cards & Monitors”