Weird "jello" effect when scrolling web pages, LM + Mate

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
yogi799
Level 1
Level 1
Posts: 37
Joined: Tue Feb 28, 2017 5:38 pm

Weird "jello" effect when scrolling web pages, LM + Mate

Post by yogi799 » Sun Mar 12, 2017 12:00 am

It is nearly impossible to shoot a video of it probably because of the low Frame Per S rate on phones. It is basically a bit like a jello effect, except not horizontal but vertical, visible only when scrolling long web pages in Chrome or Firefox. Because browsers scroll very smoothly overall, it is terribly annoying and very visible. Sort of like as if a small part of the screen got hung up by a small fraction of a second during scrolling and then tried to catch up with the rest of the scrolling screen. Not visible in Libre Writer or PDF viewers because they jump lines rather than scrolling smoothly, so no issue there.

This is on LM with mate, both Chrome and FF. I have Ubuntu running on the same system and in Unity, scrolling is perfect (Chrome, and I presume other browsers too... after seeing Chrome's results I did not bother testing more), but here is the thing: I also installed xfce desktop on the same Ubuntu install and in it, Chrome also shows the same symptom! So Unity is the only one so far that does not display that symptom out of the three.

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by DeMus » Sun Mar 12, 2017 2:44 am

Open Chrome (or Firefox) settings and switch off smooth scrolling.
In Chrome you type: about:flags in the addressbar. When the page has loaded scroll down a bit till you see the item smooth scrolling. Here it is item 22 in the long list.
I expect Firefox to have something similar but I don't use that. Maybe it is even in the normal settings.
Short Google search an I found this:

Code: Select all

If you're a Firefox user, there's a way to make scrolling more pleasant:

1. Start Firefox.

2. Click Tools, Options.

3. Click the Advanced icon, then look in the Browsing section.

4. Enable Use smooth scrolling, then click OK.

Now try scrolling with your wheel. Much smoother, no? Your mileage may vary, but I find this a much better way to scroll in Firefox.
You would of course not enable but disable it.

yogi799
Level 1
Level 1
Posts: 37
Joined: Tue Feb 28, 2017 5:38 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by yogi799 » Sun Mar 12, 2017 3:00 am

OK, sure, but now scrolling is even worse. Not smooth at all (duh...).

... and I think some remnants of that effect are still there. Of course it is hard to tell since scrolling now looks bad anyway.

Any idea why Ubuntu/Unity works flawlessly on the same setup? Something vastly improved in Unity as compared to other GUI's?

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by DeMus » Sun Mar 12, 2017 3:04 am

yogi799 wrote:OK, sure, but now scrolling is even worse. Not smooth at all (duh...).

... and I think some remnants of that effect are still there. Of course it is hard to tell since scrolling now looks bad anyway.

Any idea why Ubuntu/Unity works flawlessly on the same setup? Something vastly improved in Unity as compared to other GUI's?
No idea, I left Ubuntu when they invented Unity cause I don't want that.
No, when you switch off smooth scrolling, scrolling is no longer smooth. That's the whole idea. You either choose this or that.
There are program which can record your desktop, like a movie. Maybe you can make something like that to show us what is the trouble you are having. Simplescreenrecorder should be able to that. See if you've got that in the repos. I use Manjaro Linux so I have different repos.

yogi799
Level 1
Level 1
Posts: 37
Joined: Tue Feb 28, 2017 5:38 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by yogi799 » Sun Mar 12, 2017 3:25 am

OK, thanks. Yeah, I dislike Unity as well. I am on Mate for one reason... same layout as Windows LOL (and I work on all three platforms, Win, Mac and Linux).

Let me find some time to commit to this issue. Not urgent. I will reply again once I get a video sample.

yogi799
Level 1
Level 1
Posts: 37
Joined: Tue Feb 28, 2017 5:38 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by yogi799 » Tue Mar 14, 2017 11:06 pm

OK, this is the video. You can kind of see the weird effect. So annoying. The background information is in the first post.

https://www.youtube.com/edit?video_id=s ... rrer=watch

yogi799
Level 1
Level 1
Posts: 37
Joined: Tue Feb 28, 2017 5:38 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by yogi799 » Tue Mar 14, 2017 11:32 pm

**UPDATE**

I have noticed that this is not only happening in web browsers. Thunderbird mail preview does the same thing.

Is this some issue with my video driver? Again, Ubuntu with Unity on the same laptop does not display that problem. But Ubuntu with xfce desktop does.

User avatar
roblm
Level 9
Level 9
Posts: 2765
Joined: Sun Feb 24, 2013 2:41 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by roblm » Fri Mar 17, 2017 11:03 am

1. Did you try using a different Window Manager. Go to Preferences > Desktop Settings > Windows > Window Manager. Change the default setting to Marco + Compton, Compiz and others.

2. In Preferences > Windows, you can test marking and unmarking the checkbox next to Enable software compositing window manager.

3. Try using the 4.8 kernel in Update Manager > View > Linux kernels.

4. Turn off hardware acceleratation in Firefox and Chrome.

5. Try using the parameter intel_iommu=igfx_off on the kernel command-line. I assume you already know how to do that from similar testing in your other recent topic but here are the instructions.

At the GRUB boot menu select the correct line but don’t press Enter. Press the “E” key to edit. If no menu shows then hold down the Shift key while starting. Using the arrow keys, go down to the line that starts with: linux /boot/vmlinuz............ro quiet splash $vt_handoff

Add a space to the end of the line and add the parameter: intel_iommu=igfx_off
Press F10 to start your system. If that helps, then make the change permanent. Use this command to open the grub file:

Code: Select all

gksudo xed /etc/default/grub
Change this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
To this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_iommu=igfx_off"
Then use this command to update grub:

Code: Select all

sudo update-grub

danindenver
Level 1
Level 1
Posts: 4
Joined: Sat Jan 12, 2013 2:48 pm

Re: Weird "jello" effect when scrolling web pages, LM + Mate

Post by danindenver » Sun Dec 03, 2017 8:07 pm

Did you ever find a solution to this?

Is it possible that you had Wobbly Windows turned on in Compiz?

Post Reply

Return to “Graphics Cards & Monitors”