Display Port not working

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Aeducan
Level 1
Level 1
Posts: 1
Joined: Wed Apr 19, 2017 9:23 pm

Display Port not working

Post by Aeducan » Wed Apr 19, 2017 9:27 pm

I have 2 4K monitors connected and run them both through displayport cables. I had to dig up a HDMI cable to get one monitor to work and am not sure what I need to do to get my dual monitor set-up to work at 4k. Thanks in advance

MichaBit
Level 1
Level 1
Posts: 3
Joined: Thu Apr 27, 2017 9:24 am

Re: Display Port not working

Post by MichaBit » Thu Apr 27, 2017 9:55 am

Ive got the same Problem and do not find a solution on Zotac ZBOX CI323 nano.
If connecting to DP, Mint freezes. :(
Also tested on Debian Stretch and Ubuntu Mint 17.04 with the only difference, that Ubuntu mostly not freezes and detects the monitor in settings, but no screen.

To follow the instructions in attached link was good for Mint but unfortunately no screen on DP as before.

https://unix.stackexchange.com/question ... ux-mint-18

German: http://knud.aquarius.uberspace.de/wordp ... tallieren/

Edit: i have to use an DP --> HDMI adapter cause none of my two monitors has an DP port.
# Im not willing to install Windows 4 testing DP.
All suggestiöns to get DP running @Mint are very welcome - i dont like VGA.^^

jdrobinson314
Level 1
Level 1
Posts: 1
Joined: Tue Jun 13, 2017 8:59 pm

Re: Display Port not working

Post by jdrobinson314 » Tue Jun 13, 2017 9:15 pm

I'm here with the same issue.

I have a zotac ci323 also and cannot seem to get any displayport output. I can get HDMI to output at 4k30hz though. Hotplugging dp just seems to cause a crash of the login manager and I have to ctrl+alt over to a tty to log in and do a safe shutdown or reboot from an hdmi or vga connection.

So far I have found no kernel flags like nomodeset in grub that could be causing problems.

Running linux mint 18.1 xfce, fully updated with the exception of the latest red level kernel.

zebbeman
Level 1
Level 1
Posts: 1
Joined: Wed Oct 17, 2018 7:35 am

Re: Display Port not working

Post by zebbeman » Wed Oct 17, 2018 7:39 am

I have the same issue with 17.3 and I dual boot with Windows 7 so I can confirm that it works on Windows 7 on the same machine.

I know this is an old post, but switching to nvidia’s prop drivers fixed it for me

Post Reply

Return to “Graphics Cards & Monitors”