3 monitor display on Mint 18.2 from ASUS Nvidia gt730 2g ddr5

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
steveadoo
Level 1
Level 1
Posts: 3
Joined: Tue Jul 25, 2017 9:56 am

3 monitor display on Mint 18.2 from ASUS Nvidia gt730 2g ddr5

Post by steveadoo » Tue Jul 25, 2017 11:05 am

Hello everyone,

I've looked about a number of forums and tried a number of things but can't seem to crack this problem.

I have Linux MInt 18.2 64 bit (kernel 4.10.0-27) installed with cinnamon and dual boot with Windows 10 with an ASUS Nvidia gt730 2gb ddr5 GPU on an ASRock H270 Performance Motherboard. My full system info is:

System: Kernel: 4.10.0-27-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.4 (Gtk 3.18.9-1ubuntu3.3) dm: mdm Distro: Linux Mint 18.2 Sonya
Machine: Mobo: ASRock model: H270 Performance Bios: American Megatrends v: P2.10 date: 05/12/2017
CPU: Quad core Intel Core i7-7700K (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 33600
clock speeds: min/max: 800/4500 MHz 1: 799 MHz 2: 799 MHz 3: 799 MHz 4: 799 MHz 5: 799 MHz
6: 799 MHz 7: 800 MHz 8: 799 MHz
Graphics: Card-1: Intel Device 5912 bus-ID: 00:02.0 chip-ID: 8086:5912
Card-2: NVIDIA GK208 [GeForce GT 730] bus-ID: 01:00.0 chip-ID: 10de:1287
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
GLX Version: 3.0 Mesa 17.2.0-rc1 Direct Rendering: Yes


My ideal desktop is on 3 displays- HDMI connected Samsung monitor on my desktop, a smart TV on the other side of the room via VGA and an Epsom monitor. My desktop monitor should be my main display with everything always showing up on it as the other two outputs won't always be turned on during a session. I can get this extended desktop scenario to work no problems with windows 10 and if I jump through a bunch of hoops every session I can make it work on Mint as well, but if I restart it all falls apart.

I'll talk you through the 'hoops'.

I set my motherboard to read the onboard graphics output, plug my HDMI desktop monitor into it and log into Linux. I can only see the HMDI connection in display and xrandr so, then I have to edit the line in xorg.conf:

Option "IgnoreDisplayDevices" "CRT" with a # to disable it.

I restart cinnamon and I can see my 2 monitors attached via VGA in both the display settings for cinnamon and the Nvidia control panel. As the HDMI connected 'main' monitor (the one I want to be my primary) is still connected to the onboard graphics it is labelled as 'Prime' in the Nvidia controls and can't be adjusted there.

So, I unplug from the onboard graphics and into the HDMI output on the GPU and voila- all three monitors are in the Nvidia control panel. I can adjust their position and resolution to my hearts content, set my primary monitor as the HDMI connection, get everything looking all perfect (except my conky widget is on the wrong display- a smaller problem for now) and then save the settings from the Nvidia contrl panel to merge with xorg.conf. I check /etc/X11/xorg.conf and sure enough it has been merged and saved ok.

So now that all displays are running from the GPU I shut the computer down. I change the HDMI back into the onboard output and boot into BIOS to adjust the preference from onboard to PCIe graphics and shut down again. Change the HDMI back again into the GPU output and when I boot up into GRUB, it is on my VGA connected TV only (this is because it is the leftmost connection on the GPU and is the default primary) I select Mint from the bootloader and again the screen is only on the TV and cinnamon starts in Graphics rendering mode. When I look for the xorg.conf file I checked was present before, it has been changed to xorg.conf.072562017 and there is no xorg.conf present.

As I said, it works no problem in Windows and I know it will work in Mint too as I can get it there albeit after a fair process that I'd obviously like to avoid doing every session in Mint.

Any help would be extremely well received!

Thanks

User avatar
roblm
Level 9
Level 9
Posts: 2793
Joined: Sun Feb 24, 2013 2:41 pm

Re: 3 monitor display on Mint 18.2 from ASUS Nvidia gt730 2g ddr5

Post by roblm » Sun Jul 30, 2017 10:35 am

From your inxi output, it appears there is no Nvidia driver installed. How are you able to open the Nvidia control panel (NVIDIA X Server Settings)?

Here's what I suggest. At the desktop, use this command to rename the xorg.conf file to xorg.conf.old:

Code: Select all

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
Reboot, enter the BIOS and change the primary display device to PCIe graphics, if it's not already set.
Shut off the PC and connect all 3 monitors to the Nvidia card. Start the PC and at the desktop go to Preferences > Display and arrange the 3 displays correctly. Then click Apply.

Post Reply

Return to “Graphics Cards & Monitors”