Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
User avatar
UltraViolence
Level 1
Level 1
Posts: 20
Joined: Sat Nov 19, 2016 1:18 pm
Location: Heck

Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by UltraViolence » Fri Aug 04, 2017 1:26 pm

I have to use fglrx for accelerated video decoding. I inherited a supposedly 120hz TV that is EDID locked to 60hz on HDMI and VGA inputs.

In windows over VGA I was already able to do 720P 75hz and 85hz. I can't really go higher because of VGA limitations and I don't have a windows machine with HDMI output. I'd like to test 75-120hz at 1080P on my linux machine but despite AMD control panel reporting max refresh rate of 75hz the settings will not allow >60. Xrandr claims 60+ on many resolutions.

First thing, tried adding 1920x1080_75 with xrandr and it errors. Tried adding ignore DCC and ignore edid to xorg.conf and no dice. The AMD control panel will allow setting a custom resolution but doesn't allow changing the refresh rate.

Anyone know how to test this? I don't know for a fact 120hz or anything really above 75 will be supported. I have to try and hope for the best... linux graphic stack is not making it easy. I have DP to HDMI cables on order if all else fails.

User avatar
UltraViolence
Level 1
Level 1
Posts: 20
Joined: Sat Nov 19, 2016 1:18 pm
Location: Heck

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by UltraViolence » Thu Aug 10, 2017 6:01 pm

I have tested the monitor on windows and it supports 120hz no problem. When I hit the "display" button on the remote 120hz is there.

In mint I added a "1920x1080R" mode that was generated via cvt -r 1920 1080 120. aticonfig --initial has copied this into xorg.conf but the monitor is still stuck at 60hz.

I even have looser hsync and vsync values in the xorg.conf. What is going on? Is there another way to override? Card is an HD 7000 caicos model so it should support 120hz without issue too. Fglrx is refusing to go outside the edid info.

Xorg log : https://pastebin.com/S4AZmCfg
Xorg conf file: https://pastebin.com/tDniqgPG

User avatar
roblm
Level 9
Level 9
Posts: 2827
Joined: Sun Feb 24, 2013 2:41 pm

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by roblm » Fri Aug 11, 2017 8:59 am

UltraViolence wrote:I have tested the monitor on windows and it supports 120hz no problem. When I hit the "display" button on the remote 120hz is there.
If you have a Windows system and you have tested the monitor works at the 120 Hz refresh rate, then install the AMD EDID Utility to get the monitors's EDID. Download the Windows version from here: http://developer.amd.com/amd-edid-utility/

Run the program and save the EDID to a file named edid.bin. Transfer this to the Linux system, to your Home directory (/home/user-name). Use this command to install the program edid-decode:

Code: Select all

sudo apt install edid-decode
Then use this command in the Terminal and post the output:

Code: Select all

edid-decode edid.bin

User avatar
UltraViolence
Level 1
Level 1
Posts: 20
Joined: Sat Nov 19, 2016 1:18 pm
Location: Heck

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by UltraViolence » Fri Aug 11, 2017 6:22 pm

That won't work because the best timing in the edid is 60hz. The original is even inside my x log.

I thought of doing this:http://hotcashew.com/2013/08/fixing-inv ... wit-fglrx/

I still have to add 120hz to whatever I copy and that is where I'm not sure how to proceed.
The manufacturer was just a prick and left 120hz to be done by the display's processor, there is even a setting for it, 120hz low, med, high. But I don't want fake "motion enhancement" on a real 120 panel.

User avatar
roblm
Level 9
Level 9
Posts: 2827
Joined: Sun Feb 24, 2013 2:41 pm

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by roblm » Sat Aug 12, 2017 1:46 pm

I was exploring the possibility of the fglrx driver not being able to read the complete EDID of the Sharp TV, for various reasons. I wanted to compare that EDID with the EDID being read by the graphics driver in Windows.

User avatar
UltraViolence
Level 1
Level 1
Posts: 20
Joined: Sat Nov 19, 2016 1:18 pm
Location: Heck

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by UltraViolence » Sat Aug 12, 2017 5:11 pm

Nope, sadly its all there.

User avatar
roblm
Level 9
Level 9
Posts: 2827
Joined: Sun Feb 24, 2013 2:41 pm

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by roblm » Sat Aug 12, 2017 8:02 pm

I assume you converted both EDIDs to readable text by using a program such as parse-edid or edid-decode.

If the fglrx driver was forced not to read the TV's EDID, then it could be forced to use the Modeline in the xorg.conf file, but this warning line from the log file shows the line Option "IgnoreEDID" is not being read:

Code: Select all

[  3829.400] (WW) fglrx(0): Option "IgnoreEDID" is not used
If you want to do some experimenting, then you could try creating a custom EDID containing just the 1920x1080@120 mode using the Custom Resolution Utility in your Windows system. You can get it from majorgeeks.com:

http://www.majorgeeks.com/files/details ... ility.html

The picture below shows the program opened:
cru-1.png
Remove all of the other resolutions and under the Standard resolutions window, click Add. Select the 1920x1080 resolution and type 120 in the Refresh Rate window. The custom mode will be added as seen below:
cru-2.png
Then click Export. Save the file as edid.bin. Transfer that file to the Mint installation. Below is the extracted contents of a custom EDID I created with only a 1280x1024@120 mode listed. Of course I could not really use it because it's not supported:

Code: Select all

edid-decode edid.bin
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   1e 6d 86 4b 00 00 00 00 04 13
version:         01 03
basic params:    80 26 1e 78 ea
chroma info:     32 31 a3 57 4c 9d 25 11 50 54
established:     00 00 00
standard:        81 bc 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    00 00 00 fc 00 4c 31 39 34 32 0a 20 20 20 20 20 20 20
descriptor 2:    00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00
descriptor 3:    00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00
descriptor 4:    00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00
extensions:      00
checksum:        cc

Manufacturer: GSM Model 4b86 Serial Number 0
Made week 4 of 2009
EDID version: 1.3
Digital display
Maximum image size: 38 cm x 30 cm
Gamma: 2.20
DPMS levels: Standby Suspend Off
Supported color formats: RGB 4:4:4, YCrCb 4:2:2
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
  1280x1024@120Hz
Monitor name: L1942
       Dummy block
Dummy block
Dummy block
Checksum: 0xcc
EDID block does NOT conform to EDID 1.3!
	Missing preferred timing
	Missing monitor ranges
Get the name of the connected output, which is DFP1 in your case. Change the name of the edid.bin file to DFP1.edid and add it to /etc/ati. Log out and back in. If successful, the Xorg.0.log file will show a line similar to this:

Code: Select all

[   616.610] (II) fglrx(0): Successfully loaded EDID override file - /etc/ati/DFP1.edid - bytes:256

User avatar
UltraViolence
Level 1
Level 1
Posts: 20
Joined: Sat Nov 19, 2016 1:18 pm
Location: Heck

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by UltraViolence » Sun Aug 13, 2017 2:58 pm

That is what I was looking for. Unfortunately Xorg says no usable modes found. So maybe a GPU or AMD driver issue?

User avatar
roblm
Level 9
Level 9
Posts: 2827
Joined: Sun Feb 24, 2013 2:41 pm

Re: Amd Proprietary (FGLRX) Above 60hz on Mint 17.3

Post by roblm » Sun Aug 13, 2017 8:21 pm

I forgot to mention this, in case you didn't do it, but you have to use your xorg.conf file at the same time, which will list the vertical and horizontal frequency ranges to be used. Also, after logging out and back in, check in Preferences > Display for any new modes.

The TV's EDID lists a maximum supported dotclock of 150 MHz, which seems low. If it's correct, then that may be the limiting factor:
Extracted contents:
Manufacturer: SHP Model 3488 Serial Number 16843009
Made week 41 of 2012
EDID version: 1.3
Digital display
Maximum image size: 110 cm x 62 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4, YCrCb 4:2:2
First detailed timing is preferred timing
Established timings supported:
1024x768@60Hz
1024x768@70Hz
1024x768@75Hz
Standard timings supported:
Detailed mode: Clock 148.500 MHz, 930 mm x 523 mm
1920 2008 2052 2200 hborder 0
1080 1084 1089 1125 vborder 0
+hsync +vsync
Monitor name: LC-50LE650U
Monitor ranges: 23-76HZ vertical, 15-81kHz horizontal, max dotclock 150MHz
Dummy block
Has 1 extension blocks
Checksum: 0x31
At 120 Hz, the dotclock is 285.2 MHz, actually should be 285.25, which greatly exceeds 150 MHz.
ModeLine "1920x1080R" 285.2 1920 1968 2000 2080 1080 1083 1088 1144 +hsync -vsync


In previous testing I've done, the fglrx driver would not use a reduced blanking mode created by the cvt tool. Try testing these reduced blanking modes created with umc (universal modeline calculator), at 75 Hz and 85 Hz, but the dotclocks still exceed the 150 MHz limit. You can try them with and without new EDIDs created with the Custom Resolution Utility.

Code: Select all

Modeline "1920x1080_85.00"  198.50  1920 1968 2000 2080  1080 1083 1087 1124  +HSync -VSync
Modeline "1920x1080_75.00"  174.50  1920 1968 2000 2080  1080 1083 1087 1119  +HSync -VSync
Also change the Option "PreferredMode" and Modes lines in the xorg.conf file. For example:

Code: Select all

Option "PreferredMode" "1920x1080_85.00"
Modes "1920x1080_85.00"
If there is a problem getting back to the desktop, then press Ctrl+Alt+F1 to enter the virtual console tty1. Login and then type this command to remove the xorg.conf file:

Code: Select all

sudo rm /etc/X11/xorg.conf
Then type: sudo reboot

Post Reply

Return to “Graphics Cards & Monitors”