<SOLVED> Dark (oversaturated) UI elements, except nemo

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
pablo89pl
Level 1
Level 1
Posts: 4
Joined: Fri Oct 20, 2017 3:24 pm

<SOLVED> Dark (oversaturated) UI elements, except nemo

Postby pablo89pl » Fri Oct 20, 2017 3:46 pm

Hello, I have a problem,
Since a week all icons and UIs are darkened than before, looks like oversaturated (please look in the picture, this is not theme issue, doesnt matter which theme I use)

Image
Image
Most of third-party software looks OK
Menu in Nemo is too dark too, all windows popups...


It looks like driver issue, maybe gtk? I try to update very frequently...
In all updated I had among others: mesa-va-drivers, libdrm-radeon1 (I dont know why this is on my system when I have intel graphic card), libglapi-mesa, libwayland-egl1-mesa, libgles2-mesa, xserver-common and related)
Linux Mint 18.2, Cinnamon, kernel 4.10 (same 4.11 and 4.8 )
Last edited by pablo89pl on Tue Oct 24, 2017 10:56 am, edited 1 time in total.

User avatar
karlchen
Level 17
Level 17
Posts: 7950
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Dark (oversaturated) UI elements, except nemo

Postby karlchen » Fri Oct 20, 2017 4:11 pm

Hello, pablo89pl.

Maybe in your case the changed screen colours are really caused by software.
Yet, it might be worth the time to check out with a different monitor. Means attach an external monitor and check whether colours are back to what they were before.
It happened here to my external monitor:
One fine evening some months ago, all colours were still fine. Next day, when I switched on the same Mint system, light gray colour had turned into pink. Pink! Just imagine. Everything which should be light gray is pink.
For the past few months I have been running Linux Mint 17.1 "Girlies Edition". :lol:
It is caused by the VGA connector of the external monitor. (Crosschecked in various ways.)
The machine attached to the DVI-D cable of the same monitor still displays all colours correctly.
Maybe something similar happened in your case as well?

Best regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

pablo89pl
Level 1
Level 1
Posts: 4
Joined: Fri Oct 20, 2017 3:24 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby pablo89pl » Sat Oct 21, 2017 2:10 pm

I use secondary monitor every day - same issue.
This looks like all native UI is too dark, but third party which use probably different ways to draw UI is okay..

ugly
Level 2
Level 2
Posts: 89
Joined: Thu Nov 24, 2016 9:17 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby ugly » Sun Oct 22, 2017 1:36 pm

I think I noticed this too. It happened after installing a lot of updates on a PC that I don't use very often. It was about a week ago as well (but I hadn't run updates in about a month).

I'll post back with some detailed more info later. Off the top of my head, it is a Kaby Lake Intel processor using the on-board graphics. I don't remember the updates that installed, but there were some video-related updates.

pablo89pl
Level 1
Level 1
Posts: 4
Joined: Fri Oct 20, 2017 3:24 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby pablo89pl » Sun Oct 22, 2017 2:30 pm

i have latitude e7440, haswell i7 4600u, intel hd 4400 I believe - if this matter

ugly
Level 2
Level 2
Posts: 89
Joined: Thu Nov 24, 2016 9:17 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby ugly » Mon Oct 23, 2017 5:19 pm

Here's my results from inxi -FxzG

Code: Select all

System:    Host: media-ZBOX Kernel: 4.11.0-14-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 2.24.30) Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: ZOTAC model: ZBOX-CI527/CI547 v: XX
           Bios: American Megatrends v: B331P205 date: 03/15/2017
CPU:       Dual core Intel Core i3-7100U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2400 MHz 1: 817 MHz 2: 499 MHz 3: 499 MHz
           4: 1768 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 driver: N/A Resolution: 1920x1080
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           GLX Version: 3.0 Mesa 17.3.0-devel - padoka PPA Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.11.0-14-generic
Network:   Card-1: Intel Ethernet Connection I219-LM
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-3: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 480.1GB (5.2% used)
           ID-1: /dev/sda model: SanDisk_SDSSDA48 size: 480.1GB
Partition: ID-1: / size: 46G used: 10G (23%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 387G used: 6.3G (2%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 34.5C mobo: 29.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 202 Uptime: 5 min Memory: 849.5/7905.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

ugly
Level 2
Level 2
Posts: 89
Joined: Thu Nov 24, 2016 9:17 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby ugly » Mon Oct 23, 2017 5:39 pm

Just ran some updates again, and it seems back to normal.

pablo89pl
Level 1
Level 1
Posts: 4
Joined: Fri Oct 20, 2017 3:24 pm

Re: Dark (oversaturated) UI elements, except nemo

Postby pablo89pl » Tue Oct 24, 2017 10:55 am

ok, I updated also, and it works...
so one of following packages has been fixed:
Image


Return to “Graphic Cards & Monitors”

Who is online

Users browsing this forum: No registered users and 9 guests