Trouble adding new resolution to display options

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
onpocket
Level 1
Level 1
Posts: 2
Joined: Sat Oct 21, 2017 8:35 am

Trouble adding new resolution to display options

Postby onpocket » Thu Oct 26, 2017 12:00 pm

[Before we start, i'm using Linux Mint 18.2 Sonya]

Hi, i'm posting here because i'm having some trouble adding a new resolution to my screen since i've changed the graphic's card proprietary drivers, from the "xserver-xorf-video-nouveau (open-source)" to the "nvidia-340 (recommended)".

(Please let me know if i'm at the wrong place)

[I've done that because the benchmarks are suppose to be better, and they end up being since my computer does not overheat anymore and streams videos more fluently]

Since i've changed this option i've lost all resolutions options in the display settings as seen on this image . There's a image with description that shows what i'm talking about [at the end of the post there's a link that will take you there] (the only resolution that i've available is 1680x1050).


I've also tried to change some options on "NVIDIA X Server settings", and it gives me several resolution options, as seen on one of the images accessed from the link at the end of the post. However even if i change the resolution settings in this application and click "Apply", i end up having this resolution for only one session (with no problems). So logically i tried to click "Save to X Configuration File" and it works when i restart the computer i get the resolution that i asked for (1440x900 60Hz). BUT here's the problem: when i login i end up having a "picture" with the resolution 1440x900 on a frame of 1680x1050. So i end up having my desktop "floating" on the main frame of 1680x1050. There's an image with description on that link.

With that in mind, i logically assumed that the problem is in the display options that only have 1680x1050 available. So i've followed the following tutorial which teaches how to add a new screen resolution on Linux Mint https://community.linuxmint.com/tutorial/view/877.

When following the tutorial i get this (on the NOTE link).
My system

Code: Select all

inxi -Fxz
(in one of the posts).

NOTE (IMPORTANT): All the images that i took are in here https://imgur.com/a/r5aqx. Only after i had written all this post, was when i realized that the images were too large to upload.
Last edited by onpocket on Wed Nov 01, 2017 6:22 pm, edited 1 time in total.

User avatar
karlchen
Level 17
Level 17
Posts: 7951
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Trouble adding new resolution to display options

Postby karlchen » Sun Oct 29, 2017 4:35 pm

onpocket wrote:Only after i had written all this post, was when i realized that the images were too large to upload.
Only if you should not have found out about the [rimg] button at the top of the forum editor window, next to all the other nifty little buttons there. :wink:

And the screen output of inxi -Fxz (beware: capital F, lowercase x, lowercase z ) does not even need a screenshot, because the output is pure text. It can be marked and copied from the terminal window and pasted here in the forum editor between [code] tags to preserve screen formatting. :D
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

onpocket
Level 1
Level 1
Posts: 2
Joined: Sat Oct 21, 2017 8:35 am

Re: Trouble adding new resolution to display options

Postby onpocket » Sun Nov 05, 2017 11:28 am

Code: Select all

System:    Host: joao-M7X0SU Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: clevo (portable) product: M7X0SU v: Rev. A1
           Mobo: clevo model: M7X0SU v: Bottom
           Bios: Phoenix v: 6.00 date: 11/07/0892
CPU:       Dual core Intel Pentium Dual T3400 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 8668
           clock speeds: max: 2167 MHz 1: 1667 MHz 2: 1667 MHz
Graphics:  Card: NVIDIA G98M [GeForce 9300M GS] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1680x1050@59.88hz
           GLX Renderer: GeForce 9300M GS/PCIe/SSE2
           GLX Version: 3.3.0 NVIDIA 340.102 Direct Rendering: Yes
Audio:     Card Silicon Integrated Systems [SiS] Azalia Audio Controller
           driver: snd_hda_intel bus-ID: 00:0f.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter
           driver: sis190 v: 1.4 port: 1000 bus-ID: 00:04.0
           IF: enp0s4 state: down mac: <filter>
           Card-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter
           usb-ID: 001-002
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 750.2GB (4.5% used)
           ID-1: /dev/sda model: WDC_WD7500BPVT size: 750.2GB
Partition: ID-1: / size: 684G used: 28G (5%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 66M (15%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 50.8C mobo: N/A gpu: 0.0:68C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 11:28 Memory: 2097.2/3948.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


Last bumped by onpocket on Sun Nov 05, 2017 11:28 am.


Return to “Graphic Cards & Monitors”